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67Tutorial Animate your vector artwork

N
ot everyone likes them, but a 
web site’s intro animation can set 
the tone and also be a fantastic 
showcase – especially if the site 

is a web-based art gallery like Graduart.
Graduart focuses on the work of students, 

graduates and post-graduates, and Clusta 
helped develop the brand for the online gallery 
from day one. Clusta began by designing the 

logo, followed by the graphical element, which 
you’ll see represented in this tutorial. The brief 
for this project was simply to be organic, cool 
and fl owing.

This tutorial demonstrates how Clusta 
combined different programs and techniques 
to achieve the transformation from static design 
for print to animation for the web. View the 
fi nished animation at [w] www.grad-u-art.com.

Expertise provided by Clusta, who have worked for companies such as Sony, Orange 
and the BBC across a diverse range of media including websites, intranets, extranets, 
e-fl yers, CDs, videos and print. See more at [w] www.clusta.com.
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68 Tutorial Animate your vector artwork

Plan your attack

When starting a project, 
always have the aim clear in 
your mind. Make sure you’ve 
worked out answers to basic 
questions that may cause 
problems if left too late in the 
process, such as how fast the 
pace should be, or what music 
should be used. Always keep 
the brief clear in you head 
and carefully choose the 
elements that make 
up your design.

Part 1: Creating the elements
First, you need to use Illustrator CS2 to convert all your photographic elements into vectors...

1
In Illustrator CS2 click File>Import, and browse 
to the images you want to use in your project – 

for this tutorial we use fl ower JPEGs. Select your fi le 
and press Open. Then click either of the two 
selection arrows on the main toolbar and click on 
the image to select it. To convert this image to 
vector, click Object>Live Trace>Tracing Options.

2
The Trace Options look daunting but are quite 
straightforward. Click Present, and a dropdown 

menu will appear showing the different trace styles 
you can apply. Select Detailed Illustration. The 
Threshold option enables you to change the contrast 
of your trace depending on the brightness/darkness 
of your image. Click Preview to preview the image. 

3
Move the Trace Options box to one side and 
you’ll notice that the image’s appearance has 

changed to a black-and-white silhouette. Adjust the 
Presets/Threshold until you achieve the desired 
effect. Click Trace to confi rm the settings.

7
Now carefully select each element (in this 
case, each fl ower). Use the Lasso tool on your 

main toolbar to draw around the shape. The item 
within is automatically selected. Separate the 
different elements.

8
With the fl ower selected, click Insert> Convert 
to Symbol. Here the object can be converted to 

a movie, button or graphic symbol so that it can be 
stored in the Movies Library to animate later. Enter 
the name as Flower_01 and under Behaviour click 
on Movie Clip. Repeat the process for each fl ower.

9
Once your elements have been converted to 
movies, click Window>Library. The three 

symbols should be stored for later use. Delete the 
three symbols from the main stage and click 
File>Save, save the movie as Main Animation in a 
new folder called Animation. You now know how to 
covert to vector and prep for animation, so repeat 
the process for the rest of the design elements until 
all elements are ready.

4
Click Object>Live Trace>Expand As Viewed. 
You should now see the image converted into 

separate vector elements and it’s ready to export to 
Flash for fi nal prepping. Click Files>Export, create a 
new folder called Converted Elements and save as 
an SWF (default setting) making it a Flash movie. 
Repeat these fi rst four steps for all your elements.

5
Open Flash and in the bottom middle you’ll see 
a background colour option. Change this to a 

mid-grey (the reason for this will become more 
obvious later on). Click File>Import and select your 
SWF. Click Open. The elements that aren’t needed 
must be edited out. Select all of the image and you’ll 
notice that it’s broken down into lots of little symbols, 
making it easy for you to move or subtract areas.

6
With the Arrow tool selected click on and 
delete the large black background. Then 

delete everything else until you’re left with just 
your main elements (in this case, the three fl owers). 
Click Edit>Select All, then click Modify>Breakapart. 
This allows you to remove the black areas while 
retaining transparent shapes, such as in the white 
area of the fl ower.
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69Tutorial Animate your vector artwork

Client content

All navigation and client 
content has been removed 
from the design in this 
tutorial. Visit the site at 
[w] www.grad-u-art.com 
for a full overview.

Avoid complications

As you may know, Flash is 
foremost a web-design tool, 
but it can also be very useful 
for constructing static 
illustrations. Remember to 
keep your Flash library and 
layers tidy – not naming them 
properly is only going to cause 
problems further down the 
line. If it comes to animating 
300 symbols that you can’t 
fi nd, it’s going to get stressful.

Part 2: Layout and animation
Prepare the Flash movie for the web and lay out all the graphic elements ready for animation...

1
With your Flash fi le open, click Modify> 
Document then select Dimensions. The 

standard should be to accommodate for 600x800, 
but this is a huge 1,200x1,600. Choose Background 
colours. Change your Frame Rate to 30fps to allow 
your animation to run smoother than the standard 
12fps (try it and see the difference).Click OK.

2
Now you can start laying the graphical 
elements out on your stage. Open your Library 

(F11), select all the items in the Library (hold Shift 
then click on the top and bottom item) and drag 
and drop the items on to the stage. You should now 
see all the items bunched up in the middle. 

3
With all the items selected move your mouse 
over them and right-click (Windows) or Ctrl-

click (Mac) to select Distribute To Layers. If you 
look at the timeline on the top left, you’ll see that 
each stage item is now on a layer of its own – this 
will help you with depth arrangement for the layout 
and animation. 

7  We want the symbol animation to start off 
completely transparent and appear to scale up 

and become visual. Select the timeline frame 1 and 
select the symbol on the stage. Click Modify>
Transform>Transform and Scale, change Scale to 
10 per cent, and leave Rotate empty. The symbol 
should now appear smaller on the stage.

8
With the symbol still selected, click Windows> 
Properties. Click the Color menu in the middle 

of the bar and select Alpha. Reduce the slide bar on 
the right to 0 per cent. 

9  Go to frame 5, select the symbol on the stage. 
Click Properties, then click the Color menu and 

select Tint. Change the colour window to 100 per 
cent white. The symbol also needs to be scaled on 
this frame in order to give it a slight bounce. Repeat 
Transform and scale as in Step 7, this time increasing 
to 110 per cent. 

4
Now all you need to do is get your design 
together. (We’ll let you work the details of this 

part out for yourself...!) Once the fi nished design is 
laid out, you need to work backwards and build up 
the animation.

5
Click the Eye symbol just under the timeline to 
turn off all other layers except the one you 

want to work on. On the appropriate layer’s fi rst 
frame, right-click/Ctrl-click to select Create Motion 
Tween and deselect the frame. Notice the frame 
has turned blue to indicate a Tweening action 
(animation action).

6  Select the Tweened frame again and right-
click/Ctrl-click to select Copy Frames, then on 

frame 5 of the timeline right-click/Ctrl-click to select 
Paste Frame. Do the same on frame 8.
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Keep the fl ow

If your animation starts to 
look a little unrealistic in 
terms of its fl ow then have 
a play around with the 
Tweening Ease. You can 
inject a lot of natural 
movement and even gravity 
into your work just by 
tweaking the slide bar up or 
down (see Step 13).

10
In the timeline you’ll notice a red bar – move 
this over frames 1 to 8 to see the symbol 

animate. You can now apply Steps 6 to 9 to the 
other symbols in this sequence, staggering the 
layers over fi ve frames. (Remember to extend the 
frames on the lower layer to the length of the fi nal 
layer in the sequence.)

11
The next symbols to be animated are going to 
need to be masked to give the appearance that 

they gradually fl ow across the screen. Go to the 
beginning of the timeline and select the fi rst frames 
of the three layers and drag the frames along the 
timeline to meet the end of your last sequence.

12
Highlight the layer named Green, click 
Insert>Layer, name the layer Mask Green. On 

frame 104 of this layer right-click/Ctrl-click to select 
Insert Keyframe.

16
Repeat this process for the other symbols, 
staggering the animation over 15 frames to 

add to the dynamic of the animation.

17
The next part of the sequence involves masking 
with multiple different tweens. Drag the fi rst 

frame of your Scribble layer to frame 165. Add a 
Mask layer to it, create a rectangle on that layer and 
convert to a symbol movie called Scribble Mask_01.

18
Remembering to unlock your layers fi rst, 
double-click on the Scribble Mask_01 symbol 

on frame 165. You should now be inside the symbol, 
where you can make your multiple Tweening layers 
act as one mask. Using the Tween>Motion action 
from Step 13, animate the rectangle to cover the 
bottom corner of the scribble symbol.

13
In your main toolbar click the Rectangle tool 
and just to the left-hand edge of the stage 

draw a rectangle (making sure it’s slightly taller than 
the symbol you’re about to mask it with). With the 
same frame highlighted, go to Properties and click 
Tween>Motion, then move the Ease bar to 100 Out 
(this allows the animation to start fast and gradually 
slow down to stop).

14
On frame 165 of the Green Mask layer insert a 
keyframe. Also extend the frames on the Green 

layer to the same length by Insert Frames. Now the 
red rectangle on frame 165 needs to be the same 
length as the symbol on the green layer, so use the 
Transform tool on the main toolbar to resize the 
rectangle to the required length. If you drag the red 
bar in the timeline over these frames, you’ll see the 
rectangle grow.

15
Right-click on the Green Mask layer, click Mask 
and both layers will now appear locked with 

green symbols to the left of them. This means 
they’re part of a masking action – if you move the 
red bar over the animation again, you’ll see that the 
red rectangle has disappeared and is acting as a mask 
for the layer below, giving the impression of growth. 
(To edit the symbols simply unlock the layers.)

Layout and animation continued...
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19
Create a new layer and repeat the process in the 
opposite direction. Continue until the scribble 

symbol is completely covered. Now add a Stop action 
so the animation doesn’t loop throughout the movie. 
Insert a new layer, on the fi nal frame Insert Keyframe, 
and right-click/Ctrl-click to select Action. The Actions 
tag opens at the bottom. In the script box in the 
centre type stop(); and press enter. The letter ‘a’ in 
the keyframe indicates our action. Move the red bar 
over the timeline to see it animate over the scribble.

20
From this point on, you need to animate the 
other elements using techniques we have 

already covered (from Masking to Tweening). Make 
an effort to keep the animation consistent and the 
fl ow smooth, getting you back to the design you 
laid out in Step 4. 

21
All you need to do now is add a fi nishing 
touch: in this case, winding butterfl ies. Insert a 

new layer with a keyframe on the fi nal frame and 
add a Stop action. Drag your butterfl y symbol from 
the Library onto the stage.

4
Select the butterfl y, and right-click/Ctrl-click to 
select Create Motion Tweening. On frame 20 

insert a keyframe and move the butterfl y to the fi rst 
bend of your guide path (rotating it very slightly at 
the end). Repeat the process until the butterfl y 
reaches the end point of the guide. Now move the 
red bar along the timeline to see the animation.

5
You can now apply the same techniques to 
the other two butterfl ies, staggering the 

frames and adding a Stop frame at the end.

6
Now return to the lower level timeline. On the 
last frame don’t forget to add a Stop action. 

Now you can go to Control>Test Movie, sit back 
and watch your animation play. Alternatively, go to 
File>Publish Preview>HTML and watch it in your 
web browser.  ca p

1
Double-click the butterfl y symbol, select the 
butterfl y and convert it to another movie called 

butterfl y 2. Double-click until you’re within that 
symbol. You need to make the wings appear to fl ap, 
so on frame 3 insert a keyframe, select the butterfl y 
on the stage and the Transform tool so you can 
scale the butterfl y, but only width-wise, so the 
butterfl y becomes narrower.

2
Now add an extra frame to the timeline, select 
all the frames and Copy Frames. At the end of 

the frames, Paste Frames in order to repeat the 
process – repeat for around 125 frames. Copy and 
paste the fi rst frame and extend for 30 frames.

3
Go back to the butterfl y 1 symbol where you 
can animate its fl ight path. Select Layer> Add 

Motion Guide. Flash should now have added a new 
layer dedicated to motion paths. In frame 1 of the 
guide layer, use the Pen tool to draw a swirly line to 
represent the journey that your butterfl y will take 
over the distance of the animation.

Don’t give your 

processor problems

If you can manage it, try not 
to have a lot of animation 
running over the same time, 
all bunched up together. 
This will only cause your 
computer to struggle, and 
your animation will appear 
slow and ponderous.

Part 3: Final animated features
Complete your web animation by adding a winding butterfl y...
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