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Tutorial

We get to grips with some of Flash MX’s core tools
– namely the program’s unique drawing features –
and create a zoomable map for a Website

Despite the best efforts of the marketing
people at Macromedia, Flash is still most
famous for its animation capabilities. 
But such perception does it a disservice,
because in Flash MX we have a package
that can do much, much more. It’s a fully-
fledged Web authoring system, complete
with its own programming language and
database connection capabilities. In this
three-part series, we’ll explore the key
features, starting this month with the very
core of the program: its drawing tools.

Vector graphics lie at the heart of Flash.
Although it’s grown into a multimedia
tool that supports bitmap images,
video and sound, vector images are
the glue that holds these cumbersome
components together. While bitmap
images are made up of individual pixels,
each one requiring its own entry in the
data file that describes it, vector images
are made up of co-ordinates. Think of
them as points on a grid, describing
shapes, lines and fills. As a consequence,
vector images are smaller in file size, can
be scaled to any dimension, and they
don’t suffer from the same loss of quality
that plagues optimised bitmaps.

There are other vector formats on the
Web – but the fact that they’re not in
regular use is testimony to Flash’s
popularity. The World Wide Web
consortium is trying to pioneer the SVG
(Scalable Vector Graphic) format – a
dynamic graphics language created in
XML. The format has many interesting
features and is supported in Illustrator,
CorelDRAW and FreeHand, but like Flash
it requires a plug-in to function. WebCGM
(Computer Graphics Metaformat) is a
subset of SVG that can be viewed directly
in current versions of Internet Explorer.

Despite these ‘official’ standards, Flash
is the only vector format to have had any
real impact on the Web. Part of it could be
down to player distribution; around 98
per cent of browsers have the Flash plug-
in. On the other hand, it could be down to
Flash’s great toolset – a handy bunch of
widgets that enable you to create images
with the smallest number of points.

Flash MX has all the tools you’d expect
from a professional-level vector drawing

package, including freehand and Bézier
editing features. But it wasn’t always that
way. Until quite recently, the program
featured a reduced drawing toolset that
gave the illusion of reduced functionality.
In fact, Flash’s unique approach to vector
illustration is flexible and produces files
with far fewer points than ‘traditional’
tools. Drawing and editing lines, curves
and fills is easy with the simple, context-
sensitive tools available.

Over the next few pages, we take you
on a tour of Flash’s drawing complement,
as we complete a project in Flash. The
brief is to create a zoomable street map.
Our tutorial is structured so that you can
create a map of any place you like. We
simply outline an approach to the task
and provide you with some suitable
techniques to follow. Using vector
graphics in Flash will enable you to make
artwork that is resolution-independent,
and that you can transfer to the Web
without any loss in quality.

INFO Tutorial by Karl Hodge, khodge@spodgod.com.
Thanks to Time Out magazine (www.timeout.com) for
permission to use its map for the purposes of this tutorial.

VECTOR DRAWING 
IN FLASH MX

VECTOR GRAPHICS

Rob Collinet uses Flash to develop illustrations with a retro
feel. His site currently includes example artwork and Flash
games. His work’s easy to find at www.robcollinet.com.

Team Artonomy creates its impressive vector artwork in
Illustrator, but when designs are destined for the Web,
the results are often imported into Flash by its clients. 
Find out more at www.team-artonomy.com.

Someone has to create backgrounds for all those Web
animations, and at www.urbanentertainment.com, it’s
Sylvia Cziglenyi. Her portfolio site at www.sylviac.com 
lets you get a look at the original artwork for classics 
such as Undercover Brother.

Though he boasts mainstream clients such as Time
Magazine and the Discovery Channel, Jack Mortensback
fuses his Flash illustration with trippy, hippy vibes. Check
out his portfolio at www.illoboy.com.

ART86.flash  25/6/2003  7:10 AM  Page 39

ftp://ftp.futurenet.com/pub/arts/premium/arts86_flash_tutorialfiles.zip


Computer Arts_August200340

1
We’re drawing a street map, and although there
are several ways to convert the data into a vector

format in Flash, the easiest is to start with a bitmap
image of the map you want to convert. In our case,
we used a scan of a street map – this one has been
used with the kind permission of Time Out magazine,
the arts and entertainment weekly. For more info, see
www.timeout.com. Please obtain permission of the
copyright holder if you are going to use a scanned-in
map – otherwise, draw your own.

PART 1
LINE DRAWING
Flash gives you a flexible set of line
drawing tools to choose from

2
Create a new document in Flash and set the
size of the movie to the same size as the bitmap

image – 700x700 pixels is probably about right.
Import the map image to the stage and use the
Align panel (Window>Align) to centre it. Click the
Insert>Layer button on the timeline.

3
Double-click on the new Layer 2 label and name it
‘Streets’. Double-click the Layer 1 label and name

it ‘bitmap’. Select the layer labelled Streets. Now
manually trace the bitmap image using Flash’s tools.

4
Flash gives you a number of different ways to
draw lines – and lines are what we need to

trace our complicated street map. For most drawing
package aficionados, the Pen tool will be the obvious
first choice. Bring it up from the Tool palette.

5
In actual fact, Flash provides a number of
alternatives to manipulate lines, alternatives that

make the Pen tool seem positively cumbersome.
For straight lines, it’s best to go for the Line tool –
switch on Snap To Objects from the View menu to
join consecutive lines. Use the Properties panel to set
the Stroke height to 2 pixel and the type to Solid.

6
In our example, we’ve used the Line tool to trace
over a series of streets with a straight grid

structure. When drawing in straight lines, don’t worry
about overlapping. We’ll show you how to clean up
loose ends with Flash in a moment.

INSIGHT

CONTEXTUAL PEN
The Pen tool behaves in a context-sensitive

way, altering its function according to the

circumstances. Create a closed shape with it,

for instance, and said shape is automatically

filled with the current chosen fill colour.

Similarly, clicking points within a closed shape

deletes those points. The same hold true for

anchor points within a line.

PENCIL MODES
With the Pencil tool selected, choose Straighten

under the Options section of the Tools panel to

quickly draw perfect squares, ellipses, circles

and rectangles. However, although the fill

colour box is active in the Tools panel when the

Pencil is selected, you’ll have to fill the shape

with the Paint Bucket once you’re done.

7
For curved areas, we’ve used two different
techniques. The Pen tool comes in handy for

meandering lines. Select the Pen and place a start
point, then place a second point at the end of the
curve, holding down the left mouse button.

8
Move the mouse to adjust the curve of the line
until it fits. When you’re done, release the mouse

button and click on the last point you placed to
deselect it. Click the final point a second time if you
wish to continue drawing from that point.

^
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BRUSH TOOL
Although we don’t use the Brush tool in this

project, it can be handy. Essentially, it enables

you to paint with any fill, including bitmap fills.

With modes that enable you to paint in front or

behind objects, inside lines or over lines, it’s a

more liberating way to add colour.

INSIGHT
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9
The more ‘traditional’ way to create curves in
Flash is to draw a straight line between two points

of a curve, then switch to the Arrow tool. Hover the
cursor near the line and the arrow switches to the
curve adjustment icon. Click and drag to change the
straight line to a curve.

10
As you trace your map, the Pen and Line tools
will be your obvious first choices, but did you

know Flash also features a Pencil tool that you can
use for drawing freehand lines? Handily, the app
cleans up these lines on the fly.

11
In the Options panel, choose either Smooth,
Straighten or Ink to set the drawing mode.

Ink simply anti-aliases the line you draw, Smooth
reduces the number and complexity of curves in
your line, while Straighten speaks for itself.

PART 2
VECTOR EDITING
It’s not all points and Bézier handles
in Flash. You can edit shapes and
lines in a more intuitive way

12
Whichever method you use to trace or
draw your lines, they always remain editable,

either directly or via adjustments that you make in
the Properties panel. The method of editing you
choose is entirely independent of the tool used to
create the original line.

13
For example, you can manipulate a curve
drawn with the Pen tool using the curve

adjustment features of the Arrow tool. Similarly, if
you select the Subselection tool, click on any line and
you can individually move and edit anchor points,
whether they were created by the Pen or Line tool.

15
One important thing to keep in mind as you
trace over the streets in your street map is not

to leave gaps. In the next steps, we’ll be filling in the
traced areas with colour. In our example, we ‘closed
off’ streets that continued ‘off the edge’ of the map.

16
When you’ve finished tracing the outlines of
your street map, lock the layer containing the

original bitmap, switch its visibility off and select the
layer with your newly traced map.

17
Select the Paint Bucket tool and choose a
colour for the streets in your map from the

palette. We’ve noticed through experimentation that
Flash is better at filling in less complex shapes created
with lines than larger or more complex areas.

14
Using the Arrow tool, you can also adjust the
length of single lines or edit corners. Hover the

Arrow tool over a corner or the end of a line until the
cursor icon changes, then click and drag to adjust.

^
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USING SHAPES
For this project, we created shapes using the

Line and Pen tools, but you can also create

simple shapes made up of line and fill

combinations using the Oval and Rectangle

tools. Uniquely, the line and fill are independent

of each other when placed – and you can select

and edit them individually. In Flash, overlapping

shapes of the same colour on the same layer

are automatically joined. If you use a shape of a

different colour, the shape on top cuts a

corresponding piece out of the shape below.

ZOOMING IN
The finished version of our map has a zoom

facility built in. To achieve this, we used 

Jack Lender’s Zoom Me movie from

www.flashkit.com, which you’ll find on the CD

in Tutorial\FlashMX. This is a ready-built ‘shell’

with ActionScript and UI elements that you can

slot your movie clips into. Open zoom_me.fla in

Flash MX, go to the library and find our movie

clip zoom_this (on the CD). To use your own

map, replace the artwork in this clip with your

own, then save the whole file under a new

name. Use Control>Test Movie to try it out.

INSIGHT

^
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FINAL STEP
Delete the bitmap image from your file before

publishing. Our finished map used almost every
tool in the Flash drawing toolbox, from Line to simple
shape-creation tools, and many, as shown, are
interchangeable. The secret is to use functions that
you feel most comfortable with. 

18
Click within the lines you’ve drawn to start
filling the ‘streets’ with colour. If it doesn’t

appear to work, try ‘closing off’ smaller areas,
drawing single lines to seal any open shapes.
Continue in this way until all the streets are filled.

PART 3
ADVANCED FILLS
Next, use a splash of colour to
bring your line art to life

19
Switch to the Arrow tool. Earlier, we stated that
you could easily clean up overlapping lines in

Flash. Using the Arrow tool, you should be able to
select any overlaps and simply delete them. In this
way, you can tidy up edges, remove lines used in the
filling process and clean up the street ‘grid’.

20
You can use the Eraser tool to delete line
sections that you can’t select with a single

click. Alternatively,  use the Marquee or Lasso tools
to make a selection, then hit the Delete key.

21
Our example map includes vector artwork
representing a train. We created this in a

similar way to the map. After importing a bitmap
image of a train into Flash, we then traced over the
subject’s edges with the Pen and Line tools. You’ll
find the original image (train.bmp) on the cover CD.

22
When filling the shapes within the train, we
used a series of gradient fills. Select the Paint

Bucket to begin with, then open the Colour Mixer
panel (Window>Colour Mixer). Choose Linear from
the dropdown menu in this panel.

23
A two-colour, black-to-white linear gradient
is created by default. Click either colour to

select, then edit it using any of the various methods
available in the colour mixer. Use the Paint Bucket to
fill an area with the gradient.

24
You can alter the orientation, centre-point and
dimensions of the gradient fill using Fill

Transform. Select the tool, then click on the filled area
you wish to edit. The cursor changes as you select the
rotate or scale handle of the gradient selection.
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