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Tutorial

In the second of our three-part series taking an
in-depth look at the tools available in Flash MX,
we explore fundamental features of the timeline
as we create an interactive comic

The Flash timeline is a masterpiece of
interface design. Once a simplified take
on the timeline in Macromedia Director,
its expression in Flash MX is now just as
feature-rich and powerful.

The shift towards object orientation
kickstarted in Flash 4 helped that
evolution a great deal. In earlier versions,
almost all the program’s interaction and
animation capabilities were tied up in the
timeline. Recent improvements to
ActionScript and Movie Clips have taken
away that emphasis, but this doesn’t
mean the timeline is no longer important.
In fact, it’s still a central element in the
Flash interface, and knowing how to
use it well is an essential skill whether
you’re creating sites in Flash or using it
for animation.

Animation and interaction in Flash
begins with the timeline, whether you’re
using it on the main stage, editing the
timeline for a movie clip or tackling the
reduced version found in Button
Symbols. The program’s strength is that
you can create individual frames that
contain any of the elements supported
by Flash, from vector artwork to video.
Keyframes are frames that enable you
to define changes in animation or the
content of a frame. The frames between
one keyframe and another then display
the content defined in the previous one.

In turn, each frame can be composed
of a number of independent layers. One
layer may run unchanged over several
frames, while others may have a different
set of elements in each frame. The
timeline enables you to have any number
of layers you wish, too. To help cope with
this flexibility, a number of features
enable you to organise the timeline.
Name and colour-code individual layers
so you can track them more easily, for
instance, as well as group layers in
folders, using whatever criteria you like.

The timeline’s main function is to
control playback of these frames over
time. You can use ActionScript
embedded in keyframes within the
timeline to control this, or you can
reference frames within the timeline from
other objects. For example, a button may

be programmed to send the movie to a
numbered or labelled frame. When left
unfettered, a movie will play back on
screen at the set number of frames per
second specified within the Document
Properties dialog.

In this tutorial, we’re going to create a
simple, interactive project that will take
you through every major function of the
timeline. We’ll be creating an interactive
comic in a slideshow format that includes
persistent frames, the use of keyframes,
frame labels and ActionScript. The
project will be controlled by navigation
buttons that take users to labelled
sections of the timeline, and will also
require some organisation of layer
elements. We’ve provided all the artwork
for you as a library full of symbols that
you can drag and drop directly to the
stage. You’ll be able to concentrate on
working through the main features of
the timeline, picking up secrets, hints and
tips along the way.

INFO Words and Flash expertise by Karl Hodge,
khodge@spodgod.com. Wild For Adventure comic 
strip artwork by John Broadley (broadl.j@virgin.net) 
– used with permission.

FLASH MX IN DEPTH
WEB NAVIGATION

Flash lends itself well to Web comics, thanks to the
timeline’s blend of linear animation features and non-linear
interaction. British artist Daniel Merlin Goodbrey uses both
in his online ‘Hypercomics’ series (www.e-merl.com).

Scott McCloud (www.scottmccloud.com) has become an
authority on comic strip artwork with his seminal books
Understanding Comics and Reinventing Comics. Using
Flash, he’s built The Right Number – a strip that uses a
‘zoom-in’ technique to segue effectively between panels.

Patrick Farley’s ‘Electric Sheep’ brand is well known in the
world of Web comics. Many of his strips are presented
direct in HTML, but Apocamon – a Manga style retelling of
the Book of Revelations – uses Flash timeline techniques.
Visit www.e-sheep.com to find out more…

Marvel characters are seeing a resurgence in cinemas with
the X-Men, Spider-Man, Daredevil and The Hulk. Read their
Flash-powered adventures for free at www.marvel.com.
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1
Comicstarter.fla is essentially an empty file with a
fully populated library. This contains all the

artwork you’ll be using throughout the tutorial.

PART 1 SETTING
UP THE TIMELINE 
Open comicstarter.fla from the
Tutorial folder on the CD and prepare
the groundwork for you animation

4
The label should now be editable – rename it
‘ActionScript’, then rename the others ‘Labels’,

‘Buttons’ and ‘Artwork’, from top to bottom. Right-
click on the ActionScript layer and choose Properties.

7
One underused property is the Layer Height
setting. You can choose from 100, 200 or 300 per

cent. Normally, you wouldn’t need to touch this, but
it can be handy if you want to make a layer easier to
spot while you’re working on it, or if you’re working
with sound or video layers.

8
Select the Buttons layer and click the Insert Folder
button. Rename it ‘Stage Elements’, then Shift-

click on the layers called Buttons and Artwork to
select them. Drag and drop the layers into the newly
created folder. The timeline is now ready.

9
Time to add some content… Note that if you were
using this timeline to create animation, you’d

probably want to tweak the Document Properties
before proceeding. A quick way to access this dialog
is to double-click on the frame rate displayed at the
bottom of the timeline.

5
The Properties dialog gives you quick access to
all the attributes you can set for a layer. The Guide

layer type is used in animation to create a path for an
object. Mask layers enable you to create a ‘hole’
through which you can see the layer below.

6
Changing the Outline Colour of the layer also
changes the colour swatch next to the Layer

Name in the timeline. Outline mode displays the
contents of the current layer as vector outlines – this
only works if you have vector artwork on the stage.

2
By default, the timeline contains one layer. For
this project, you’ll need three: to add these, click

the Insert Layer icon at the bottom-left of the timeline
or choose Insert>Layer from the main menu.

3
You can also right-click (or Ctrl-click on the Mac)
within the layer listing to bring up a context-

sensitive menu. There’s an option to insert new layers
there as well. Once you’ve added the extra layers,
double-click on the top layer’s Layer Name.

INSIGHT

FOLDER COMMANDS
When you have several layers within a folder,

you can change selected properties of an

entire folder rather than individual layers. 

Set the entire folder to display vectors as

outlines, lock all layers, toggle layer invisibility

using the icons in the main timeline list… it’s

up to you. You can also delete the contents

of an entire folder in one go.

^
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10
First off, set the document size to 850x400 in
the Document Properties dialog. Select the

layer named Artwork, then open the Library
(Window>Library) and find the graphic symbol
title.gif. Drag it to the centre of the stage.

PART 2 USING
THE TIMELINE
With the timeline up and ready, it’s
time to add some decent content

13
Roughly arrange the numbered images so that
they run from 1 until 12 between the ‘next’ and

‘back’ images as shown. To align them, select them all
and go to Window>Align, making sure that the To
Stage icon is toggled off, then click the Align Vertical
Centre and Distribute Horizontal Centre icons.

16
The previous steps essentially copied
keyframe 2 on the Artwork layer across 13

frames. You could’ve chosen Insert Blank Keyframe
instead, which inserts empty keyframes in each slot.
In either case, the next step is to add content from the
library to each individual frame.

17
Select the third keyframe, delete the current
image (wild1a.gif) if you added populated

frames, then drag image wild1b.gif into its place.
Continue adding the remaining images from
wild2a.gif to wild6b.gif, one for each keyframe
from 4 to 13 in the same way.

18
Select frame 14 on the Artwork layer and
delete the content on the stage. In our

completed file, we added a text box crediting the
artist – for the purposes of this tutorial, you can
simply add a box that says ‘The End’.

14
Select the keyframe at frame 2 of the Button
layer, then Shift-click on frame 12 to select

all the frames between. Right-click (Ctrl-click on the
Mac) to bring up the context-sensitive menu and
choose ‘Insert Frame’. This spreads the content of
the keyframe over 12 frames.

15
Select the keyframe at frame 2 of the Artwork
layer, then Shift-click on frame 14. Choose

Convert To Keyframes; this adds keyframes to every
selected frame in the layer. Also, add a blank
keyframe at frame 14 of the Buttons layer.

11
Click in the second frame of the layer and go to
Insert>Keyframe. Alternatively, right-click (or

Ctrl-click on the Mac) and select Insert Keyframe from
the context-sensitive menu (or press F6). Delete the
title.gif artwork in frame 2, then drag and drop the
graphic symbol wild1a.gif into its place.

12
Switch to the Buttons layer and insert a key
frame at frame 2. Drag the graphic symbols

next.gif and back.gif to the stage and place them as
shown in the illustration above. You’ll have to resize
them to 50 per cent using the Transform panel. Next,
drag the numbered images 1.gif to 12.gif to the stage
and scale them to 30 per cent.

INSIGHT

FRAME BEHAVIOUR
You may notice slightly different behaviour

between the Insert Frames and Insert

Keyframe commands. When you select

multiple frames and choose Insert Frame,

Flash inserts frames one frame past your

selected point. When you Insert Keyframe,

Flash fills in only the frames that are selected.

^
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CUT AND PASTE
The timeline has its own internal rules and

its own clipboard. To copy and paste frames,

you need to select the required frames, then

choose Copy Frames from the context-

sensitive menu or the Edit menu. The shortcut

is Ctrl+Alt+C (Ctrl+Option+C on the Mac).

FINISHED FILE
In our finished file (look in the ‘Wild For

Adventure’ folder on the CD within the

Tutorial\Flash MX folder), you’ll find a couple

of extra tweaks not illustrated in this tutorial.

We positioned another Back button on the

final page and an Instance of the Next button

on the first page. We did this by copying the

original buttons and using Edit>Paste In Place

to position them in the appropriate frames.

INSIGHT
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19
Go to the layer you named ActionScript
and right-click (Ctrl-click on the Mac) on the

keyframe at frame 1. Choose Actions to bring up the
Action Editor. In the Actions hierarchy on the left of
the panel, go to Actions>Movie Control and double-
click on the ‘stop’ to add a ‘Stop()’ action to the frame.

PART 3 ADDING
INTERACTION
The timeline is done, the elements
are all in place – now to animate!

20
Select frame 1 in the ActionScript layer, as
shown, then Shift-click on frame 14 in the

same layer. Right-click (Ctrl-click on the Mac) and
choose Convert To Keyframes, duplicating the
keyframe at frame 1 across all 14 frames.

22
Select the next keyframe and change the
Frame label to ‘wild1a’, the next to ‘wild1b’,

the next to ‘wild2a’, and so on, until you reach
‘wild6b’ at frame 13. Label the final frame ‘end’.

24
In the Actions Editor, double-click on Goto
under Actions>Movie Control, then choose

Frame Label from the Type dropdown. Choose
wild1a. Now create buttons from all the numbered
images, linking them to the corresponding frame in
the same way, until all the frames have been treated.

23
Go to the Buttons layer and select 1.gif on
stage. Press F8 to convert it to a symbol.

Choose Button and name it ‘wild1abutton’.
Returning to the stage, select the new button
and hit F9 to bring up the Actions window.

21
Select frame 1 in the Labels layer and Shift-
click on frame 14 in the same layer, then

Convert To Keyframes. Select the first frame and
go to Properties. In the Frame Label box, type ‘start’.

FINAL STEP
The Back and Next images should be turned into

buttons in the same way. When adding movie
control actions to them, choose Goto, then Previous
Frame from the Type dropdown for the Back button
and Next Frame for the Next button. 

^
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