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Tutorial

Everyone knows that
Photoshop is probably the
best bitmap editor in the
world, but how does it fare
as a vector tracer? The
answer, is extremely well
In this industry, there are countless ways to spend
your hard-earned cash, from software updates
through to objects of desire like Apple’s new
Cinema Display. But what do you do if you need
to create a particular style of illustration, and your
budget won’t extend to the app you need?

Let’s say, for example, that you’ve spent your
last penny upgrading Photoshop to v7. The
problem is, you need to create vector images,
and your budget won’t stretch to Illustrator or
even Streamline. Will you forget smooth curves
and sharp transitions, or design all your images
at 1200dpi?

Choose the right tool and apply the right
technique, and the solution is there waiting for
you within your copy of Photoshop. The Pen tool
and its Path palette have found two new creative
companions: vector masks and custom shapes.
This tutorial will show you exactly how to use
Photoshop as a vector tracer: turn an object into
a vector image using the Pen tool and custom
shapes, generating vector effects in no time.

We’ve supplied custom shapes and actions 
within this pdf, plus our source image. To load 
custom
shapes, select the Custom Shape tool, go to the
Shape dropdown in the Tool Options bar, click on
the arrow to the right of the dialog and click Load
Shapes, then navigate to the appropriate file.
To load actions, head to the Actions palette and
simply select Load Actions from the dropdown.

PHOTOSHOP
VECTORS

ILLUSTRATION

Text by Pierre-Etienne Courtejoie. 

Create this vector-stylee image in the following tutorial.
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PART 1
SIMPLE VECTORS
Learn how to simplify, vectorise and
save simple objects as custom shapes

INSIGHT

SIMPLIFICATION
Instead of using Colour Halftone, experiment
with Artistic>Cutout, Palette Knife, and most 
of the filters in the Pixelate family. Don’t forget
to look under Image>Adjustments – Posterise
and other filters could be useful too. Remember
also that when you have different levels 
of selection, Make Work Path only on areas
selected at 50 per cent and more. That’s why 
a blur is useful to even out these zones.

INSIGHT

CHANGE LAYER
CONTENT
Using Layers>Change Layer Content can lead
to many more creative effects: the Solid Colour
adjustment layers can be transformed into a
Gradient or a Pattern fill. You can also reduce
the opacity of the layers, their Blending modes
(Control/right-click their icons and play with the
advanced Blending options), or even apply a
style to your vector shapes. If you want to draw
on them, create a regular layer on top of this
layer, then group it with the masked layer by
Option/Alt-clicking on their separation line in
the Layers palette.
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1Create a new 600x600 RGB document. Draw a
circular selection using the Elliptical Marquee tool

(hit M). Use View>Show Rulers to position the start
and end points precisely and Shift-drag to create 
a circle instead of an ellipse. Select>Feather the
selection by 15 pixels. Hit D to load the default
colours, and Edit>Fill with the foreground colour.

2 To simplify the gradient, use Filter>Pixelate>
Colour Halftone. For the settings, use 16 as the

maximum radius, and set all the angles to 45 degrees.
(You might need to change the radius for other image
sizes; to obtain a similar effect, make sure that all the
angles have the same setting.) Separate the Layers,
Channels and Path palettes by dragging the tab out 
of the merged palette, then juxtapose them so they
can be accessed easily.

3 Configure the Magic Wand (press W) and make
sure that ‘Contiguous’ is unchecked in the Option

bar, then click in one dark area on the image – all the
separated spots are now selected. In the Path palette,
you can Option/Alt-click the Make Work Path From
Selection button to access its Tolerance setting. 
Set it to 1 to get precise paths. (Note that this menu is
‘sticky’: it won’t change unless you or an action enters
a different setting.) You now have vector paths. The
next time you create a path from a selection, you’ll
only need to click on the Make Work Path icon.

4 To visualise this vector path, create a new Solid
Colour adjustment layer. Creating a adjustment

layer when a path is active automatically loads it as a
layer clipping path (a vector mask). To load a path on 
a regular layer, hold down Command/Ctrl while you
click on the Add A Mask button in the Layers palette.

5 You can clean the unwanted sub-paths using the
Direct Selection tool (A). As with the Rectangular

Marquee, Shift-drag around the control points you
want to get rid of, inside and outside the halftone
shape, then simply hit Backspace or Delete to clean
the path.

6Now save the path as a custom shape using
Edit>Define Custom Shape. The shape is listed in

the Custom Shapes Presets window. To create a set
with your new shapes, select Preset Manager in the
dropdown list. In the Preset Manager, you can Shift-
click several custom shapes and then press on the
Save Set button – it will save them in a new set that
now just needs to be named.

PART 2
PHOTOS TO PATHS
Now we’ll apply different
posterisation techniques

7Open Start.tif from the CD. Save it immediately as
VectorBody.psd to avoid altering the original file.

Copy the background layer (Command/Ctrl+J), name
it ‘base’ and desaturate it with Image>Adjustment>
Desaturate, or Command/Ctrl+Shift+U. Adjust its
levels automatically: Image>Adjustments>Auto
Levels (or hit Command/Ctrl+L). Add a Threshold
adjustment layer so we can build a selection based on
the lightness levels of the image. Don’t change the
default 128, as this will be a good indication of how
the simplification process is going to affect the image.
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8 Reselect the Base layer and apply Filter>Blur>
Gaussian Blur. Thanks to the Threshold layer, you

can see the image dynamically simplify itself while
you change the radius of the blur. Choose a level that
gives smooth curves to the image, while maintaining
a good amount of detail. In this case, 3 pixels is a
good compromise.

9Double-click the thumbnail of the Threshold
adjustment layer to change its setting to 16. It will

visually discard all the pixels lighter than this point.
With the Magic Wand set to Non-contiguous, click on
a dark area of the image, then Select>Modify>Grow
By 1 Pixel (to avoid small gaps between tones). In the
Path palette, click on the Make Path icon.

10 In the Layers palette, Option/Alt-click on the
Create Set button, name it ‘Body’, choose a

yellow colour for it in the Layers palette and make a
new Solid Colour adjustment layer. Choose 16,16,
16 as RGB values to match the chosen threshold.
Another advantage of using an adjustment layer is
that you can change the values afterwards.

11Hide the layer set by clicking its eye icon. Change
the settings of the Threshold adjustment layer to

64, select the black parts, Grow the Selection by 1 Pixel
and make a path. Create a Solid Colour adjustment
layer with R=64, G=64 and B=64. Drag the tile of the
Solid Colour layer over the folder icon of the set. It’s
placed under the first adjustment layer.

12 Starting to experience a sense of déjà-vu? Well
now you need to repeat step 11 six times with

these values : 96, 128, 160, 192, 224, 240, both for the
Threshold and the Solid Fill adjustment layers (you
can vary the number of layers and their value). The
actions included within this pdf might be useful for   
this kind of assembly linework.

13As in Step 5, clean the possible artefacts on the
vector layers. Our advice, is to mouse over the

layer clipping path tiles to see the path’s edges on the
main document, and make sure that you select only
points inside or outside the limits of the path, not
those that define its edges. The big transparent areas
like the forehead will be fixed with another method.

14 There are several areas inside the body that
are still transparent, and you don’t want to fill

the exterior of the body, either. Option/Alt-click the
eye next to the layer set icon to hide everything but
the contents of the set. Create a new layer without 
the menu (it’s a temporary one, so you won’t need to
name it), then Command/Ctrl+Option or Alt+Shift+N
and Stamp a copy of all the visible layers with
Command/Ctrl+Option or Alt+Shift+E.

15 To find the smallest holes, apply a bright Stroke
Layer Style. Using a hard-edged brush, fill in

the gaps. Don’t worry if it looks like you’re ruining the
image – this layer will also be converted to a one of
single tone. Delete the Style. Command/Ctrl-click 
the layer’s thumbnail, then Select>Modify>Grow 
By 3 Pixels to create an outline and jump to the Path
palette to transform these pixels into vectors. Add a
Solid Colour adjustment layer set to 248, 248, 248.
Place it at the bottom of your set. Delete all the non-
vector layers, and also the Threshold adjustment
layer. You can now save this image.

16 Re-open the Start.tif image and save it as
Face.psd. Flip the image horizontally via

Image>Rotate Canvas>Flip Horizontal. Crop it 
(hit C) to get a close-up of the head – approximately
1600x1200 pixels. Don’t worry about the image
quality caused by rescaling, as we’ll be transforming
the image later. Duplicate the background, rename 
it ‘hexbase’ and desaturate it. 

17 To give the image a particular style, run
Filter>Distort>Displace with both Scale options

set at 10 per cent, Displacement Map set to Tile, and
the Repeat Edge Pixels option checked. Select
honeycomb.psd as a displacement map. It is located
in the Displacement Map folder, inside the Photoshop
Plug-ins folder. The image now has hexagonal
pixelisation – if you like this effect, use HEXaction
from the action set included within this pdf.
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25Open Start.tif again. Save it as Eye.psd. Crop 
a 1600x1200 section around the left eye. Run

the 4steps vectorizer action from the Vectorizer1 set.
Delete the two lighter layers, and set the Solid Colour
adjustment layers to R=144, G=73, B=110 for the dark
layer; R=166, G=93, B=131 for the medium1 layer; and
R=197, G=124, B=162 for medium 2.

26Drag and drop the eye image into the
composition, then scale it to fill more space.

Change the 4stepsVector set’s Blending mode to 
Hard Light and lower its opacity to 75 per cent. In the
HexVector set, add a Solid Colour adjustment layer,
with its Blending mode set to Colour. You could also
switch the set’s Blending mode to Pass Through.

20 Select the set, then create a gradient mask that
follows the diagonal of the glasses. Change it

to vector: run Filter>Pixelate>Colour Halftone at 32 for
the radius and 45 for all the angles. Command/Ctrl-
click the layer mask thumbnail to load its transparency
as a selection. In the Paths palette, select Convert To
Path. In the Layers palette, click the Add Vector Mask
button (when there’s a layer mask, it automatically
creates a vector mask), and delete the raster one.

21Transform the set to give it some perspective:
Edit>Free Transform. Command/Ctrl-click the

left, top corner point and drag it to the top, dragging
the middle, right handle to the left. If you want to only
distort the contents of the set (not its mask), Unlink
the mask from the set and Transform the contents.
You can experiment with distortions without data loss.

22Hide the Body set and create a new one
named ‘Stars’. Check the Create New Shape

layer icon in the Options bar. Select the ‘softstar’
shape (Shift-click) in the centre to create a small star.
Before transforming it in a fractal-like pattern, make
sure Add To Shape Area is selected in the Options bar.

23Hit Command/Ctrl+Option/Alt+T to Duplicate
Free Transform. Move the centre point to the

limit of the top branch of the star, and in the Options
bar enter 125 per cent for the length and height, and
33 degrees as the angle. Press Command/Ctrl+Shift
+Option/Alt+T (Duplicate Transform again) several
times. To check your results, select the starstep shape
from the CheapShapes set within this pdf.

24 Import the HexVector set, select the star layer,
and in the Paths palette, drag the star’s vector

mask to the New Path icon. While this path is active,
reselect the HexVector set, then Command/Ctrl-click
the Layer Mask icon to apply the fractal vector mask.
You may need to resize the set to fit it in the mask:
unlink the chain icon, then Edit>Transform the paths.

PART 3
SET AND MATCH
The sets aren’t just used to clean the
Layers palette – they serve a purpose

18Add a Threshold adjustment layer, set it to 32
and repeat the process from Step 9. Select,

Grow, Make Path and create a set to be named
‘HexVectors’. Give it a colour, then create a Solid
Colour adjustment layer with these values: 96, 160 
and 224 (these steps are recorded in the action ‘4steps
HexVect’). Fill in the gaps (as in Step 15) and save.

19Make a new document, 2400x1400. Import the
Body layer set, change its Blending mode to

Normal and add a Hue/Saturation adjustment layer.
This way, you can change just the colour of the set,
leaving the layers beneath unaffected.

FINAL STEP
There are still some raster elements in the file – the

background and the layer masks from some of
the adjustment layers. Replace the background with
another Solid Colour adjustment layer set to a light
green (R=240 G=247 B=204), then click on the Add
Mask button – there is now a raster and a vector one.
The vector masks always have a line before them –
delete the other one and follow the same process for
the colourisation layers. Your 100 per cent vector
psychedelic image is made totally in Photoshop –
compare your results with final.psd within this pdf.

INSIGHT

PAINT YOUR VECTORS
Drawing a shape using the Pen tool requires
some practice. Instead, paint a shape using 
the Brush tool, select it, Make Path and save 
the shape. This is a useful way of creating crisp
signatures at any size, or even handwritten
copyright notices. Using a calligraphic brush,
you can now draw vector graffiti in Photoshop,
too. If you’re not happy with your drawing
abilities using a mouse, invest in a Wacom
tablet – or enter our competition on page 47.
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