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Tutorial

In the third part of our series taking an in-depth look
at Flash MX, we create the credit sequence for a Web
cartoon using the package’s animation features

There’s no avoiding it – when people think
of Flash, they think of animation. It may well
have evolved into an application authoring
package, but there are good reasons why
it’s largely famous for animation. The
combination of vector graphic support
with the easy-to-use timeline makes it a
pleasure to work with. Even if you’ve
never considered animation before, Flash
MX provides you with enough roads in to
inspire anyone.

The most obvious way to get started is to
use frame-by-frame animation. Pioneered
in the earliest days of the art, this technique
is given an interesting new twist in Flash.
Vector graphics enable you to make
changes to artwork quickly, while layers
enable you to build up static backgrounds
to accompany your work. The package’s
ability to adapt to other media means that
you’re not confined to using Flash’s
drawing tools. You can just as easily use
the program in a more traditional way,
scanning in artwork and arranging it in
Flash. The results can be instantly viewed
and tweaked in a variety of ways.

This traditional method is augmented by
several features that you could only achieve
digitally. Tweening is Flash’s killer feature –
a method that enables you to specify the
start and end points for an animation,
letting Flash work out the frames in-
between. As the package has become more
sophisticated, tweening has too. In Flash
MX, you can automatically animate the
rotation, scale, colour, transparency and
position of objects. If it’s necessary, you can
do all of those things at once – creating
spinning objects that grow larger as they
fade into view, for instance. To control the
movement of objects, you’re also able to
define paths that combine with tweening
techniques to give a superb level of control. 

Flash 4 introduced a feature that enables
you to take two different shapes and
animate the transformation from one to the
other. Again, this is a form of tweening,
requiring you to simply place two
keyframes on the timeline containing two

different objects. Creating the animation is
as simple as selecting a menu command.

In isolation, such techniques are easy to
master, but when combined into a single
project, the results can be very impressive
indeed. Over the last two issues, we’ve
looked at Flash’s drawing tools and timeline
in detail. In this third tutorial of the series,
we combine all that knowledge with Flash’s
animation techniques to create the
introduction to a Web cartoon. We’ll show
you all the techniques we used to complete
the project: how to combine frame-by-
frame animation with tweening effects,
how to morph shapes and create fades. 
INFO Words and Flash expertise by Karl Hodge,
khodge@spodgod.com

FLASH MX ANIMATION
WEB CARTOONS

The Mr Men are back – in Flash form! Actually, these
cartoons have nothing to do with the famous Roger
Hargreaves’ Mr Men series – they’re a collection of 
quirky ‘films’ by Steve Whitehouse. You’ll find them at
www.whitehouseanimationinc.com – have a look at what’s
possible when you use Flash as an online animation tool. 

Proof that having one good idea can kick-start a career,
Joel Veitch’s work has recently made the transition from
Web to TV. You can still see a collection of his Flash-
powered animations of guitar-wielding kittens singing
glorious pop songs at www.rathergood.com.

Homestar Runner (www.homestarrunner.com) has
acquired cult status among the net community, even
getting a recent name-check on Buffy The Vampire Slayer.
The site’s high-point is Teen Girl Squad – a bizarre
combination of fashion tips and extreme violence.

Viral marketing is the natural next step for successful
Flash animators – and that’s what JibJab specialises in.
Visit www.jibjab.com for Flash cartoons you’ll definitely
want to pass on to your friends.
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1
Open credits_tutorial1.fla in Flash MX. This is
an empty movie that contains all the various

media you’ll need to complete this tutorial. The file
gordon_credits.fla is the finished project using the
techniques we’ll discuss, while gordon_credits.swf
is the Shockwave Flash version.

PART 1
FRAME BY FRAME
Locate the Flash tutorial folder on your
CD and find credits_tutorial1.fla

2
Go to Insert>New Symbol and choose Movie
Clip. Name the clip ‘gordon_swims’. Next, we

need to set up the timeline for frame-by-frame
animation. In the top-right corner of the timeline
is the Frame View pop-up menu – click the icon to
open the menu and choose Preview.

3
In Preview frame view mode, each frame in the
timeline shows the artwork on stage – this is

handy in frame-by-frame animation, giving you a
visual cue as to what’s happening while you work.

4
Open the Library (Window>Library) and find
the Fish folder. Inside it are four graphic symbols.

Drag and drop the symbol named gordon1 to the
stage, as shown. A preview of the symbol will appear
in the timeline. Centre the symbol on stage using the
‘Align’ panel (Window>Align).

5
Select frame 2 and hit F7 to place a blank
keyframe. Drag and drop an instance of the

graphic symbol ‘gordon2’ to the stage. To help you
correctly line up the second frame with the first, you
can switch on Onion Skinning – a mode that enables
you to see the previous frame.

6
In this case, switch the Layer to Outline mode by
clicking the fourth icon along in the layer 1 label.

Select the second of the Onion Skinning icons on the
bottom-left of the timeline – the Onion Skin Outlines
button. Move the symbol you placed in the frame
until it’s correctly aligned.

7
Insert a blank keyframe at frame 3. Notice how
the Onion Skin Markers change to encapsulate all

three frames. You can manually alter the beginning
and end markers so that onion skinning affects as
many or as few frames as you like. Alternatively,
clicking the Modify Onion Markers icon enables
you to select a choice from a menu.

8
Drag and drop an instance of gordon3 to the blank
keyframe and, as before, use Onion Skinning to

position it. Create a blank keyframe at frame 4 and
add an instance of the symbol gordon4. 

9
When you’re happy with the positioning of the
symbols, click the Onion Skin Outlines button

again to switch it off, then turn off Outline mode
in the layer. Hit Enter to view your animation.

INSIGHT

^

ADJUSTING OUTLINES
When adjusting elements manually on stage,

it may be necessary to switch back into Outline

mode so that you can accurately select the

element. Just toggle the Outline icon on the

Layer label and, if you prefer, switch to standard

‘Onion Skin’ mode using the first of the Onion

Skin buttons on the timeline. With an element

selected, you can also use the arrow keys to

nudge things around.
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17
Hover the cursor close to the object until it
changes to the Rotate icon. Manually rotate the

movie clip so that it faces in the direction of the path.
Select frame 30 and move the second instance of the
clip to the end of the path on the left, aligning the
centre mark over the end of the path.
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10
Return to Scene 1 of your movie – there’s a link
at the top of the stage window. Drag and drop

an instance of the gordon_swims movie clip you
created to the stage. In the Transform panel, enter 50
per cent to scale the clip down.

12
Select the Pencil tool from the Tools panel.
Click the Options icon at the bottom of the

panel and select Smooth. In the top-right section of
the stage area, use the Magnification menu to zoom
out to 50 per cent. Use the Pencil tool to draw a wavy
line across the entire workspace – from one side of
the stage to the other, as shown.

13
Notice in the screenshot that the line moves
completely outside the limits of the stage.

When we play the movie back, our character will
swim into the screen from one side and out the other.

INSIGHT

^

OTHER TWEENS
You can also use motion tweening to rotate

and resize objects. Simply change the rotation

or scale of one of the keyframes, making sure

that the Scale box is ticked in Properties and

you’ve chosen a rotation type. You can animate

colour effects by selecting an instance of the

object you want to animate, then using the

Colour dropdown to select a transition. Setting

one instance of a clip’s Alpha to 0 per cent and

the end frame to 100 per cent creates an

effective animated full fade.

PART 2
LINEAR MOTION
Using our frame-by-frame animation
to take things further – with motion

11
Select frame 30 and hit F5 to insert frames.
Right-click (or Ctrl-click on the Mac) the layer

label to bring up the context-sensitive menu for layer
1 and choose Add Motion Guide. This adds a guide
layer that’s joined to the original layer. Select this.

14
Select Layer 1 and highlight frame 30. Hit
F6 to insert a new keyframe. Select the first

keyframe and select the instance of gordon_swims
on stage. Set the Tween menu in the Properties panel
to Motion. Tick Orient To Path and Snap.

15
The Orient To Path setting makes your
animated symbol rotate in the direction of the

guideline. The Snap setting helps the object on the
animation layer snap to the ends of the guideline.

16
With the first frame still selected, move the
gordon_swims movie clip so that its centre

mark snaps to the end of the motion guide on the
right of the screen. With the object still selected,
hit Q to select the Free Transform tool.

18
Again, manually rotate the clip in the direction
of the path. Press Ctrl+Enter to test the

playback of the movie. The process we’ve described
applies to all instances of motion tweening; to make a
clip move along a straight axis, you don’t need to add
a motion guide layer. Just start and end keyframes.

ART88.flash  13/8/2003  7:44 PM  Page 37



Computer Arts_October200338

FINAL STEP
You can control more complex shapes using

shape hints. Choose Modify>Shape>Add Shape
Hint to add a point to a shape you’re transforming,
then add a corresponding point on the shape it’s
transforming into. You can add as many hints as
you like to control the process. 

INSIGHT

^

ACTIONSCRIPT
ANIMATION
ActionScript is there to control objects, and in

Flash MX there are many dedicated commands

that control the state of objects, which can be

used in animation. Open our finished project file

(gordon_credits.fla) and the library, going to the

bubbles folder. In here is a movie clip called

bubble_blower. The second frame contains an

ActionScript that randomly generates bubbles

in our movie. The key is the duplicate MovieClip

item, which random duplicates copies of a

movie clip at different co-ordinates and scales.

This code was cleaned up and adapted from the

ActionScript in bubbles_rising.fla by Vikram

Prajapati, found at www.flashkit.com. 23
Select keyframe 10 and drag and drop an
instance of the graphic symbol text_bubble to

the stage. Align it over the letter F. Click away from
both objects to deselect everything, then select the
letter and delete it. Select the bubble symbol and hit
Ctrl+B to break the symbol down into a shape.

24
Return to frame 1 and select the letter F. Hit
Ctrl+B to break the symbol down into a shape.

Go to the Properties panel and chose Shape from the
Tween menu. Add frames at frame 10 for each of the
other layers. Press Enter to see your animation.

19
Although the basic technique is similar to that
outlined in Part 2, shape tweening has some

functional differences that should be addressed
directly. To see an example of shape tweening in
action, open the file credits_tutorial2.fla, drag and
drop an instance of fishhatlogo from the Text folder
in the library to the stage and press Ctrl+Enter.

20
In this example, letters morph into bubbles
(which then rise using a motion tween). These

are quite different shapes but the transition works
because the shapes are simple. The animation is
simply a transformation from rectangle to circle. 

21
To try out the technique for yourself, delete
the movie clip fishhatlogo from the stage,

then drag and drop an instance of fishhat_text in the
root of the library. Unlike motion tweening, shape
tweening works on single shapes, not symbols.
Select the text and hit Ctrl+B twice.

22
The first Ctrl+B breaks down the symbol, the
second breaks the text down into individual

letters. Go to Modify>Distribute To Layers. Each letter
is assigned its own, uniquely named layer. Select
layer F and insert a keyframe at frame 10.

PART 3
SHAPE TWEENING
How to transform one shape into
another to create exciting transitions
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