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Tutorial

Get up to speed with the
exciting new features in the
latest release of Macromedia’s
indispensable Web editor, with
our exclusive demo and tutorial

Dreamweaver MX 2004 isn’t quite the revolutionary
upgrade that MX was, but its essential improvements
include changes to long-established parts of the program,
such as the way the Page Properties and Property
Inspector work, as well as many other welcome
refinements. In the following in-depth tutorial, we
explore some of the new features more fully.

The biggest changes relate to the way Dreamweaver
creates and displays Cascading Style Sheets, but we’ll also
explore new features like the Tag Inspector and the live
Target Browser check. 

This tutorial assumes you’re familiar with some of the
basics of Dreamweaver, such as setting up a site, inserting
images and working with the MX workspace. We’ll also
pay a brief visit to Fireworks to customise the imagery.
Turn the page for your first play with MX 2004.

INFO Tutorial by Ian Anderson of zStudio. zStudio is a new-media consulting
practice that provides out-sourced Web development and training to designers
and agencies. 

DREAMWEAVER
MX 2004

NEW RELEASE
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1
Open Dreamweaver MX 2004 and, in the new
Splash screen, click Create New>Dreamweaver

Site. Switch to the Advanced tab, click the browse
button for Local Root Folder and locate the Start
folder. Select it as the local root folder and name
the new site DW Tutorial, as shown.

PART 1
GETTING STARTED
First, copy the Start folder from
the cover CD to your hard disk

2
Open the file start.htm, and ensure the Properties
palette is visible at the foot of the window. Choose

Window>Properties if it isn’t open. If you’ve used
Dreamweaver before, you’ll notice that the default
font is larger and the layout slightly different. Note the
new Page Properties button on the Properties palette.

4
Choose Edit>Preferences>General category and
ensure the ‘Use CSS instead of HTML tags’ option

is selected. Page Properties now creates CSS styling
information, instead of the deprecated HTML
attributes previous versions used to insert. Click OK,
then click the Page Properties button in the Properties
palette to open the new Page Properties dialog.

7
Choose Headings from the Category list. Choose
Heading font: Arial; Bold, Heading 1: 24 pixels;

Colour: #660000. Choose Apply to see the result. If
you wish set similar options for Heading 2 and 3,
make the sizes 18 pixels and 14 pixels respectively.

8
Change back to the Appearance category, and
set the margins as follows. Left Margin: 25 per

cent, Top margin: 50 pixels, Right margin: 25 per cent,
Bottom margin: 10 pixels. Test the page in a browser;
the content should be centred with flexible margins,
giving readable lines at most common window sizes.

9
Switch to Code view using the large buttons at
the top of the document window, and locate the

STYLE element in the HEAD of the page. This is
where Dreamweaver stored the settings; it always
embeds the style information in the HEAD, even if
there’s a linked style sheet attached.

5
In Page Properties, choose Page Font: Verdana,
Size: 11 pixels, Text color: #333333, Background

color: #e6e6e6. Dreamweaver now sets up tag styles
for BODY, TD and TH, so that other elements on the
page can inherit the formatting attributes.

6
Choose Links from the Category list. Choose
Bold, Link color: #0066FF, Visited links: #003399,

Rollover links: #CC0000, Active links: #FF3333,
Underline style: Show underline only on rollover.
In previous versions, you had to create specific
styles by hand to achieve the same result.

3
Ensure the Tag Inspector palette is open (there
should be a tick beside Window>Tag Inspector)

and examine the three tabs: Attributes, Behaviours
and Relevant CSS. The Attributes panel contains new
options for all the HTML attributes available for the
selected element, and the Relevant CSS panel shows
all the CSS rules now affecting the selected element.

CSS AND YOUR
TARGET AUDIENCE
Most Web users have browsers equivalent to

IE or NN v5 or higher, which means you can

use much of CSS as it’s intended. If you’re

designing for an audience relying on versions

3 and 4, however, you may wish to stick with

HTML formatting for a while yet.

INSIGHT

^

ART90.dw  14/10/2003  3:39 PM  Page 76



Computer Arts_December2003 77

Tutorial

10
Highlight the text in the first paragraph using
triple-clicking or dragging. Note that the

Properties palette shows the formatting we chose
in Page Properties. Choose a larger size: 14 pixels.
Dreamweaver now creates and applies a new class
called Style 1, which you can see in the new Style
menu in the Properties. Choosing another font or
colour will amend the style definition.

PART 2 STYLES
Next, dynamic style creation and
checking for browser compatibility

11
For convenience, you can rename the
new style. Choose Rename… from the Style

menu in the Properties palette, and, in the dialog
that appears, change the name to “firstPara”. To
apply the new class to other text on the page, simply
highlight it and choose firstPara from the Style menu.

12
To edit a style, you now need to either click
the Edit Style button in the CSS Styles palette

with the name of the style highlighted, or right-click
(Ctrl-click on a Mac) on the name of the style in
the CSS Styles palette and select Edit from the
Contextual menu. Edit the style definition for
firstPara to make the colour #660000.

13
Dreamweaver can now handily check your
pages for browser compatibility as you go

along. Open the browser check menu beside the Title
text field in the toolbar at the top of the document
window, and choose Settings. Tick Netscape
Navigator and select version 3.0.

16
In order to share the style information between
pages, you need to create an external style

sheet. This is just a text file. Choose File>New, then
choose Basic Page and CSS. Click Create. Save the
new CSS file as styles.css in the site root.

17
Open the Code view for the page you’re
working on, and locate the STYLE tag or tags

in the HEAD of the page. Highlight the contents of
each STYLE tag (but not the comments <!— and —>)
and cut/paste them into the new CSS page you
created. Save and close the CSS page, and delete
the empty STYLE tags from the HEAD of the page.

18
Now you need to link the new style sheet
file to the page. Open the CSS Styles palette

and click the Attach Style Sheet button. Browse for
the file you created and then click OK. Use link if you
wish Netscape Navigator 4 to see the attached styles,
or Import if you wish to hide them.

14
A yellow warning triangle should now appear
on the menu, indicating that Dreamweaver

has identified some incompatibilities. If it doesn’t
appear after you click back into the page, choose
Check Browser Support from the menu.

15
Choose Next Error or Previous Error from
the browser check menu to highlight the

affected areas of the page, or choose Show All Errors
to open the Reports panel and list all the problems
found. We’ve selected version 3.0 browsers only to
show the check working; these are not problems
you’d actually wish to fix, since less than one per
cent of users rely on version 3.0.

INHERITANCE
PROBLEMS
CSS properties applied to top-level elements

like BODY are meant to affect all the child

elements in the HTML; this is how the basic text

formatting is meant to work through the new

Page Properties. Netscape 4 was especially

bad at inheriting attributes correctly, and it’s

something that other browsers may also have

problems with. As long as your primary

audience has moved on from Netscape 4,

you shouldn’t have too much trouble.

EMBEDDED STYLES
The ability to define styles on the fly is great,

but Dreamweaver can’t seem to get its head

round putting its new styles into a linked style

sheet – it always embeds them in the page.

Unfortunately, if you use the automatic styles

from the Properties or Page Properties, you’ll

have to get used to moving them into your

linked style sheet as you go along.

INSIGHT

^
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EDITING STYLES
The hardest thing to get used to in MX 2004 is

that double-clicking the name of a style no

longer edits it through the Edit Style dialog.

Instead, Dreamweaver opens up the style tag

or linked style sheet for you to edit the CSS by

hand. This is good for hand-coding, but the

point of a visual editor is to use the editing

tools. Instead of double-clicking, you need to

select the style in question and click the Edit

Style button to get the Edit Style dialog. It’s

a shame the user doesn’t get a choice here.

INSIGHT

^

19
Click at the end of the page and choose
Insert>Table. Enter width: 300 pixels, rows: 3,

columns: 3, cell padding: 0, cell spacing: 0, border: 0.
Note the new options for specifying accessibility
features; these are used only in data tables. Click OK.

PART 3
TABLES AND TAGS
Dreamweaver MX 2004 offers
new table features and enhanced
access to tag attributes

22
The Tag Inspector’s Attributes panel offers
another way of setting options for selected

HTML elements, and provides the complete range of
attributes for any tag. The Properties palette is easier
to use, but only offers commonly used options.

25
Using the Relevant CSS panel, you can see
all the CSS formatting that’s applied to the

selected element. The panel is divided into two areas;
the top area shows all the Applied Rules currently
affecting the selected tag on the page. The lower
area shows the actual properties of the style that’s
selected in the Applied Rules area.

23
Click in the linked text in the second paragraph
– see how the Tag Inspector title changes to

Tag <a>. Try clicking different elements on the page,
and see how the attributes available change. List the
options alphabetically using the second button at the
top of the panel to make it easier to browse them.

24
You can use this instead of editing the code to
set specialised options. Click back on the <a>

tag in the Tag Selector, and click in the space beside
Title in the Attributes panel. Type in a brief message to
appear as a tooltip when the user hovers their mouse
over the link, then test the page in a browser.

27
Where the name of a property has a red
strikethrough, this indicates that the property

is inherited from another Applied Rule. The Relevant
CSS panel is a very powerful way of exploring the
way that the CSS rules interact with each other.

20
When a new table is inserted, the table has
new menus at the top to control the widths

and make it easier for you to insert columns in the
right place. After resizing a table, choose ‘Make cell
widths consistent’ to ensure all the cell widths add
up to the overall table width.

21
You can hide the menus by choosing
View>Visual Aids>Table Widths. Choose

View>Table Mode>Expanded Tables Mode or press
F6 to make it easier to position the cursor within table
cells – this turns on an artificial cell padding. Drag in
the images from the slices folder to try it.

26
The alphabetical list is more useful for seeing
the formatting in one go, because all the

properties that are currently set are found out of order
at the top of the list. The category list is sometimes
better for applying new properties to the rule. Try
choosing the Applied Rule “Body, TD, TH” and
setting Line Height to 20 pixels.
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TABLE ACCESSIBILITY
Dreamweaver now always offers accessibility

features when you insert a table, such as

caption, summary, headers and so on. It’s

important to remember not to use these for

layout tables, however. They’re only intended

for use with data tables. Unfortunately,

Dreamweaver still doesn’t offer any visual

interface for the more advanced table

accessibility features like ROWGROUP,

COLGROUP and header IDs.

NEW TAG INSPECTOR
This is probably the least intuitive of the new

features. The key to using the Tag Inspector is

to select the element you wish to work with via

the Tag Selector at the bottom of the document

window first. The Attributes, Behaviours and

Relevant CSS panels then offer fine control over

the settings for that tag. The confusing bit is

that if you select a CSS rule in the CSS Styles

panel, this is another valid context for the Tag

Inspector, and it changes to display only the

Relevant CSS panel so that you can quickly edit

the properties for that style rule. This can be

confusing until you get used to it.

INSIGHT

^

28
Press Return at the end of the first paragraph
to create an empty line, then choose Insert>

Image. Import the Cuillin.jpg and ensure it’s selected.

29
Choose the Cropping tool from the Properties,
and resize the cropping rectangle to outline a

square area of the image. Press Enter or click the
Cropping tool to crop the image. This affects the file
on disk. To cancel without cropping, press Esc. 31

You can now effectively create a new image
from scratch in Dreamweaver and switch to

Fireworks to customise it. Delete the heading text
“Adipiscing Elit” and choose Insert>Image Objects>
Image Placeholder. Resize the placeholder image to
make it about 150 pixels wide and 30 or so high.

32
Click the Create button in the Properties
palette to open the image placeholder as a

new untitled document in Fireworks. Using the Text
tool, type “The Black Cuillin of Skye” and format it
appropriately. Choose Modify>Canvas>Fit Canvas to
resize the image to fit the text precisely, then select
Done to return to Dreamweaver. Save the PNG file
and the GIF file in the site folder when prompted. 

PART 4
IMAGE EDITING
This version introduces several
useful image-editing features

FINAL STEP
We’ve highlighted some of the most interesting

features in DW MX 2004 in this tutorial, but
other more subtle improvements include superior
performance and stability, as well as better CSS
rendering. There are many more features to explore
– check out www.macromedia.com for details.

30
Resize the cropped image to make it smaller;
about 100 pixels wide. This is usually a bad

idea, because there are now too many pixels in the
image being downloaded. To correct this, click the
Resample button on the Properties – this applies
image-sizing to make the file the correct resolution.

33
The exported GIF is now displayed as the
page heading in Dreamweaver. Note that the

Properties palette has recorded the source PNG
image. If you now click the Edit in Fireworks button,
Fireworks will open the source PNG and re-export the
GIF, once you’ve finished working in the app.
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