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Tutorial

In our first ever Flash MX 2004 tutorial, we take a look 
at the new ease-of-use features that can turn anyone 
into a Flash guru

Starting life as an animation package for the
Web, Macromedia Flash has evolved over
time into a powerful application development
tool. This transformation has now been
re-emphasised with the release of Flash MX
2004 – an upgrade so radical that Macromedia
has had to soften the blow by splitting the
package into two versions.

Flash MX 2004 Professional introduces a
whole new way to create Flash movies based
on ‘screens’. Programmers and application
developers will find this a more familiar
approach than the package’s traditional
Timeline model. The Standard edition of Flash
MX 2004 doesn’t have this particular feature,
but it’s in no way a ‘light’ version of the
package. It’s still a full upgrade, jam-packed
with new features – most of them aimed at
making Flash faster and easier to work with.
Templates and components were introduced

in the last version of Flash and the new
release improves on these, making them
easier to build, use and configure.

The big time-savers, though, are the
Timeline Effects features and the new
Behaviours panel. Both automate tasks that
were previously the preserve of Flash experts,
enabling you to add animation and interaction
to your movies in seconds.

Follow our step-by-step tour of Flash MX
2004 Std to discover how the new features
work and get some ideas for your own work.

INFO Tutorial by Karl Hodge

ILLUSTRATION BY TADO
www.tado.co.uk

WORLD FIRST
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1
Launch Flash MX 2004 for the first time and 
you’ll notice something different straight away – 

a new Start screen. You don’t need to keep it there;
just tick the box marked Don’t Show Again if you
want Flash to start up in the old-fashioned way. 
The Start screen gives you access to recent items,
templates and Flash lessons.

PART 1 TEMPLATES
Build movies more quickly with Flash
MX 2004 templates

2
The Create From Template list gives you a series
of categories to choose from. Flash templates

were introduced in the previous version of the
application but now there are more to choose from.
Don’t be caught out, though – some of them include
features that are exclusive to the Professional version
of Flash MX 2004.

4
Other templates have page elements and
Components already embedded into them. 

Click on the Quiz folder in the Start screen and open
the second template in the list named Quiz_style_2.
The timeline is clearly labelled so you can see which
elements are on which layer.

7
Go to Window>Component Inspector – the
editable options for the Component appear in 

the Inspector. Resize the Inspector so that you can 
edit the parameters available.

8
The other Learning Interactions have their own
editable parameters that work in the same way.

You can access them through the library, by opening
the Learning Assets folder and selecting an item –
alternatively, choose Components in the Movie
Explorer. Go to the library and double-click on the 
Fill In The Blank component.

9
Launch the Component Inspector using the
button on the Properties panel and resize the

inspector so that you can enter the parameters. It’s
here that you create the actual questions for your quiz
by following the instructions within the component.
Objects can be replaced directly, as long as you retain
the established component relationships.

5
You’ll notice that some layers are locked – these
contain interaction and actions that shouldn’t be

edited. Looking through the structure of this template
is a master class in Flash movie design – every
element is categorised in the library for easy access,
and every layer is labelled.

6
Next, go to Window>Other Panels and choose
Movie Explorer. You’ll find a movie clip labelled

‘mc, frameNav’. Nested within this is a Component
which enables you to edit options within your quiz.
Simply right-click on it (or use Ctrl-click on the Mac)
and choose Go To Location.

3
The simplest templates are just documents with
the page dimensions already set up. Click on 

the Advertising folder in the Start screen – you’ll 
be shown a list of banner, skyscraper and pop-up 
ad templates at standard sizes.

LEARNING
COMPONENTS
The Learning Assets used in the Quiz 

Template example are bundled in Flash 

MX 2004 as Common Libraries. You’ll find 

them in Window>Other Panels>Common

Libraries>Learning Assets, where they can

easily be dragged and dropped into your 

own movies, and their Component elements

edited in the Component Inspector.

INSIGHT

^
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10
Third-party programs like SWiSH made 
Flash effects and animation easier. Now, 

Flash MX 2004 includes animation effects that don’t
require any timeline tweaking – all you have to do 
is select an object and change the parameters in 
the Timeline Effects dialog.

PART 2
TIMELINE EFFECTS
Animate anything without direct
timeline tinkering

11
We’ll go through those instant animation
capabilities step by step. Start by drawing a

shape on screen, then marquee around it to select 
the whole thing. Drag the object into the bottom-left
corner of the stage. Notice that as you do, guides
appear within Flash as you position the object.

12
Now, with the shape still selected, go to 
insert Timeline>Timeline Effects>Transform/

Transition and choose Transform. Note that you 
don’t have to convert the shape into a symbol first –
Flash will do that for you.

13
Looking at the Transform dialog, you’ll 
notice that all of Flash’s traditional animation

capabilities are represented. In this case we’ll animate
motion, rotation and scale. Select Move To Position
from the position dropdown menu and enter 550
pixels in the X co-ordinate box.

16
The Transition option helps you create
presentation style fades and wipes. Want to

apply one to an entire scene? Place a rectangle shape
over the stage on the top layer and apply the required
options to create full-screen transitions.

17
Exploding text is easy in Flash MX 2004. 
Use the Text tool to add a phrase or logo to 

the stage. With the text selected, go to Insert 
Timeline Effects>Effects and choose Explode. 
Now set the parameters you want in the dialog 
and Flash does the rest, breaking apart the text 
into shapes, distributing letters to individual layers
and tweening the animation.

18
The Expand Effect only works on text. Other
effects like Drop Shadow and Blur work on 

any object. Any Timeline Effect you apply can be
removed by selecting the clip on screen and going 
to Modify>Timeline Effects>Remove Effect.

14
Type ‘2’ in the Spin box to make the shape
rotate twice and set Scale to 200 degrees. Click

Update Preview to see how the animation will look
before clicking OK. The animation is automatically
created as a movie clip and placed in your movie.

15
To edit the clip directly, double-click on it to
open in the Symbol Editor. However, it’s easier

to go to Modify>Timeline Effects>Edit Effect and use
the dialog to tweak parameters again.

RENAMING
Flash automatically names animated shapes 

for you after the Timeline Effect type that you

choose. To rename the effect to something

more intuitive, you’ll have to track it down 

in the Movie Explorer or library and open the

Symbol Properties dialog.

INSIGHT

^
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ACTIONS SHORTCUTS
Now there are shortcuts for many of the most-

used ActionScript commands. Many of them

are intuitive, because they’re a combination of

the ESC key and the first two letters of the

ActionScript command. Common examples 

are ESC and st for stop(), ESC and gp for Goto

and play, and ESC and gu for getURL.

MULTIPLE CHOICE
Multiple behaviours can be added to frames 

or buttons, building up scripted responses 

to timeline events or user interactions. As in

previous versions, scripts can be exported from

the ActionScript editor for use in other movies.

INSIGHT

^

19
A major new addition to Flash MX 2004 is the
Behaviours panel. Behaviours are analogous

to Dreamweaver behaviours or actions in Photoshop.
They enable you to build ActionScript-based
interaction into your movies without having to 
edit any script manually.

PART 3 BEHAVIOURS
Button scripting is now faster in Flash
with behaviours

22
Return to the main stage and select Frame 
1 in the timeline. Go to Window>Other

Panels>Common Libraries>Button. In the library,
open the Circle Buttons folder. Drag and drop an
instance of ‘circle button – next’ to the stage.

25
Buttons can also be more easily programmed
to load URLs. Select a button and click the 

Add Behaviour button in the Behaviours panel.
Choose ‘Web’ and select ‘Go to Web Page’. Next, 
type in a complete URL and select a target window
from the dropdown.

23
With the button selected, go to the Behaviours
panel and click the Add Behaviour icon.

Navigate through the menu to Movieclip behaviours.
There’s a large list of possible behaviours that can 
be associated with a button.

24
Choose Goto And Stop At Frame Or Label. 
In the dialog that appears, enter the frame

number ‘2’ to instruct the button to go to frame 2 and
stop playing. Notice that you can target specific clips,
scenes and objects if necessary. Test the movie by
hitting Ctrl (or Command on the Mac) and Return.

20
Behaviours can be added to frames or 
objects. The list of available behaviours alters

contextually to reflect the options you can apply.
Create a new movie, select the second frame in the
timeline and hit F6 to add a new keyframe. On the 
first frame, add the text ‘Frame 1’ in large type. In 
the second frame, add the text ‘Frame 2’.

21
Go to the Actions panel at the bottom of the
screen. You can see the position of current

selection with the movie hierarchy within the 
palette. Select Frame 1 in the timeline. Click the Add 
A New Item To The Script icon. Navigate to Global
Functions>Timeline Control and choose Stop.

26
Behaviours have reduced one of the most
complex aspects of Flash down to a few clicks.

Though the package has had the capability to load
external media – from Flash movie clips to MP3s – 
for a couple of versions, Flash MX 2004 now adds 
all the necessary code automatically.

PART 4
ADDING EXTERNAL
ELEMENTS
Create streamline movies that load
external elements
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VIDEO PLAYER
The Video behaviours that are accessible

through the Behaviours panel actually control

movie clip behaviour, so they can be applied to

any animation that has been encapsulated as 

a movie clip and placed within the main stage.

The dialog for Video behaviours lets you select

any clip within the movie hierarchy. Although

the behaviour can be attached to frames, they

function best when applied to buttons.

INSIGHT

^
27

Building an MP3 player in Flash used to be
something of a torturous process. Now, all

you need is a ‘stub’ movie containing an interface 
for the player and some MP3s already uploaded 
to your Web space. Start by simply drawing two
shapes, suitable for use as buttons.

28
Select the first of those shapes, go to 
the Behaviours panel and click the Add

Behaviours icon. Choose Sound and select Load
Streaming MP3 file. Because the item you have
selected is a shape, not a symbol, you will be
prompted to convert it. Click OK.

29
In the dialog that appears, enter the full URL 
to an MP3 file stored in your Web space. If 

the MP3 file will be stored in the same folder as your
Flash movie, you can enter a relative path – but using
an absolute URL will enable you to test the file.

30
Give the file entered an instance name 
and click OK. Select the second button 

shape and go to the Behaviours panel. Click the 
Add Behaviours icon and choose Stop All Sounds
from the Sound menu.

31
Now test the movie. Clicking on the first
button you created will play the MP3 file;

clicking on the second will stop playback. To make 
the script for the first button more efficient, you could
add a Stop All Sounds behaviour to it before the Load
Streaming MP3 File behaviour.

FINAL STEP
Movie clips can be replaced just as easily,

enabling you to build up movies that include
multiple external clips. This enables you to make
your Flash movies in a more modular way,
loading in sections and discarding them – much 
as your browser loads individual Web pages. 
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