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One of Flash MX 2004 Pro’s most powerful new features is Forms-based Development. 
We take a look at an example that will start you on the road to powerful Flash applications
Flash MX 2004 Pro has a new feature that will have
traditional developers salivating, and it’s called Forms-
based Development (also known as Screens-based
Development). This new offering will also prove valuable
to those of you who have never set foot into the wild
world of traditional development…

So what is it? Simply put, it will enable you to structure
complex applications in Flash without using multiple
frames or layers on the main timeline. Instead of basing
your applications on traditional timelines, you’ll be able 
to visually lay out your application as a series of screens.
But don’t worry – you’ll still have the choice to use the
timeline or a mix of forms and timelines if you want to.

If you’re already comfortable with using the timeline
in Flash, why learn another method? Well, this is more
intuitive, it will help you clear away unnecessary code,
and enable you to jump between frames more easily.
Many traditional designers are finding themselves drawn
into Web development, and the new features in Flash MX
Pro will make this switch easier than ever.

In this tutorial, we show you how to create a simple
Website that displays two different T-shirts for customers
to browse. Please note that we use the term ‘Screen’
interchangeably with ‘Form’.

INFO Tutorial by Ryan Carson, co-founder of the Creative Fight Club known as
BD4D.

NEW RELEASE

ILLUSTRATION BY TADO www.tado.co.uk

FLASH MX 2004 PROFESSIONAL
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1As soon as you launch Flash MX Pro 2004, you’ll
be faced with plenty of choices. We’re going to

create a Flash Form Application, so choose the Flash
Form Application option under Create New.

PART 1 SETTING
UP YOUR SCREENS
We’ll start by setting up our 
Forms-based Application

2 Start by creating the basic backdrop for the
Website – a very simple GIF that is placed on the

‘application’ form on the first layer. Because this is 
the parent form to the others, its graphics appear as
the background of its child forms.

8 Click on the application form and expand the
timeline window. Add a new layer called ‘actions’.

On this layer, add the following code which will hide
form2 and 3 when the app starts:

5As in step 3, add the graphic siteRedShirt.gif to
Layer 1 on the form2 form. Make sure to include

the invisible button over the graphic – this will be
used to let the user return to the homepage.

6As in step 4, right-click on the application form
and click Insert Screen. A new form (‘form3’)

appears as a child to ‘application’. This is used to view
a close-up of the grey shirt when the user clicks on it.

3 Click Window>Timeline, then on form1, then click
Layer 1 and place siteHome.gif. This will be the

first form the user views. Add an invisible button on
each shirt – see the insight above for how to do this.

INVISIBLE BUTTONS
IN FLASH MX 2004
Create a 100x100 square. Click on the square,
then Modify>Convert to Symbol. Name it
‘btnInvisible’ and click Button. In your library,
double-click on the new btnInvisible symbol
and drag the keyframe to the Hit state, leaving
the Up, Over and Down states blank.

INSIGHT

^

if ((_root.application.form2 != 
undefined) && (_root.application.form2 != 
null)) {

_root.application.form2.setVisible(false);
}

if ((_root.application.form3 != 
undefined) && (_root.application.form3 != 
null)) {

_root.application.form3.setVisible(false);
}

This code is included in the ‘Step 8 code’ folder within
the tutorial files which  you can simply cut and paste it 
into Flash.

UNUSED ITEMS
Though not new, one of the most useful
features of Flash is the Select Unused Items 
in the Library panel dropdown menu. Clicking
this will highlight all unused items in your
library; deleting this will make your SWF 
nice and lean. Warning! Make sure to create 
a back-up of the FLA before doing this, as 
the deletion is not reversible. 

INSIGHT

^

7Next, set up the final form by adding the
‘siteGreyShirt.gif’ to Layer 1 on the form3 form.

Again, you’ll be needing an invisible button on top of
the graphic, to enable the user to navigate between
forms. Before we add behaviours to the invisible
buttons, we need to make form2 and form3 invisible
when the app starts. 4 Right-click on the application form and click Insert

Screen. A new form (‘form2’) appears as a child to
‘application’. This form will be used to view a close-up
of the red shirt when the user clicks on it.
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10
In the window that pops up, navigate to form2,
keep Absolute checked and hit OK. Flash has

now written the ActionScript needed to take us to
form2 when that button is clicked.

PART 2
NAVIGATING
BETWEEN SCREENS
How to use Form behaviours

11
Now that we’ve set up the behaviour to show
form2, we need to add a behaviour to hide

form1 (our current form). Click on the invisible button
over the red shirt again. In the Behaviours panel, click
the +>Screen>Hide Screen. Choose form1 and hit OK.
Make sure Absolute is ticked.

12
Now let’s test our movie. Hit Ctrl+Enter
(Command+Enter for Macs). Make sure that

when you click the red shirt, the larger view of the red
shirt appears and the two smaller shirts disappear.

13
To view the code that Flash is writing for us,
click on form1 and then the invisible button

over the red shirt. Hit F9 to bring up the code for that
button. As you can see, there was quite a bit of code
to knock out, so one of the advantages to using
Forms-based Development with Flash behaviours, 
is that it’ll save you time.

16
One last detail to be checked in the Show 
and Hide behaviours: the order of execution.

Make sure the Hide behaviour is above the Show
behaviour. To change the order, select one and move
it with the arrow button in the Behaviours panel.

14
Now we’ll add the behaviours on form2 that
will take us back to form1. Click form2 and then

select the large invisible button. In the Behaviours
panel, click +>Screen>Hide Screen. Choose form2
and hit OK. Make sure Absolute is ticked.

15
We’ve told form2 to hide itself; now form1
needs to be told to show itself. Select the

invisible button on form2. In the Behaviours panel,
click +>Screen>Show Screen. Choose form1 and OK.

PINNING SCRIPTS
Ever wished you could keep multiple sections

of code on the clipboard? Flash MX Pro 2004

enables you to do just that by using ‘Pin Script’.

In the Actions panel, go to the frame that has

the code you want to copy. In the Action panel’s

dropdown menu, click Pin Script or hit Ctr+=.

You can pin as many scripts as you like.

INSIGHT

^
PART 3 SCREEN
TRANSITIONS
Ready-made transitions between
Flash Screens

17
Flash MX Pro 2004 has another interesting
capability: ready-made transitions between

Screens. As with any pre-packaged animations, there
is big potential for cheesiness, but if used carefully
these will be useful, and will also save you time.

9
Click on form1, then on the button over the red 
T-shirt. Now open up the Behaviour panel. 

This is a new addition to the Flash MX 2004 suite.
Click +>Screen>Show Screen.
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20
If you look at the Behaviours panel, you’ll see 
a Transition behaviour attached to a ‘reveal’

event, making our fade-in transition play when form2
is shown. We’ll add a fade-out Behaviour when the
form is hidden. Click form2, and +>Screen>Transition. 

Computer Arts_Christmas200342

FLASH MX 
DEVELOPER CENTRE
There is an abundance of tutorials and samples

to be found at the Development Centre

(www.macromedia.com/devnet/mx/flash).

Everything from ‘Building a Tip of the Day

Application: Working with Web Services’ to

‘Building a Streaming Video Presentation with

Flash MX 2004 Media Components.’

INSIGHT

^

19
Now you’ll see the Transitions window 
pop-up. Select Fade in the list and In for the

direction. Choose a Duration (we used 1 second) and
None for Easing. Note the handy preview on the
bottom left. Finally, click OK. 22

The default value for Transition behaviours 
is ‘reveal’. Since we want this to happen 

when form2 is hidden, we need to change the event
to ‘Hide’. In the Behaviours panel, select the event
dropdown in the fade-out Transition behaviour 
and select Hide.

25
To complete the navigation to form3 from
form1, add a Show Screen behaviour to the

button, choosing form3 in the Select Screen pop-up
window (You create the Hide Screen behaviour first.)

23
Now test your movie to make sure that the
new fade-in and fade-out transitions are

working. We could’ve done all of these transitions
with traditional timeline tweens and masks, but using
behaviours is much simpler.

24
Now let’s add the behaviour to form1 to make
the grey T-shirt button go to form3. Click on

form1 and then on the invisible button over the grey
T-shirt. As in steps 9 and 10, add a Hide Screen
behaviour to the button, choosing form1.

21
Again, you’ll see the Transitions window 
pop-up. Select Fade in the list and Out for the

direction. Choose a Duration (we used 1 second) and
None for Easing. Now click OK.

26
While we’re on form1, let’s add transitions
when it is being hidden or shown. The process

is the same as 18 and 19 in this section. This time,
however, let’s choose Wipe for the Transition Style,
and Top Left for the Start Location.

18
We’ll now add a transition that will fade in
form2 when it is shown and fade out form2

when it is hidden. Click form2 and then +>Screen>
Transition. You’ll notice that we simply attached this
behaviour to form2, instead of a button.

WHAT’S IN A NAME?
One of the best ways to guard against

overwriting valuable work, whilst also allowing

you to backtrack, is Configuration Management.

It’s really just a fancy word for saving your FLA

as a new name each day you work on it. Start

with flashFileV001.fla, then flashFileV002.fla and

so on. Once your directory starts filling with old

versions, create a versions Backup directory and

put the old versions there.

INSIGHT

^
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30
It’s important to choose the names of your
forms wisely when you create them. If you

decide to change the name after you have created
behaviours that apply to that form, they won’t work.
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MACROMEDIA
ON DEMAND
Macromedia has launched an online training

resource that’s free for Macromedia Account

holders. If you don’t have a Macromedia

Account, it’s free to register. On Demand

seminars range from ‘Flash MX 2004 Family:

Using Behaviours’ to ‘Using Dreamweaver

Templates within Contribute’. All seminars

have video and audio. Head to the Website

www.macromedia.com/macromedia/events/

online/ondemand/index.html.

INSIGHT

^
27

Now for the transition when form1 is being
hidden. For an interesting effect, let’s choose

Wipe again, Bottom Right for the Start Location, and
Out for Direction. After you’ve added the transition,
don’t forget to change the Event to Hide. Repeat steps
26 and 27 for form3.

28
Click on the invisible button over the large
grey T-shirt on form3. In the Behaviours panel,

click + >Screen>Hide Screen. Choose form3 and hit
OK. Make sure Absolute is ticked.

29
The final navigation behaviour we’ll assign is
to show form1. In the Behaviours panel, click

+>Screen>Show Screen. Choose form1 and hit OK.
Make sure Absolute is ticked. Now you can navigate
between all three forms in our application.

31
To record the file’s history, click the
‘application’ form, go to Window>Timeline

and add a new layer. Call it ‘fileHistory’. Open up 
the Actions panel (F9) and add your comments.

PART 4
FINISHING UP
Create streamline movies that load
external elements

FINAL STEP
We’re done. From here, you could continue to

add more forms to extend the functionality
of your Forms-based Application. Carry on
exploring Flash MX 2004 Pro’s new Form-based
features – you’ll find that there’s plenty on offer 
in terms of functionality. 
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