
Computer Arts_January200468

ILLUSTRATION BY THS

www.ths.nu

ART92.typo  25/11/03  5:14 pm  Page 68



Computer Arts_January2004 69

Tutorial

Dreamweaver MX 2004 has many powerful features that
make building Websites easier, while also giving you
more control over the site layout. We’re going to focus on
the new set of CSS tools and capabilities: the CSS Rule
Inspector, improved CSS layout visualisation, improved
CSS rendering, improved CSS Panel, CSS-based Text
Property Inspector, CSS-based page properties and CSS
code hint pop-ups.

These tools give you an amazing amount of control
over the text and layout of Websites. If you’re curious
about whether or not to move from MX to MX 2004, 
the improved CSS rendering alone will make it worth 
the upgrade cash.

In this tutorial we’re going to adapt a template that
ships with Dreamweaver. By the time we’ve finished

you’ll be able to create a Web page, using CSS
and JavaScript to control the entire page. If you’re
accustomed to using tables and HTML font tags to lay
out your site, we’ll teach you new skills that will help
you win new and better clients.

INFO Tutorial by BD4D’s Ryan Carson.

DREAMWEAVER MX 2004
CSS TYPOGRAPHY & LAYOUT

Using CSS in Dreamweaver MX 2004 is even easier than before. If
you’re serious about designing and building professional Websites,
this is a tool that will give you an advantage over your competitors,
while also making your job more enjoyable
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6
Now we’ll create CSS Styles using the CSS Styles
Panel. In the CSS Styles Panel (Shift+F11), add a

new style by clicking New CSS Style. For Selector,
type ‘#siteName’. This is the name of the CSS style.
Tick ‘Advanced (IDs, contextual selectors, etc)’ and
leave ‘Define in: This document only’ ticked.

4
In this tutorial we’re adapting a template that
ships with Dreamweaver, as it’s a great example

of how to use CSS, HTML and JavaScript together 
to create a quality Web page. The page is going to
have a Global Nav, Global Subnav, Section Links, 
and a Feature article. Start out by typing these into
cssTest.html as simple text.

5
The amazing thing about using CSS to lay 
out your Web page, is that the code is much 

more clear and simple compared to using tables. 
If you preview the text you’ve just typed in, it looks
ridiculous. Don’t worry! We’ll be using CSS to put
those elements in their proper place.

7
At first, the sheer number of options can be
overwhelming, but don’t worry, we’ll take it 

easy at first and then tackle the more complex CSS
capabilities a bit later. Select the Box Category and
enter 16 for Padding>Top and 8 for Padding>Bottom.
Tick ‘Same for all’ on Margin and enter zero.

8
Next up is creating CSS Styles using code 
pop-up hints. We’ve inserted a Content Block 

into myCSS.css using the CSS Styles Panel. Now 
let’s try doing it in Code View. We’re going to need 
a Content Block to hold the Site Name, Global Nav
and Subnav – we’ll call it masthead. It will have the
following values: position: absolute; top: 0px; left:
19px; right: 2 per cent; width: 96 per cent.

9
Now create a third CSS element called pageCell.
This will be the area where most of the page

content is placed.  It will have the following values:
position: absolute; top: 112px; left: 2 per cent; right: 2
per cent; width: 96 per cent; background-color: #ffffff.

PART 1 SETTING 
UP THE FILES
Start by creating a new HTML file

1
In Dreamweaver MX 2004 (we’ll refer to it as just
Dreamweaver from now on), select File>New>

Basic page>HTML. Make sure that ‘Make document
XHTML compliant’ is checked.

2
Now we need to create the CSS file that
accompanies this HTML file. In Dreamweaver,

click File>New>Basic Page>CSS. As you can see, it
gives you an empty CSS file with a comment stating
that it’s a CSS Document. Now go ahead and save
these two files as cssTest.html and myCSS.css.

3
Now we’re going to attach the CSS document to
the HTML document. It’s always best to attach,

instead of embed CSS documents. This enables you
to use the same CSS document on multiple HTML
files. Hit Shift+F11 to bring up the CSS Styles Panel.
Click the Attach Style Sheet button on the bottom-
right and browse for myCSS.css.

ART92.typo  25/11/03  5:14 pm  Page 70



Computer Arts_January2004 71

Tutorial

13
Go ahead and experiment with the ease at
which you can modify the size and location 

of these Content Blocks. In Design View, select the
pageCell Content Block and drag or resize it. You’ll 
notice that Dreamweaver auto updates myCSS.css 
for you. Make sure to save before you do this, as
Dreamweaver crashed on us when we tried to undo
the changes – it pays to save regularly!

14
To get the masthead looking right, there are a
few more CSS elements to take care of. Let’s

add a globalNav and globalLink elements. The values
for globalNav are: position: relative; width: 100 per
cent; min-width: 640px; height: 32px; color: #cccccc;
padding: 0px; margin: 0px; background-image:
url(“glbnav_background.gif”). Note the usage of 
a background image.

17
If you open the Design View you’ll notice 
that the page is looking better, but it’s still a 

bit messy. Let’s add a body, link and h1 styles that 
will tidy things up for us.

PART 2 COMBINING
CSS AND HTML
Now on to the fun part

10
We’ve done lots of work setting up these files,
so let’s start laying out the page. We’re going 

to place <div> tags around our text, which will
position it on the page. In the Code View Window,
place a <div> tag around the ‘Site Name’ text.
Dreamweaver’s helpful code pop-up hints suggest
styles from myCSS.css to choose from. Go ahead 
and choose ‘siteName’.

11
Now place the two Global links and the five
Sub-Global links into a masthead <div> tag.

After you’ve done this, nest the siteName <div> 
inside the masthead <div> tag. This is one of the 
most powerful features of CSS – the ability to nest
Content Blocks. And finally, place the rest of the 
text in a pageCell <div> tag.

12
If you view the page in Design View you’ll see
the affects of the CSS Content Blocks. We 

know it’s no work of art at this stage, but it gives you 
a notion of the usefulness of CSS – creating page
layouts without building complex tables.

15
In addition to globalLink, we’re also going to
add ‘globalLink a’, ‘globalLink a:visited’ and

‘globalLink a:hover’. By adding link elements to the
globalLink Content Block, we’re able to control its 
link styles uniquely from the rest of the page.

16
Now it’s time to add the globalNav and
globalLink <div> tags to our page. We’ll be

nesting the tags inside the masthead <div> tag, just
below the siteName <div>. There is some JavaScript
in the global links which we’ll address later.

INSIGHT

^

CONTENT BLOCKS 
VS CLASS STYLES
When creating a CSS document, you can

usually divide it into two areas: Content Blocks

and Class Styles. Content Blocks are used for

placing content on the page and are prefixed 

by the hash character. Class Styles are used for

controlling typography and are prefixed by a

period. Class Styles are the only CSS Style 

that can be applied to any text in a document,

regardless of which tag it resides in.
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23
Let’s address the feature section of the page.
You guessed it – we’ll need a feature Content

Block. We’ll be using padding and margins to place
the feature on the page, while also defining a feature
h3 class for the feature title.

21
You’ll have noticed by now that we’ve set
onmouseover to call JavaScript functions.

These two functions simply change the CSS property
of something on the page to “hidden” or “visible”.

22
Now that we’ve built a function to show the
global subnavs, we need to hide them when

you move your mouse away. Thankfully, there is a
browser event called onmousemove which we can
place in the <body> tag. This executes every time 
you move the mouse. We’re going to use it to call a
JavaScript function called closeSubnav.

24
Next up is Page Name. Let’s create a
pageName content block and a h2 class to go

with it. By now, you’re hopefully more comfortable
with the padding, margin, border and font CSS
properties we’ll use for this Content Block. 

25
Last but not least is the section links area. 
We’ll need four CSS elements: the sectionLink

Content Block and the h3, a:link, a:visited, a:hover
classes. Using the power of CSS, we can even change
the background image when the mouse passes over
a link, all without tables or JavaScript.

26
The sectionLinks content block really
demonstrates the power of CSS. By placing 

a simple <div> tag around a group of links, you can
achieve very complex rollover effects, while keeping
the HTML clean and simple.

PART 3 JAVASCRIPT
Next, we’ll add JavaScript into the mix
– combining it with CSS and HTML

18
Now we’re going to tackle the global subnav.
We want this to only appear when you place

the mouse over a global link, then disappear when
you move away.

19
Let’s start by adding a subglobalNav class.
We’ll also need an a:link, a:visited and a:hover

for this class, as we want the links in the global
subnav to look unique from other links.

20
Now let’s combine the CSS with the HTML.
Add two <div> tags, with id=”subMenuItem1”

and id=”subMenuItem2”, giving them both
subglobalNav for their class attribute. Place these
inside the masthead <div>, below the globalnav
<div>. A tremendously useful CSS property we’re
using is “visibility: hidden” – this makes the global
subnav invisible until we tell it to appear.

INSIGHT

^

JAVASCRIPT AND CSS
How can you decide between making a CSS

class or a CSS Content Block? The difference 

is very subtle. If you’re using JavaScript to

control something on the page, for example 

an <a href> tag, you should use a class

(.styleName). This is because you’ll need to 

give the id attribute of the <a href> tag a unique

name so the JavaScript can manipulate it.
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FINAL STEP
All that’s left now is to hit F12 to preview your

page in a Web browser. By now you should 
have gained insight into the powerful layout and
typography features that CSS and Dreamweaver
can offer to the serious Web designer. 

31
Lastly, make sure to use Dreamweaver MX
2004’s new capability to check your CSS for

browser compatibility. If you see any red underlines
in your CSS or HTML document, mouse over them
and Dreamweaver will give you an explanation of 
the problem – convenient is an understatement!

PART 4 THE TAG
INSPECTOR PANEL
A feature not to be missed

27
Now that we’ve laid out all of the CSS and
placed it into the HTML, we can explore the

usefulness of the Tag Inspector Panel. Trust us when
we say that this is something you’ll want to make use
of. Open it up by hitting F9 or Window>Tag Inspector,
and once it’s open choose the Relevant CSS tab.

28
The reason why the Relevant CSS tab on the
Tag Inspector is so important, is because it

helps us sort out complex CSS dependencies. Click
your mouse on the globalLink <div> tag and the
Relevant CSS tab tells you that it is being influenced
by body, #masthead and #globalNav <div> tags.

29
There are two views of CSS elements that are
assigned to the current tag that is selected (the

globalLink <div> tag for our example): Category View
and List View. We generally find List View more
helpful, as it puts the elements that have been
assigned a value right at the top.

30
Now the final touches. Before we close up
shop, one last small note. If you’ve used CSS

before and are accustomed to <span> tags instead of
<div> tags, it’s best to use <div> tags, as browsers
which don’t support layers will handle them slightly
better. Make sure you check out Dreamweaver’s Help
files – they’re pretty good.

INSIGHT

^

LAYOUT VIEW
Dreamweaver MX has an amazing tool called

Layout View. You can simply draw your tables,

and Dreamweaver codes the table for you. 

Not only is it quick, it generates clean code. 

To switch to Layout View, Click View>Table

Mode>Layout Mode (or Ctrl+F6). Now open 

up the improved Insert bar (Ctrl+F2) and select

the Layout Table button.

INSIGHT

^

CONTENT BLOCKS
In addition to being able to visually lay out

tables in Dreamweaver, you can also create

Content Blocks in the same manner. To switch

to Layout View, Click View>Table Mode>

Layout Mode (or Ctrl+F6). Open up the Insert

bar (Ctrl+F2) and select the Draw Layer button.

You can resize, drag and nest these content

blocks however you like, and Dreamweaver

takes care of writing the CSS for you.

BROWSER
COMPATIBILITY
Dreamweaver MX 2004 offers even more

capabilities for checking your code for browser

compatibility. It automatically underlines

offending code pieces as you write them, 

with helpful tool tips to explain what the

problem is. If you would like to specify exactly

which browsers are checked against, select

Settings from the Target Browser Check 

menu in the Document toolbar.
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