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Colour management
with digital cameras
How do you colour-manage images that have no colour device
profiles? Sort out your digital camera concerns with Photoshop’s
profile assignment features…

igital cameras represent a
loose link in the digital
colour management chain. At
the same time, they make

colour management simpler by removing
several intermediate colour conversion
steps – film, development, scanning –
along the way. The technology for

normalising the input from digital
cameras is still to be established, but
Photoshop can help bind these devices
into a proper managed system for
photographers and prepress alike.

Unlike scanners, digital cameras 
don’t capture images with a consistent
light source of a specific hue or quality.

As a result, you can’t produce a
meaningful ICC-compatible colour
profile for a digital camera: it would only
be valid for the precise, identical
weather or studio conditions on which
the profile was based. The most that can
be done at the moment is for the
manufacturer to calibrate the camera 
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as best it can in the knowledge that the
images are destined to be viewed, edited
and printed starting from a generic RGB
colour space.

One solution to hit the market a
couple of years ago was Print Image
Matching (PIM) from Epson. A PIM-
enabled camera embeds information
about the camera settings into the photo,
such as exposure, focal length, and white
point. Then a PIM-enabled printer can

apply automatic colour corrections and
image enhancement based on this
information on the fly as the image is
printed. You can even activate the PIM
enhancements as you open these photos
into Photoshop, for printing to any
printer you like. We show you how at the
end of the following tutorial.

This approach is based on the more
widely supported EXIF 2.1 standard. EXIF
is a file format based on compressed

JPEG, as published by the JEIDA
organisation and used in just about every
current digital camera in the world. EXIF
allows for basic information about
camera settings to be embedded into
the header of photo files. You can view
the EXIF data for your digital camera
images using the File Browser window or
File Info command in Photoshop.

Since EXIF information is merely
metadata rather than comprising actual

Colour Confidence
Full-scale colour management

throughout the studio has

recently become a great deal

easier – and cheaper – to

achieve with the arrival of the

Colour Confidence suite from

TypeMaker. Instead of spending

several thousand pounds on

bespoke systems or hiring a team

of colour consultants, you can at

last do it yourself with no

specialist skills and an outlay of

just a few hundred quid.

Colour Confidence is a

modular range, the main £395

(exc VAT) Studio package

principally comprising a Monitor

Profiler utility, a hardware

colourimeter, and a test image file

with a reference print. It also

includes a utility called What

Profile? for opening digital images

that don’t have any embedded

profile. This feature gives you a

preview of how applying a new

profile will affect the image in a

comparative four-paned window.

A companion Print Profiler

package (still in final beta as we

went to press) enables you to print

copious calibration sheets, then

read the patches back in with a

spectrophotometer to create

custom ICC profiles for every

printer and every grade of paper

stock you use. You can output the

test image and compare it to the

reference print to check if the

profiles are accurate enough, and

re-profile the printers as required.

You can contact TypeMaker

on [t] 0121 604 1234.

Having output swatch sheets, Print Profiler enables you to take readings
back in through a spectrophotometer, so building the colour space
definition for a custom ICC profile.

Mac OS X users can view and rotate 3D models of the colour space supported by any ICC profile
using the ColourSync Utility (Utilities folder).

Epson’s Photo Expert site at [w] www.photoexpert.epson.co.uk provides tutorials, case studies and
galleries, many of which are aimed at generic digital camera users.
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corrective instructions or colour space
descriptions, it can only be used to
inform other software or instruct other
devices. It’s therefore customary for
digital cameras to include a colour
space reference in their EXIF data
pointing to sRGB. In Photoshop 6.0 and
7.0, this often leads to disappointing
results, since sRGB is a hamstrung
colour space compared with the broader
working space options available in the
program, such as the ubiquitous Adobe
RGB (1998).

In simple terms, opening an EXIF
photo will cause Photoshop to believe
the image has an embedded sRGB
profile, which it picks up from your
system at the moment of opening. In
reality, it doesn’t have any profile
because the camera itself is unprofiled.
Put another way, sRGB is an arbitrary
profile given to the camera’s photos, 
and you need to pick a better one if 
you want a better looking image. The
tutorial here explains how to do this, 
and how to manage the relationship
between a working on-screen colour
space and a printer colour profile, all
within Photoshop.

This re-application of a more
appropriate profile than the one
suggested by the raw EXIF header is
effectively what Epson’s PIM does but in

a proprietary fashion compared to EXIF’s
open standard. Since both PIM and EXIF
are in common use, we’ve covered them
together here, but expect these
technologies to continue developing
over the next few years. It should
become automatic on consumer
cameras and printers, and more

controllable on professional devices and
in Photoshop. Colour management on
digital cameras still has a long way to go.

Under Windows 98 and later, the ICM colour management system enables you to select multiple ICC
profiles for your printer, then choose one as the default.

Expertise provided by Alistair
Dabbs. You can contact Alistair 
on [t] 020 8464 4686 or 
[e] ali@dabbsnet.com.

Part 1: Assign the right profile
Convert your image to a specified colour profile… 

Click OK to close the Colour Settings window, and then use Photoshop’s
File Browser to locate an image that you’ve captured with a digital 

camera. Notice in the EXIF pane that the EXIF Colour Space item indicates 
‘sRGB’ as its default.

Press Ctrl-Shift+K (Windows) or Command-Shift+K to open Photoshop’s
Colour Settings dialog window. For this tutorial, set the RGB Working

Space as ‘Adobe RGB (1998)’, and Colour Management Policies for Profile
Mismatches to ‘Ask When Opening’. Or just select the Europe Prepress Defaults
from the Settings list at the top.

1
2

Ignore EXIF plug-in
If you want to set up Photoshop’s

Colour Management Policies

not to prompt you every time

there’s a profile mismatch, you

can still get Photoshop to ignore

the ‘embedded’ sRGB profile

when opening EXIF images and

apply the default working space

instead. Just install Adobe’s 

free Ignore EXIF Colour Space

plug-in. Download it from 

[w] www.adobe.com/support/

downloads/detail.jsp?ftpID=18

81 (Windows) or from 

[w] www.adobe.com/

support/downloads/detail.jsp?f

tpID=1882 (Mac).
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In the Assign Profile window, the bottom item labelled ‘Profile’ should be
selected, with the embedded sRGB profile indicated in the pop-up list. If

you wanted, you could click on this pop-up and change the embedded profile to
any other that you have on your system.

In the Convert To Profile window, the Source
Space shows the current working profile, in our

case Adobe RGB (1998) as before. In the
Destination Space pop-up, choose an ICC profile for
the printer you are about to use. You can now print
the image accurately on that printer.

You have now assigned the correct colour
profile to the digital photo for editing. Later

on, you can close the colour management loop by
setting an output profile for printing. Save the
image, then, from the Image menu, go to the Mode
sub-menu and choose Convert To Profile.

Instead, just click on the second item labelled ‘Working RGB: Adobe RGB
(1998)’. This switches the default sRGB profile to the correct working

profile – this time retrospectively. Make sure the Preview option is ticked so you
can see the difference this makes, then click OK to accept.

6 7

8 9 A less risky alternative to switching the
embedded working profile for a print profile

(steps 8 and 9) is to assign it temporarily at output.
Choose Print With Preview from the File menu, tick
Show More Options and choose Colour
Management from the pop-up.

10

Assign the right profile continued…

To prove the point, close the image and return
to step 3. Open the image as before but this

time allow Photoshop to preserve the embedded
sRGB profile. The result should look different. Now
from the Image menu, go to the Mode sub-menu
and choose Assign Profile.

When the image opens, choose the File Info
command from the File menu. Click on the

Section pop-up and pick EXIF to view the EXIF
information once again. Note that even though the
EXIF Colour Space still reads ‘sRGB’, it’s not the
embedded profile.

4 5Double-click on the thumbnail in the File
Browser to open the image. Since you’ve set

Photoshop’s working space to Adobe RGB (1998),
the embedded sRGB profile is identified as a
mismatch. Click on ‘Convert document’s colours to
the working space’, then click OK.

3

Wrong profile
solution
If you inadvertently save an

image with the wrong profile

embedded, pay careful attention

when re-opening the image later

on. At the Embedded Profile

Mismatch dialog window, you

can either accept the embedded

profile or allow a conversion to

the working space. Once the

image is open, you can still

switch back to the working space

using Convert To Profile (step 9)

but not Assign Profile (step 5).
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Whenever you configure Photoshop to use colour management then print
out from Photoshop itself, you must disable any additional colour

management features within your printer driver. This differs from one driver to
the next; here, we’ve shown the Epson Stylus Photo inkjet driver as an example.

All you need to do is click on the Profile pop-up under Print Space and
choose an ICC profile for the printer you are about to use. Instead of

replacing the embedded profile, Photoshop conducts the conversion from source
colour space to the print space on the fly.

Don’t open the image yet, though. You’ll first
need to exit Photoshop, install the Print Image

Matching plug-in (see margin note) and then
relaunch the program afresh. Click on the Import
sub-menu under the File menu, then choose PRINT
Image Matching.

To demonstrate Epson’s Print Image Matching
technology, obviously you’ll need to work with

a photo captured with a digital camera that supports
it. Locate it in Photoshop’s File Browser and check
out the thumbnail and EXIF information. This image
was taken with a Nikon CoolPix E5000.

11 12
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EXIF 2.2
This latest version of the EXIF

standard adds extra fields to hold

more information from a digital

camera about the environment in

which a photo was taken. This

allows additional automatic

colour correction to take place,

along similar lines to Epson’s PIM

technology. HP is backing EXIF

2.2 with its own printers and

cameras, and Nikon is moving its

camera range over to the new

standard too.

PIM plug-in
Epson’s Print Image Matching

plug-in for Photoshop, as

demonstrated here, can be

downloaded from [w]

www.epson.co.uk/support/down

load/pim.htm. It’s free and is

available for all flavours of

Windows from 98 to XP and Mac

OS from 8.5 through to X. More

information on how to take

advantage of Print Image

Matching can be found at 

[w] www.pim.epson.co.uk.

Part 2: Print Image Matching
Activate PIM enhancements as you open your image into Photoshop…

From the Image menu, click on the Mode sub-
menu and choose Assign Profile. Ensure the

Preview option is ticked in the Assign Profile dialog
window, then switch back and forth between
‘EPSON RGB 2001’ and ‘Working RGB: Adobe RGB
(1998)’ to appreciate the difference. ca•s

The image opens. Note how the image data
has effectively been imported into a new

document (labelled ‘Untitled-1’) rather than opened
as a file in the normal way. But to understand what
PIM has done, try switching back to a non-EPSON
source profile, as explained in the next step.

Click Open. A couple of seconds later,
Photoshop’s Embedded Profile Mismatch

dialog window appears. You can see that the PIM-
enabled camera has embedded a special EPSON
RGB 2001 profile into the image. Leave ‘Use the
embedded profile’ selected and click OK.

4 5 6

In the dialog window that appears, navigate to
the image we looked at earlier. This import

dialog will only let you open images that contain
PIM data as well as the basic EXIF information. Tick
PRINT Image Matching Preview to see a thumbnail
idea of the PIM enhancement.
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