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Customise tools
in Photoshop
Why be a slave to art tools when you can
create, customise and automate your own?
Here are four steps to interface mastery…

hen Adobe sings the praises
of Photoshop’s intuitive
interface, the company isn’t
just chanting about the way

floating palettes dock together. One of
the main reasons Photoshop is so
accessible is that Adobe has combined
the dual advantage of having lots of
ready-to-go features (such as colour
swatches and effects filters) and do-it-
yourself customisation. In other words,
Photoshop’s defaults are powerful
enough to get you started, but they can
also be customised and automated
quickly to take you to a higher level.

But while working with custom
swatches and layer styles is common
enough, many Photoshop users have yet
to explore other ways of personalising
the program. Personalisation often gets
a bad press, as if changing the look and

feel of a program is best left to anal
retentives and people with too much
time on their hands. Here, we want to
encourage you to personalise your copy
of Photoshop as a means of speeding up
your work rather than slowing it down.

This tutorial introduces the process of
customising and saving new brushes and
shapes for re-use and sharing, setting up
complex automated Actions, and even
automating the triggering of Actions
across any number of images with little
more than a click and a drag. To start
with, though, we take a look at a sadly
overlooked personalisation feature in
Photoshop known as custom
‘workspaces’. The one common thread
through these customisation functions is
that they’re intended not so much for the
most organised Photoshoppers, but
actually for the sloppiest.
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Part 1: Personalise your workspace
The easy way to keep your workspace tidy…

Here’s the result. No matter which palettes 
you had open and how they had been

arranged, everything is sent back to its original
default status and position. However, any Palette
Options settings you’ve made (such as Thumbnail
Size) will be preserved.

You can always dock, combine and close
palettes at this point, but there’s a quicker

method for cleaning up a messy screen layout. From
the Window menu, click on Workspace and choose
Reset Palette Locations from the sub-menu.

After just an hour or so’s work, it’s not
uncommon for Photoshop’s palettes to be

spread everywhere. Only the most anal retentive
among us think about docking some to the Palette
Well when they’re not being used.
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A little dialog window appears, prompting you
to give your saved palette layout (or

‘workspace’) a name. Here you can type in ‘My
palette layout’ or similar, but in this instance let’s 
say this is a good layout for handling colour
adjustment in photos, so name it as such.

A better idea would be the ability to reset the
palettes back to a layout you’d prefer, rather

than to that default layout. So arrange the palettes
as you normally like them, then from the Window
menu, click Workspace and choose Save Workspace
from the sub-menu.

By default, Photoshop remembers the status
and position of all your palettes from when

you last exited the program. If you’d rather
Photoshop launched with reset palettes each time,
press Command+K (Mac) or Ctrl+K (Win) to open
the General Preferences window and untick Save
Palette Locations.
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On the subject of workspaces, you might also
like to consider customising the content of

certain palettes and dialog windows by selecting the
Preset Manager command from the Edit menu. We’ll
explain how this works in Part 2 of this tutorial.

In just a couple of minutes, you could set up
and save workspaces for a variety of common

Photoshop tasks. Once done, you can call up the
most appropriate workspace for the job in hand
from the Window>Workspace sub-menu for instant
access to the right palettes.

Obviously that workspace isn’t appropriate for
other types of Photoshop work. For example,

when using the Brush tools, you’ll want the Brushes
and Swatches palettes prominent. So just repeat the
previous step, this time giving this painting
workspace a different name.
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Preset Manager
Although the normal place to find

the Preset Manager command is

near the bottom of the Edit menu,

it can be called up from a

number of palette menus too.

This includes the Brushes,

Swatches, Styles and (of course)

Tool Presets palettes.

Additionally, you can call it up

from the Palette menu of any of

the Tool Preset pop-ups in the

Options bar.

Brushes preview
When browsing the Brushes

palette, you don’t need to

physically click on each preset

brush in order to view its preview.

After all, this might lose any

unsaved customisation you’ve

conducted on the currently

selected brush. Instead, just let

the mouse pointer hover over a

preset name. First the tooltip

label pops up, then a second later

its preview appears in the palette.

This temporary preview clears as

soon as you move the mouse.
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Part 2: Create custom brushes and shapes
Customise and save new brushes and shapes for re-use and sharing…

With your customised brush saved under its
new name, it’s added automatically to the

bottom of the currently active list of Brush Presets in
the Brushes palette. You’ll also find it at the bottom
of the Preset pop-up list in the Options bar when
the Brush tool is active.

If you wanted to use another preset brush at
this point, you’d lose all your customisation

settings from the currently selected brush. So click
on the Brushes palette menu and choose the New
Brush command. Type in a name for this altered
brush and click OK.

Switch to the Brush tool and open the Brushes
palette. Click on the Brush Presets to view a 

list of ready-made brush styles. Click on one and try
it out. Now use the Brush Tip Shape options and
other controls to customise this brush further just as
we’ve done here.

A prompt appears, just as in step 2, asking you
to type in a name for your new brush. Take

note of two things here. First, a thumbnail of the
brush itself is shown. Second, look at the sheer size
of the brush, in this instance 310 pixels wide.

Now try this little trick for creating a new
custom brush from scratch. Open any image

and look for an interesting texture that might make
a decent brush, such as our cauliflower here. Trace
around it using the Lasso tool, then choose the
Define Brush command from the Edit menu.

You can manipulate the presentation of the
Brush Presets from the Preset Manager dialog

window (Edit menu). Here you can change the
order to move your new brush higher in the list,
switch brush sets or even use the Reset Brushes
menu to return to the default list.

As with the Brush tools, the new shape has
been added to the list presets, which are

available in the Options bar when the Custom
Shape Tool is selected. Again, you can use the Preset
Manager dialog window to move it higher in the list
for convenience.

Original vector shapes can be saved as new
presets in a roughly similar way. Here we have

converted an ‘e’ character to outlines and distorted
it. With the shape layer selected, choose the Define
Custom Shape command from the Edit menu. Name
it and click OK.

Your cauliflower brush is immediately available
for use from the presets in the Brushes palette

and Preset pop-up in the Options bar. Reduce the
brush size and play with it to obtain some
interesting variations. Just remember to save any
further customisation as a new preset.
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Brush size
shortcuts
To increase and decrease the

size (width or diameter) of a

selected preset brush in 10-pixel

increments, tap the ] and [ keys

respectively. When using

calligraphic brushes, pressing

Shift-] and Shift-[ increases and

decreases the hardness of the

brush edge in 25 per cent jumps.

Remember to use these

commands between strokes,

since they won’t work as long as

the mouse button is pressed.
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Part 3: Create repeat actions
Set up complex automated Actions…

Without further ado, you can immediately
conduct the same routine of commands to other

images. Just open any image, click on the Action
name to select it, and click on the Play Selection
button. Here, everything has been shrunk, sharpened
and posterised to the same specific values.

Photoshop will now memorise each
identifiable command and filter you carry out

in sequential order until you click the Stop
Playing/Recording button at the bottom of the
Actions palette. Here, for example, we have
reduced an image in size, sharpened it and
posterised it, then clicked Stop.

Photoshop’s default set of Actions is offered
principally as a demonstration of the Actions

feature. To better understand it, create a new Action
routine yourself. Start by clicking the Create New
Action button in the Actions palette, give it a
descriptive name, and click Record.

You can also insert a pause in the routine,
perhaps to present instructions before the

following step. Click on the command in the 
Actions palette after which you want the pause,
then choose Insert Stop from the palette menu.
Type the message you want to appear and tick
Allow Continue.

In certain instances, it might be better for the
automated Action to present you with a dialog

window so you can enter different values as
required. To make this happen, click on a command
in the Action, then click on the Toggle Dialog
On/Off icon next to the tick to activate it. 
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Historic Actions
ImageReady differs from

Photoshop in its treatment of

History and Actions.

ImageReady allows you to drag

and drop commands from the

History palette into the Actions

palette, so you can capture

something you have already

done. Frustratingly, Photoshop

won’t let you do this: instead, you

must prepare and record all

Actions deliberately, not add

them from the History palette as

an afterthought.

Just for good measure, we’ve inserted another
menu item just before the final Actual Pixels

command, this one being Fit On Screen, also from
the View menu. Now our Action will end by filling
the screen with the document window, then
zooming back out to 100 per cent for clarity.

The Insert Menu Item dialog window appears,
waiting for you to choose a menu item. In 

our case, we want the Action to end by displaying
the final image at a zoom of 100 per cent, so 
we’re inserting the Actual Pixels command from 
the View menu.

Not all Photoshop commands can be recorded
by the Actions palette, such as view options

and zoom levels, because strictly speaking they’re
not actions that edit the image in any way. You can
still insert afterwards, though. Choose Insert Menu
Item from the Actions palette menu.
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Now when you run the Action, you’re
prompted to enter values for every command

with the Toggle Dialog On/Off activated, and the
Stop command you inserted has the effect of
popping up a little message like the one shown here.
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Part 4: Batch processing
Trigger Actions across a number of images at once…

A good habit to get into is to put all the 
images you want to change into one folder –

it’s easier to manage that way – so choose Folder
from the Source pop-up window. Click on Choose
and locate the folder itself. If appropriate, tick
Include All Subfolders.

The Batch dialog window looks a bit
complicated at first, but it’s broken into three

basic sections: Play (which Action to apply), Source
(which images to apply it to) and Destination (what
to do with the changed images afterwards). Pick an
Action from the Play section to begin with.

Photoshop’s Batch processing function is an
extension of Actions, letting you apply a

selected Action to large numbers of images rather
than expecting you to open, change and save them
one by one. To start, click on Automate under the
File menu and choose Batch from the sub-menu.

By default, the Batch command always saves
images to their original file format. If you want

to incorporate a format conversion (such as TIF to
JPG), you need to include this in the Action itself.
Then tick Override Action “Save As” Commands as
shown here, dismissing the warning.

Choose a Destination for the image files after
the Action has been applied. Again, it’s easy to

manage if you select Folder from the Destination
pop-up. Choosing None leaves the images open in
Photoshop, while Save And Close saves them back
to the same location with the same file names.
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Limited Actions
Only ticked commands in an

Action will be carried out, so if

you want to exclude certain

commands from an existing

sequence without having to re-

edit it, just untick those items in

the Actions palette. To trigger just

a single command from an

Action, hold down the Ctrl

(Windows) or Command (Mac)

key and double-click on its name

in the Actions palette.

Save sets
Whether creating brushes,

shapes or actions, remember to

save them using the Save

command in the relevant palette

or Options bar pop-up menu.

These custom creations won’t

vanish when you exit Photoshop,

but saving them to your hard disk

is insurance against accidentally

deleting them or applying a

palette’s Reset command. Saved

brushes, shapes and actions can

also be shared with colleagues.

Click OK and give the droplet a name and
specify where to save it to. This way, you can

apply custom Actions en masse to any group of
images at any time simply by dragging their file icons
over and dropping them onto the droplet icon. ca•s

The Create Droplet dialog window looks
exactly the same as the Batch window, and the

same rules apply. However, it’s probably more
appropriate this time not to specify a particular
destination folder – if it gets deleted at some point
in the future, the droplet won’t work any more.

This batch can now be run straight away. If,
however, you’d like to run the same batch on

more than one occasion, you can save it as a
‘droplet’ icon on your desktop. Click on Automate
under the File menu and choose Create Droplet
from the sub-menu.
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Regardless of whether you’re changing the file
format or not, it’s a good idea to alter the file

names in order not to confuse yourself later on with
dual image versions with the same name. You can
automate the renaming process using the pop-up
lists shown here.
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