
Illustration: ??? [w] ????
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Creating an 
online portfolio
Over the next 16 pages we’ll show you how to
design and build promotional Web pages, using
Photoshop and Dreamweaver to create a portfolio
that all potential clients or employers can view...

esigners often forget how much easier the Internet can make their lives. Although
nothing truly beats seeing perfect reproductions of work within a beautifully
crafted, print-based portfolio, there can be no denying that the Web is an equally
useful promotional device. After all, it’s available to pretty much anyone in the

industry 24 hours a day.
However, for those dedicated to creating print work, dealing with a Website can be a daunting

prospect. Therefore, we’re going to lead you through the process of creating a simple portfolio
site. Although our example is centred on black-and-white photography, it’s just as suitable for
displaying graphic design or illustration examples, and the modular nature of the tutorials means
you can adapt specific elements for your own needs.

We’ll use Photoshop for creating and manipulating graphics and Dreamweaver MX 2004 for
creating the Web pages. The latter application now has vastly improved support for CSS-based
workflow, enabling you to create cutting-edge, standards-compliant Websites in Design view.

Along with the tutorials, we’ll also provide some background information on what makes a
good online portfolio, tips for creating a good Website, and common mistakes that people 
make – and that you should avoid!

D

Everything needed for you to create this
Website is included on the cover CD in
the Software\Tutorials\In The Mag\

Online portfolio folder. This includes 
the original, layered Photoshop file 
and the exported graphics (within the
Assets folder). We’ve also included the
completed Dreamweaver site so you can
compare your work against ours, as well
as a couple of the original high-res
photograph scans.

Expertise provided by Craig Grannell. 
Craig can be contacted at: 
[e] craig@snubcommunications.com 
or you can visit his Website at: 
[w] www.snubcommunications.com
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Planning, structure and design
Before you get stuck into constructing your Website, take
some time to think about what you want to achieve...

s with the creation of any piece 
of work, there are a number of
stages through which a designer
must pass when working on a

portfolio Website. Perhaps the most critical
of these is the planning stage, during which
you need to decide how the site is going to
work, what it’s going to contain, and also what
technology you’re going to use to build it.

Designers often assume that the last of
those points is unimportant, but in fact the
technology you use has a bearing on the 
final result. The difference between Flash 
and HTML is vast, not only in terms of
flexibility and limitations for the designer, 
but also in terms of usability for the end 
user. Unless you’re considering using a rather
more esoteric format (such as Shockwave),
there are effectively three technology choices
at your disposal: Flash, a tables-based HTML
site and a CSS-based HTML site.

A flash in the pan

The first of these, Macromedia Flash, is
primarily a vector-graphics-based animation
and interactivity tool. Some designers argue

Fixed layouts (such as on the Computer Arts Website)

have to be targeted at a specific resolution and don’t

expand with the browser window, but they work well for

portfolios, because the elements within are mostly

graphical and of a fixed size.

‘Liquid’ layouts such as [w] www.wired.com stretch with

the browser window. Although generally preferable to

fixed designs, their lack of fixed element placing means

such layouts often aren’t suited to portfolio sites.

that it provides you with more control over
how the finished site looks and also more
scope for interaction and visual interest.
Flash sites also tend to look identical across
platforms, although at the time of writing, the
plug-in is far slower on Macs, users of which
constitute a large part of your target audience.

It’s true that Flash can be a boon to some
Website designs, but it rarely works well for
a portfolio site – animations and eye candy
can distract from portfolio items, and the
application often doesn’t deal well with
bitmaps. (Of course, if you’re an interactive
designer, Flash may well be suitable, but
we’re concentrating on creating a portfolio
for a photographer or illustrator.)

Therefore, we end up with HTML and a
choice of tables and CSS (Cascading Style
Sheets) for layout. HTML has its limitations,
but doesn’t rely on any sort of plug-in, and
sites constructed from HTML are fairly easy to
update (especially when using a visual editing
tool such as Dreamweaver or Adobe GoLive).
Tables used to be the most common method
for layout, but they can be a pain to update,
aren’t accessible, and using CSS provides a
designer with the potential for pixel-perfect
DTP-style layout control – with everything
controlled by one external file.

Technology sort of dictates how the design
will work: with HTML (whether using CSS or
tables) you need to be thinking in terms of
‘boxes’. Even if your designs are organic in
nature, the containers for items will be
rectangular. You also have to bear in mind
that monitor resolutions vary depending on
the audience. At the bottom end, you have
800x600 (still used by around a third of those

online), but the sort of people you’re targeting
will most likely have much larger screen
resolutions. However, many of them may only
be using 1,024x768 on laptops and may not
browse at full screen, therefore making an
800-pixel-wide target a good bet. 

You need to decide whether you’re going to
have a fixed-width design or a ‘liquid’ layout,
which stretches with the Web browser window.
Although liquid layouts are widely preferred,
they don’t work well when displaying the sort
of fixed-size graphics of which a portfolio’s
likely to be composed. With this in mind, we’ll
be working with a fixed width layout, but will
ensure it looks good enough when the browser
window stretches. Working with a fixed layout
will also be more comfortable for graphic
designers and illustrators, used to working
with a canvas of specific dimensions.

Back to basics

The next step should be one away from your
Mac or PC. Sketches on paper make for faster
progress than fiddling about with, and getting
distracted by, software – as is usually the case
when working on illustrations.

You need to decide how the site is going to
be structured and what the content is going to
be. Most illustrators and designers have little
time to spend on their Websites, so it’s a good
idea to make it modular and easy to update.
Also, avoid adding superfluous elements – get
everything down to the bare essentials. 

When working on sketches for this feature’s
Website, we began with a site that had several
pages: a news page, gallery, contact details
and so on. It soon became obvious that most of

A
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This folder structure isn’t set in stone, but we

recommend setting up something similar on your 

hard drive. By doing this you can keep all the files

associated with your Website in one place.

You should always seek
permission if you want to use
material from another site...

Professional designers should already be

aware of this, but the point warrants repeating

nonetheless: copyright exists on the Web the

same as everywhere else. Therefore, don’t think

you can grab graphics or code from elsewhere

and use them on your own Website, unless

express permission has been given to do so. 

In many ways, the same goes for copying (or

‘ripping’) the actual site layouts. This is quite a

common occurrence, as shown by the excellent

[w] www.pirated-sites.com (shown below left),

and the culprits often don’t seem to realise just

how fast word travels on the Web.

On the flip-side, designers creating

portfolios often tend to get paranoid about

people stealing images for use elsewhere.

We’ve seen numerous sites where the portfolio

has been ruined by intrusive watermarks or

irritating JavaScript ‘tricks’, such as disabling

the right mouse button. Our advice is simple:

avoid all such things. Your work is protected by

copyright law, and even if some unscrupulous

scoundrel downloads your work, a compressed

low-res JPEG isn’t really of use to anyone. 

If you’re not convinced and are utterly

determined to use some kind of copyright

protection, embed it in the document itself, or

include a very succinct and relatively small

copyright statement on each image. Legally,

all you need is ‘© 2004 Yourname’ (replacing

‘Yourname’ with your name, obviously).

Arrrrr, Jim Lad, there be

plenty o’ lily-livered pirates

sailing the high seas o’ the

Internet, but Tim Murtaugh’s

Website at [w] www.pirated-

sites.com cuts the scurvy

dogs down t’ size. Aye.

Copyright laws

Although computers are great for consolidating ideas,

it’s usually best to start by working offline, sketching

ideas for navigation, page structure and layouts – just

as most illustrators do when tackling a commission.

these were superfluous: visitors are going to
be at the site to see the work and nothing else.
Therefore, we decided to hone the site down to
a single page, which will contain a brief
introduction, some basic contact details and
the gallery itself. Using JavaScript, it’s actually
possible to swap images and text on the fly,
thereby avoiding the need to create a new
Web page for each portfolio image (or, for that
matter, irritating people with pop-up windows).
It also means that the portfolio can easily be
expanded and reduced by editing a single
page. For those paranoid people visiting the
Website without JavaScript enabled, we can
create a ‘fallback’ page, enabling them to
access each image without using JavaScript.

The sketch was refined a little more and it

was then time to start working on the
computer. Before opening any software, we
created a folder structure on our hard drive,
shown in the screenshot above. Although this
actual structure is by no means set in stone,
we recommend you do something similar
when working on your own sites, in order to
keep track of development images, copy,
high-res images and the Website files.

We start the tutorial by showing you how the
layout itself was created from our sketches,
and how some of the graphics were exported.
The layout document was stored in the
Development folder, while exported graphics
were placed in ‘Web - portfolio/assets’. These
files can be found on our cover CD in the
Tutorials\Online portfolio folder.

By all means use other portfolio Websites for

inspiration, but don’t be tempted to steal

layouts, images or code.
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Measuring 
internal images
To get fully rectangular borders

in Photoshop, it’s best to place

the stroke effect inside the

image. Note that CSS borders

are placed outside an image, so

bear that in mind when

measuring your images,

particularly when working on a

pixel-perfect layout.

Taking
measurements
In the old days, Web designers

used to chop up Photoshop

layouts and stitch them back

together in a complex table, but

we won’t be doing this. Instead,

we’ll be using CSS for pixel-

perfect layout tweaking.

Therefore, between exporting 

the graphics and working on 

the Web page, plenty of

measurements need to be noted

and recorded, such as column

widths, padding and the spacing

between elements. 

The layout works well, but looks too basic and
stark. Therefore, open up one of the high-res

photographs (grids.jpg, found in Development\hi-
res on the CD) and place it over the black column.
Change the blend mode to Difference and the layer
opacity to 15 per cent. Using a combination of a
layer mask and the Gradient tool, soften the effect
further, providing the essential balance between a
much-needed texture and a subtlety that won’t
distract from the main image.

Add a temporary image to the right-hand
column and resize it accordingly. Then add a

border by using Layer Style>Stroke, a Photoshop
feature that’s handy for rapidly experimenting
with border styles (we’ve gone for a one-pixel
white border). Note, however, that borders for the
site will actually be done in CSS, not Photoshop –
this is just for the mock-up. Underneath the
image, add a title and brief description.

In the left-hand column, add some random
placeholder text in a font you’re likely to use

on the final Web page – Verdana, for example. As
we said earlier, there are very few Web-safe fonts
and this is perhaps the best of them – it’s certainly
very readable on screen. Add a list for where links 
to portfolio images will be, and also place contact
details in this column.

4
5

6

Part 1: Creating the layout
We take the most advanced of our layout sketches and create a
Photoshop mock-up from which to export graphics...

Add the site’s title and orientation – after all, 
it never hurts to explicitly say what a site’s

about. For maximum contrast, use tones that are
the opposite of the background colour. Choose a
basic sans-serif font (we’ve used Gill Sans), which
looks reasonably stylish but won’t distract from
the content. Underneath the content in the black
column, add a single-pixel white line to separate 
the main title from the content.

Create a new Photoshop document and save it
as layout.psd in your Development folder. This

document should be larger than your smallest target
width of 800 pixels, so that you can design around
this area. Put guides in place to set the overall layout
width (just under 720 pixels – a ‘safe’ size that takes
into account browser toolbars at 800x600). Create
the two columns mentioned in the previous step
and fill their backgrounds accordingly.

Here’s the sketch on which we’re going to
base our Website’s layout. The thin column on

the left contains an intro and links that will load the
images in the larger area on the right. To maximise
contrast in each case, the left section will be black
text on white, and the right section will have a black
background so that the images stand out.

1

2 3

Part 2: Exporting graphics for use on a Website
We now show you how to export graphics using Photoshop’s Save for Web
function, avoiding the old-fashioned slice-to-tables method...

Go to File>Save for Web and you’ll see the
depicted dialog box. Using this dialog, you 

can compare and contrast various output settings
against your original file. When working with
single-colour text such as this, the best format for
export is GIF – not only does it produce the smallest
file size, but it also locks all of the colours, thereby
avoiding the lossy compression artefacts often seen
in JPEGs. This is saved as mh_black.gif.

Although Photoshop has a Slice tool, we’ve
already mentioned that we want to avoid

chopping up a layout and then reforming it via a
complex table. Therefore, you need to export very
specific items. The first graphic to export is the
‘BLACK AND’ text from the left-hand column.
Flatten the layout, use the Marquee tool to select
the ‘BLACK AND’ text and the space above it, then
copy it to a new document.

Prior to exporting any graphics, it’s a good
idea to make a copy of the layout document.

This is so that you don’t overwrite the original
layered file with the flattened files you’re working
on. Therefore, save the document into the
Development folder as ‘layout_to_export.psd’.

1

2 3
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Go to File>Save for Web to bring up the
depicted dialog box. This image has subtle

gradients, but they are in greyscale, which GIF 
can deal with, and it’s certainly a suitable format 
for the text. However, for such an image, a GIF’s 
file size would be too large, so try using various
levels of JPEG compression until the result looks
suitable. Because this is a portfolio site, you can
perhaps get away with a larger file size than you
would on a typical Website. The file name for this
image is mh_white.jpg.

Use the Layers palette to turn off all layers 
that are over the background (in other words,

turn off the temporary photograph and its
associated caption). Then, as before, select the
relevant portion of the layout and copy it to a new
document, as shown. Take care with the guides,
ensuring you don’t cut off the edge of any text;
zoom in to make sure this won’t happen and tweak
guides as necessary.

The next graphic that needs exporting is the
background for the black column. Go to

File>Revert or use the History palette to ‘unflatten’
the layout document. Use the Eyedropper tool to
discover where the gradient on the background
image totally merges with the background and 
add a guide at that point.

Due to the edges of the original photograph
being slightly ragged and also because such

manual rotation of an image is never totally
accurate (resulting in anti-aliased edges), the
image needs to be cropped slightly. Use the Crop
tool and drag the entire size of the image, then
hold Shift+Option (Shift+Alt in Windows) and
drag a corner to reduce the selection, maintaining
the same aspect ratio.

Most adjustments to the image should be done
at print resolution, because Photoshop has

more pixels to play with. The image – scanned as
portrait – needs to be flipped 90 degrees clockwise.
Because the scan wasn’t totally straight, guides need
to be added and the photograph rotated manually
until the bars line up with the guides.

The next thing to do is prepare all of the
portfolio images. We’ve included a couple 

of the originals, which can be found in the
Development\hi-res folder in the Online portfolio
folder on the cover CD. The alley_bars.jpg
document comes direct from a scan of a photograph
and is unchanged. As you can see from the screen
grab, it’s far too big for a Web page, has the wrong
resolution and is also a bit wonky.

Finally, the image needs to be exported via
File>Save for Web. Bear in mind when creating

a portfolio Website that people are choosing to
download the images (often one image at a time).
Don’t compress them too much, otherwise your
work will suffer and the viewer will subconsciously
link your work with low quality. However, don’t
force viewers to download files that are too large
either – they’ll get bored and go elsewhere.

As anyone familiar with digital imagery will
know, reducing an image from something

created for print to a small document fit for the Web
means a loss of detail. Bring this back by using the
Unsharp Mask filter, trying various amounts until
the result looks satisfactory. Remember that JPEG
compression in the following step will produce
artefacts, so don’t overdo the sharpening.

You now need to reduce the image’s
dimensions and resolution to that required for

your Website. Note that when using Image>Image
Size and reducing images, Photoshop will anti-alias
the edges of the image. Therefore, either set the
image size to two pixels larger than needed and
then use Image>Canvas Size to trim it further, or
flatten the image prior to resizing it. The target size
is 500x330 pixels at 72 pixels/inch.

4

5

6

7

8

9

10
11

12

For a tidier site
We’ve ensured that all of our

portfolio images have the same

dimensions, making for a neater

site. This isn’t always possible,

but you should at least attempt to

get all of the widths to be the

same when using a fixed-width

layout design.

Use RGB
Images for the Web should be in

RGB, the colour system used for

screen display. Don’t try to put

CMYK (print-optimised) JPEGs

on the Web.
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Working with the Web
You’ll need to give some thought to Web design software, standards and
hosting before launching into the next stage of your site project...

ith the layout designed and
graphics exported, it’s time to
start building the Website. One 
of the first things to consider is

which software to use, and such a decision
will be down to how comfortable you are with
specific working methods. Undoubtedly, the
best way to work with sites of a few pages or
less is with a text editor (such as BBEdit or
HomeSite). This provides you with the greatest
degree of control over the mark-up, scripts
and code within your site, but such things
tend to be alien to many graphic designers.

At the other end of the scale are WYSIWYG
or ‘graphical’ Web design applications. Most
of these provide a straightforward interface,
familiar to designers using the likes of XPress,
FreeHand and Photoshop. But, until recently,
such Web-design tools had a habit of kicking
out appalling, bug-ridden and obsolete 
code, thereby hindering compatibility. The
arrival of the latest versions of GoLive and
Dreamweaver has changed all this, and 
the latter in particular comes highly
recommended for producing cutting-edge
Websites that adhere to Web standards. 

You’ve got to have standards

Those advocating Web standards have come in
for plenty of flak in recent times and this is due
largely to many CSS-based Websites looking

like plain vanilla blobs. However, as the likes
the Jeff Zeldman continually state, using
standards shouldn’t affect the quality of the
visual design, but should ensure greater
compatibility and faster loading times for your
sites. Standards-compliant sites also tend to
be ‘future proof’.

You should also bear in mind that there are
other conventions that must be adhered to
(see ‘Common errors’ on the opposite page).
One point that needs expanding on is that
related to copy. Print-oriented designers often
find the lack of ‘Web safe’ fonts restrictive. 
The temptation is to render everything as a
graphic, but this results in poor usability and
readability, not to mention the fact that
graphical text is a pain to update. Therefore,
you should stick with Web-safe fonts for your
body copy. (Note on the previous page how we
only exported the large headings and not the
rest of the copy.)

The best available fonts are Verdana,
Trebuchet MS and Georgia, although you can
also use Arial, Times New Roman, Courier
New and – if your sanity has taken a vacation
– Comic Sans MS. Mac users running OS X
should take note that system-wide anti-
aliasing doesn’t exist by default on all Windows
machines and some earlier versions of the Mac
OS. Therefore, take care when sizing body copy
and weigh up the pros and cons of whether to
use graphics for display copy.

If someone you know is still under the misapprehension

that CSS means bland and unappealing designs, point

them in the direction of [w] www.csszengarden.com.

This site uses identical XHTML (no tables) combined

with dozens of CSS files to showcase the very best 

of standards-compliant Website design.

W
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Sure, this is a spoof site, but it still manages to

highlight the worst of Web design, including: poor 

use of space and conventions, appalling usability 

and incorrect emphasis. Point your browser at 

[w] www.ecn.bgu.edu/users/gas52r0/Jay/home

.html to see it in all its ‘glory’.
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Many hosting companies offer Web hosting and domain

names for as little as £30 per year, so there’s really no

excuse for publishing your site on free Web space with

a hard-to-remember URL. See also page 46 this issue.

Common errors

POOR USABILITY

What’s obvious to you may not be to others. 

Keep navigation and access to your work as

straightforward as possible and avoid gimmicks.

Test the site on others (preferably those who

rarely use the Web) before it goes live, taking

heed of any criticism.

MISUSE OF CONVENTIONS

The Web has numerous standard conventions, and

breaking them causes confusion and results in

inferior Websites. One example is underlining text

– underlined text online is associated with links,

not inactive copy. Another is with navigation,

which should typically sit towards the top of a

design and in the same place on each page.

INCORRECT EMPHASIS

The aim of a portfolio is to advertise your work.

Therefore, your output should be prominent –

don’t make the mistake of distracting from the

work with the site’s design, or making portfolio

items too small to make out clearly.

TEXT AS GRAPHICS

You can render display copy as a graphic (so long

as you include the ‘alt’ attribute), but don’t do so

with body copy or it can’t be printed out at a high

quality or copied to a text-based application. 

LEGACY CODING 

If you’ve dabbled a little with HTML in the past,

get yourself up to date at [w] www.w3schools.com

or use a modern Web-design application.

Photoshop moves on, and so do Web standards.

For instance, you definitely shouldn’t be using font

tags in this day and age. 

NOT TAKING TIME

Your Website is an advertisement of your ability

and professionalism as much as your work is – so

don’t rush things. A scrappy Website does more

harm than good, even if your work is amazing. If in

doubt, get a specialist to put together your site.

NOT TESTING THOROUGHLY

Web browsers have individual quirks and bugs, so

test your site in as many as possible. A suitable

test suite comprises IE6 and 5.5/Windows,

IE5/Mac, Mozilla, Opera and Safari. You don’t

have to make all pages look identical in each –

just ensure they work and look good enough.

LACK OF UPDATES

A Website is a living thing and users will assume

yours is dead if you don’t update it. Each month,

add recent work, and avoid placing emphasis on

dates – few things look worse than seeing ‘last

updated’ followed by a six-month-old date.

Hosting and publishing

We should also briefly mention hosting and
publishing your Website. The first thing is that
there really is no excuse these days for not
having your own domain and domain hosting.
Don’t skimp on this and use free Web space or
register a domain that forwards to free space.
Companies such as clara.net offer a domain
name and hosting from as little as £30 per
year, and many broadband providers will
include similar services with your account.

When looking for a domain name, choose 
a name that is easy to communicate to 
people. For instance, in the case of Snub
Communications, snubcommunications.com
is better than snub-communications.com or
snubcomms.com. When hyphens and variants
of the name come into the equation, things can
get complicated. Likewise, try to avoid sub-
domains, such as [yourdomain]. uk.com and
always check to see if your chosen name is
already in use but with a different suffix. After
all, people often accidentally get these wrong
when typing them into a Web browser; if the
.com of your .co.uk domain is a competitor, a
user might get confused and contact them
instead – or, worse, the .com might be a
porn site, thereby associating you with that,
however unfair that might seem.

With regard to publishing, most Web-
design applications have some kind of built-in
tool for synchronising local and remote sites,
although a dedicated FTP client usually
knocks these for six and is worth purchasing.
(Transmit for OS X is our favourite Mac client;
WS_FTP is a dependable one for Windows.)
Always ensure you don’t merely have an online
version of your site – keep a local version too.
And remember to take regular back-ups, so
you can revert to a previous version of the site
if something goes wrong.

Text-based Website editors such as BBEdit (above)

and HomeSite aren’t for the faint-hearted. However,

improvements to visual editors now enable designers

to use a WYSIWYG environment to create cutting-

edge, standards-compliant Websites.

Watch out for these eight easy-to-make mistakes...
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Part 3: Setting up your site and adding page defaults
Use Dreamweaver to set up the site and some application preferences,
followed by the defaults for your Web pages...

Accessibility
One of the guiding principles of

the Web is to make information

more readily available to all, and

that should include users with

disabilities. The World Wide Web

Consortium has published

Accessibility advice and

guidelines which don't take a lot

of work to implement, if you keep

them in mind right from the start.

So when you build your site,

remember to include 'alt' text to

describe image map links, so that

visually impaired visitors who

may be relying on screen reader

software can make sense of

them. Ensure that body text can

be resized, so that viewers can

enlarge it if they need to. When

you create hypertext links, try to

use text that makes sense, never

just 'click here'. And structure

your site so that it is possible to

tab through structural elements,

not just click on them, so that

people who find it difficult to use

a mouse can still get around it.

For more advice, visit the Web

Accessibility Initiative site at

[w] www.w3.org/WAI/

To set document view preferences, you have
to open a new document. Go to File>New to

bring up the New Document dialog. Select Basic
page from the category list and then HTML from
the Basic page list. Ensure that ‘Make document
XHTML compatible’ is selected (XHML is the most
recent mark-up standard). Click Create and
Dreamweaver will open a new document for you.

Go to Preview in Browser and add your
installed browsers to the list. For each one,

click on the plus sign to bring up the Add Browser
dialog, then click Browse and select the relevant
software on your hard disk. Note that you can
specify primary and secondary browsers, which
are afforded keyboard shortcuts. Do not just rely
on Dreamweaver’s Design view or, for that matter,
Internet Explorer. As we’ve said elsewhere, you
need to test your site in a range of browsers, and
preferably on both Windows and Macs.

Under General preferences, ensure the correct
spelling dictionary is selected (there are various

options for English, for instance) and then go to the
Code Format category. The most important thing
here is Automatic Wrapping, which should be
turned off. This ensures Dreamweaver doesn’t place
hard breaks in your code, which can sometimes lead
to layout errors and also make Web page content
trickier to update.

4

5

6

Dreamweaver is a powerful and complex tool,
so you need to ensure it’s set up correctly. By

and large, its default settings are pretty good, but
there are some that need changing. Cmnd+U
(Ctrl+U in Windows) brings up Dreamweaver’s
preferences. By default, Dreamweaver’s accessibility
settings are turned off, so access that category and
check the Images and Media boxes. The former
makes Dreamweaver prompt you for ‘alt’ text when
you add an image.

Click the folder icon to the right of the Local
root folder field and navigate to the Web

folder within the structure created earlier. Select it
and click Choose (OK in Windows). Take care not to
choose the assets folder! At this point, you can also
set up information for your hosting space, by going
to Remote Info, selecting FTP from the drop-down
menu, and then inserting the relevant information
about your Web space. Click OK and Done to finish.

Prior to working on the Web pages, you need
to set up your site. Go to Site>Manage Sites

and in the resulting dialog box, go to New>Site.
Click on the Advanced tab and in the Site name
field, input your site’s name (we’ve used ‘Computer
Arts Projects portfolio’).

1
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Both of these documents must be attached to
the Web page. To attach the CSS file, bring the

HTML file to the front and select Manage Styles
from the Properties Inspector’s Style drop-down
menu. In the resulting dialog box, click Attach.
Browse to and select your file, select the Import
radio button and click OK. (Using Import to attach
the CSS file hides the CSS from obsolete browsers,
ensuring your Web page is accessible to all Internet-
enabled devices.)

Go to File>Save As and Dreamweaver should
automatically navigate to the root of your

Website. Save the file as index.html, taking care to
alter the default Dreamweaver suffix (.htm). You
should see your document appear in the Files
panel (accessible via the Windows menu, if the
panel is not active). Create two more files by going
to File>New: a CSS file and a JavaScript document,
Save them in the site root as blackandwhite.css
and global.js, respectively.

Choose Split view from the document toolbar.
Dreamweaver purists sometimes balk at this

view, but we reckon it’s a Godsend: it enables you to
work in Design view and check whether code has
been applied correctly – something that’s essential
when positioning divs or working with templates.
Click the View Options button and turn everything
on in Visual Aids and at the foot of the menu, as
shown. This will ensure that code displays in a
readable manner and that Design view aids are on.
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Next, add meta tags to assist search engines
in finding and filing the site. This is done via

the Head icon drop-down menu within the Insert
bar’s HTML selection. Simply choose Keywords
and Description from the menu and input the
relevant content. For the former, choose
approximately 30 non-generic keywords or
short phrases; for the latter, provide a very
succinct description of your Website.

Go to View>Head Content and a small icon 
bar will appear between Design and Code

view. This provides easy access to invisible content
in the head of your Web page. Click on the Title
icon and add a document title (such as ‘BLACK 
AND WHITE – a photography site’). If you don’t
amend this title, your document will be called
Untitled Document when opened in a Web browser
– very unprofessional.

It’s best to attach JavaScript by using the Code
section of Split view. Click after the first meta

tag and hit Enter. Select the HTML set on the Insert
bar and click the Script button. Click OK and mark-
up will be added to the document. Click after ‘script’
in the opening tag of this mark-up and hit space to
bring up the Code Hints menu. Choose ‘src’, then
use Browse to find your JavaScript document and
click Choose (OK in Windows) to attach it.

10 11 12

IDs and classes
When working with CSS, you

typically work with IDs and

classes. The difference between

these is that IDs can be applied

to only one element, but can be

targeted by scripts, while classes

can be applied to multiple Web-

page elements. Therefore, for

major structural elements (the

navigation area, and so on), we

tend to use IDs, since there is

only one of these on a page. For

repeated elements, it’s common

to use classes. Note that you can

also create CSS definitions for

any HTML element.

Naming
conventions
Throughout this tutorial we’ll be

using the following naming

convention for things like CSS

IDs and editable regions:

wordWord. This is simple to

remember and read, and ensures

we avoid ‘dangerous’ characters

such as spaces and underscores. 

Part 4: Working with basic page structure
You can now start working with divs and CSS in order to
create the basic structure of the Web page...

Add another div tag in the same way for the
right-hand column. This time in the Insert Div

Tag dialog, type rightColumn for the ID. Because
we want this to come after the leftColumn div in
our structure we choose ‘After Tag’ and <div
id=”leftColumn”> from the Insert field. Click OK
and you’ll see the div placed in the correct position.

Dreamweaver’s CSS workflow is logical: you
first use the Insert Div Tag from the Layout

selection of the Insert bar to add HTML divs to the
Web page, and you then style them using the CSS
Style Definition dialog. First, then, click somewhere
in Design view, then click the aforementioned Insert
Div Tag button. In ID type ‘leftColumn’ and click
OK. You’ll see the div added to Code view; it’s also
populated with dummy content, so you can tell
where it is in Design view.

Prior to dealing with the Web page layout’s
structure, you need to revisit the original

mock-up, in order to see what’s required.
Essentially, there are two columns, but these
should sit in the centre of the screen. There are
various ways of achieving this, but what we’re
going to do here is create two columns that
stretch to the width of the browser window and
then place our fixed content within them.
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Click Apply and OK and you should see the
columns set up in Design view. As you can see

in the above image, there are now two columns,
both of which have been floated left, therefore
placing them side-by-side. Both have taken on the
property values defined in the previous step. The
benefits of this system should be obvious: all these
settings can be changed (site wide) just by editing 
a single CSS file.

Here, we set property values for our chosen
div. In Background, choose white (#FFFFFF)

for Background colour (you can use the pop-up
colour picker). In Box, set Width to 31 per cent and
Float to Left. Click Apply and OK. Follow the same
procedure for the second column, but instead type
#rightColumn in the Selector field. Other differences
for this column are the background colour, which
should be black (#000000), and the width, which
should be 69 per cent.

You now need to style these divs using CSS.
Go to Style>Manage Styles in the Properties

Inspector, then click on New. In the New CSS Style
dialog, choose Advanced as the Selector Type,
then type #leftColumn in the Selector field. (For
CSS rules, IDs must be preceded by a hash sign
and classes by a period.) Click OK and the CSS
Style Definition dialog will appear.

4

5

6

CAP55.tut_folio  20/1/2004  7:01 PM  Page 39



Presenting yourself: Online portfolio40

Part 5: Continuing page structure
You now need to add two more divs to complete the page structure. 
These divs will be containers for the Web-page content...

Bring up the New CSS Style dialog and
choose Advanced as the selector type. Type

#leftContent into the Selector field, taking care
not to omit the hash sign. Click OK. In the CSS
Style Definition dialog, go to Background and set
Background colour to white (#FFFFFF). Then go to
Box and set Width to 195 pixels (a measurement
taken from the mock-up). Set Float to right,
because you want the content of this column 
to sit at the right of its container.

Select the content in the leftColumn div and
delete it, taking care not to delete the div itself

(check in Code view). Then insert another div as
previously, this time with an ID of leftContent.
Because you’ve just deleted content from the
leftColumn div, the cursor is in the correct position,
so leave Insert as ‘At insertion point’. Click OK to
continue. Look at Code view: the new div should be
nested within the leftColumn div.

Already, there are things that need amending
– the columns don’t sit flush to the edge of the

Web page. Therefore, you need to set property
values for the body tag. Open up the New CSS
Style dialog again and choose Tag as the Selector
Type. Choose body from the drop-down menu and
click OK. In Background, set Background colour to
black (#000000). In Font, set Font to ‘Verdana,
Arial, Helvetica, sans-serif’ and Size to 11 pixels.
Finally, in Box, set Padding and Margin to 0.
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Under Padding, uncheck ‘Same for all’ and set
the values to 135 pixels, 0, 50 pixels and 19

pixels for Top, Right, Bottom and Left respectively.
In Background, set Background colour to black
(#000000). For Background image, Browse to and
choose mh_white.jpg (from the assets folder), set
Repeat to no-repeat and Horizontal position and
Vertical position to left and top respectively. Note
that when you return to Design view, your columns
might sit one under the other on a small monitor.

Once again, bring up the New CSS Style dialog
and choose Advanced for the selector type.

Type #rightContent into the Selector field and click
OK. In the CSS Style Definitions dialog go to Box
and set Width to 521 pixels – gain, a measurement
taken from the mock-up.

Now add a div for the content in the right-
hand column. Again, select the content in

rightColumn and delete it (using Code view to 
help, because the content is black on a black
background). This time in the Insert Div Tag dialog,
type rightContent for your ID name.
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Part 6: Adding content to the left column
Use the left-hand column for introductory copy, the portfolio links and contact details...

Working with
margins
A good rule of thumb when

working with page element

margins is to set the top margin

to 0 and control spacing using

the bottom margin.

Use the Properties Inspector to add a list of all
the portfolio images. These will later be turned

into links and the list itself will be styled to remove
the bullet points and margins. Do not just use a
normal paragraph and carriage returns to create 
this list, because this results in poor, non-semantic
mark-up and reduces formatting flexibility later on.

Hit the right arrow to deselect the image, then
hit Enter. Dreamweaver automatically creates

a blank paragraph. Use this to add some body copy
to the left-hand column, separating paragraphs by
hitting Enter. Text formatting can be altered by
using the Format menu in the Properties Inspector.
Note that if you type or paste non-standard
characters into Design view (such as smart quotes
from Word), Dreamweaver automatically converts
them into HTML equivalents.

In Design view, select and delete the content
from the leftContent div. Choose the Common

selection from the Insert bar drop-down menu and
click the Image icon. Choose Image from the drop-
down menu. Navigate to mh_black.jpg in the assets
folder and click Choose (OK in Windows). In the
subsequent dialog box, type some Alternate (alt)
text for people using alternate browsers or screen-
reader software. Click OK and the image will be
added to the Web page.

1 2

3

CAP55.tut_folio  20/1/2004  7:01 PM  Page 40



Presenting yourself: Online portfolio 41

Block elements, such as paragraphs, always
have default margins around them and this

can vary from browser to browser, so we need to
set specific margins. In the New CSS Styles dialog,
choose Tag as the selector type and type ‘p’ in the
Tag field. In the CSS Style Definition dialog, go to
Box and deselect ‘Same for all’ under Margin. Set
Top to 0 and Bottom to 1ems.

Adding a class to an inline element can be
done in several ways. First, select the target

object in Design view (in this case, the ‘BLACK
AND’ image). Then do one of the following: select
the relevant class from the Properties Inspector’s
Class menu; or double-click the relevant class in the
CSS Styles panel; or go to Text>CSS Styles and
choose the relevant class; or right-click the relevant
tag in the status bar and go to Set Class>[relevant
class] (as depicted).

You should now start using CSS to set very
specific spacing between the page elements.

The first of these will be to set the spacing
underneath the image at the top of the left-hand
column. Open the New CSS Style dialog and
choose Class as the selector type. Type .blackand
(including the period) into the Name field. Click
OK. In Box, deselect ‘Same for all’ under Margin
and set Bottom to 18 pixels.

4
5

6

Next, style the list. This is done by creating
the contextual selectors #leftContent ul and

#leftContent li. For the latter, set all padding to 0.
For the former, set top and bottom margins to
2ems and left margin and left padding to 0. Under
List, set Type to none. This removes the standard
bullet from list items.

Click OK and you’ll once again see the CSS
Style Definition dialog box. In Box, uncheck

‘Same for all’ under Padding and then set Right to
10 pixels. Click Apply, and paragraphs within the
leftColumn div acquire padding to the right. At this
point, the ‘BLACK AND’ image is within a
paragraph, so you should select it, hit the left arrow
and then set Format to None in the Properties
Inspector – the image should have no formatting.

If using a small monitor, expand the document
window until the columns sit side by side.

Note how the text in the left-hand column hugs
the dividing line. You don’t want this to happen, but
also don’t want to set padding on all paragraphs, so
instead use a contextual selector. In the New CSS
Style, set Selector Type to Advanced and type
#leftColumn p in the Selector field. (This effectively
means ‘all paragraphs within the leftColumn div’.)
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Each of the four link states – link, visited, hover
and active – can be amended, creating rollover

effects. In the New CSS Style dialog, choose
Advanced for the selector type and then a:hover
from the Selector drop-down menu. In the CSS Style
Definition dialog, set Colour to #555555. Don’t
leave off the hash sign – Dreamweaver will still show
the hover colour, but many browsers won’t.

If you look at Design view, you’ll notice the
email link has the standard blue colour. Like

every other page element, this can be changed. In
the New CSS Style dialog, choose Tag for the
selector type and type the letter ‘a’ into the Tag
field (<a> is the HTML anchor tag). Click OK 
and, under Type, set Weight to bold and Colour to
black (#000000).

Now change the email address into a live link.
This is done by selecting the link and typing

into the Link field ‘mailto:info@thisdomain.com’
(replacing info@thisdomain.com with your email
address). Note that email addresses online are often
harvested by spammers. You can combat this by
going to http://hiveware.com/enkoder_form.php
and using Enkoder. The results can be pasted into
your Web page in place of the entire link (using
Code view).

10
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How margins work
By default in CSS, margins

collapse rather than accumulate,

so the bottom margin of 1em on

paragraphs and the 2em margin

at the top of the list don’t

combine to 3em – the final

margin is simply the greater of

the two: 2em.
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Part 7: Adding content to the right-hand column
You now need to add content to the black area of the page.
Introduce the portfolio image, title and caption...

Cut and paste
If you don’t fancy working through

the JavaScript, just cut and paste

it from the example site on this

month’s cover CD.

Select the image in the rightContent div, hit the
right arrow and then Enter. Type a title for the

image, hit Enter and then type a caption for it. Some
of these elements now need reformatting. Select the
image, hit the left arrow and choose None from the
Properties Inspector’s Format menu. Select the title
(you only have to click inside it) and choose Heading
1 from the Format menu. The title will ‘vanish’
because it’s currently black on a black background.

You now need to define the style for
paragraphs in the rightContent div. This is

done via the usual means – a contextual selector. In
the New CSS Style dialog, the selector type should
be Advanced and called ‘#rightContent p’. The only
thing to define in the CSS Style Definition dialog is
the Colour, which should be white (#FFFFFF). The
reason for defining this now is that we’d otherwise
be working with black text on a black background.

Select the content in the rightContent div and
delete it, again taking care not to delete the

div itself (use Code view to assist). Use the Image
icon to add the first portfolio image, from the
assets folder: 1_alley_bars.jpg. Add some alt text
in the Image Tag Accessibility Attributes dialog
(something like ‘portfolio image’). Click OK. Note
that the image should be correctly positioned
thanks to the padding settings defined earlier.
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Here is the result. The paragraph hugs the
bottom of the title and the latter is rendered in

uppercase regardless of what’s written inside the
tag. You could have achieved the same effect by
formatting everything as a paragraph, typing the
title in uppercase and setting a carriage return
between the title and caption. However, our use of
semantic mark-up is more flexible and means that
all this formatting can be changed easily in future.

Next, open the New CSS Style dialog and
add another contextual selector to our CSS

file, to define the title, formatted as Heading 1.
Choose Advanced for Selector Type and type into
the Selector field: #rightContent h1. In the CSS
Style Definition dialog, choose ‘Arial, Helvetica,
sans-serif’ for Font, 12 pixels for Size, bold for
Weight, white (#FFFFFF) for Colour and uppercase
for Case. Under Box, deselect Same for all under
Margin and set Bottom to 0 pixels.

Now style the image. This is done via another
contextual selector. In the New CSS Style

dialog, choose Advanced for the selector type and
type #rightContent img into the Selector field. In
the Border category leave ‘Same for all’ checked in
all cases and set Style to solid, Width to 1 pixel and
Colour to white (#FFFFFF). When you click OK and
Done you should see a thin white border on 
the portfolio image.
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Part 8: Making the page dynamic
Now use some JavaScript to make your Web page dynamic, so the list links can
be used to change the portfolio image and associated title and caption...

The following line of code is added next (note
that to make formatting tidier, it’s a good idea

to add a carriage return after each semi-colon): 
var displayedCaption = 
document.getElementById(“caption”);
displayedCaption.firstChild.nodeValue =
theCaption;

Next, between the curly quotes, type the
following, remembering to copy cases

identically in each case: var displayedTitle =
document.getElementById(“theTitle”);
displayedTitle.firstChild.nodeValue = theTitle;

We’ll now show you how to write a JavaScript
function that will make it possible for you to

click links on your Web page to swap the main
portfolio image, title and caption. This means your
portfolio can be a single page, rather than a number
of Web pages, which would take longer to update.
Open global.js and type the following: function
swapPhoto(photoSRC,theTitle,theCaption) {}

1
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Scroll Design view until you can see the list of
portfolio items. Select the relevant portion 

of the first one that you want to turn into a link.
Type non_javascript.html into the Link field in the
Properties Inspector. Note how the link
automatically takes on the CSS link property 
values defined earlier.

Now go back to your Web page. First, provide
each of the elements to be swapped with the

unique IDs from the script (theTitle from step 2,
Caption from step 3 and imgPhoto from step 4). 
The simplest way to do this is in Code view – just
type id within the tag and add the relevant value
between the quotes (imgPhoto for the image,
theTitle for the title, and caption for the caption).

Finally, you need to add the following line 
of code to complete the script: 

document.images.imgPhoto.src = “assets/” +
photoSRC; Note that the path within quotes is the
location of your images, so if you’ve placed these in
a folder other than ‘assets’, you’ll need to edit that
line accordingly. Should you want to, you can add a
JavaScript comment prior to the function, in order to
state what it’s for. A single-line comment is started
with two forward slashes, so a typical comment
might read: // image swapper.
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The previous step creates the status bar text,
but it remains on even when the cursor is

moved, so we need to add another behaviour for
when the cursor is removed from the link. To do
this, in onmouseout type: window.status=’’; (Again,
this uses two single quotes – that is not a double
quote after the equals sign.) Depicted is the result,
as shown in a browser that supports status bar text.

The next two steps will create text for the
status bar when the user hovers over the

portfolio link (otherwise the JavaScript above will 
be displayed). In onMouseOver type:
window.status=’View image’; return true;” 
Note that the words View image should be
surrounded by single quotes – surrounding it
with double quotes breaks the script.

Open the Behaviours panel. If you only see
onMouseOver, click the plus sign and go to

Show Events For>4.0 and Later Browsers. Select
onClick and type the following:
onclick=”javascript:swapPhoto(‘1_alley_bars.jpg’,
‘Title of work’,‘Caption for work’); return false;”
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The previous step will have reopened your CSS
file if it was shut. Go to File>Save All to ensure

all files are bang up-to-date and then test your
index.html file in a Web browser. For all practical
purposes, this page is now fit to use (although it
obviously still needs testing in several other
browsers). However, we’re not done yet. We still
need to work on an alternate version of the page for
paranoid Web users who’ve disabled JavaScript.

In Design view, the page is looking pretty
good, although it’s apparent that there’s one

difference from the mock-up: the title and caption 
are too close to the portfolio image. Rather than
going back into the CSS Style Definition dialog box,
select the #rightContent img selector from the CSS
Styles dialog and use the Tag inspector to add a
setting of 40 pixels to margin-bottom (found in
the Box section).

Following this procedure for each of the links
within the portfolio would be extremely

tedious. What you can do instead is copy and paste
the mark-up created for this first link around the
others in the list. When doing so, remember in each
case to include an end tag (</a>) to close the link.

10
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Save often
Save regularly when working

on Web pages and remember

you may need to save all of

the component parts before

previewing successfully. You

can do this in Dreamweaver

by going to File>Save All.
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Part 9: Creating a template and a ‘fallback’ Web page
Use Dreamweaver’s built-in template technology to create a template, and then use that
to create a new index.html page and a non-JavaScript version of our page...

In the New Editable Region dialog box, name
your editable region, again avoiding spaces

and underscores. Click OK and you’ll see the
selected area now surrounded with a border, and
with a tab at the top. This is a marker to highlight
editable regions and won’t be displayed on your
Web page. Note that in the Files panel, you should
now have a Templates folder with your template
within. Never move either – templates fail to work 
if you do so.

Dreamweaver asks whether you want to
Update Links. Unless you want a Website 

that doesn’t work, click Yes. By default, all areas
within a template are locked, so you need to define
an editable region. Doing so is very simple: select
the area on the page you want to define as an
editable region, Ctrl-click or right-click and go to
Templates>New Editable Region (or go to
Insert>Template Objects>Editable Region).

Create a non-JavaScript ‘fallback’ of your
Web page, but keep the same design. The

simplest method of doing so is to knock up a quick
Dreamweaver template. Although templates can
rapidly become complex in Dreamweaver, a basic
one takes only a couple of minutes to create. The
first thing to do is save the current index.html file
as a template via File>Save as Template. Choose a
sensible name for the template, such as ‘main’
(avoid underscores and spaces).
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Save the page again, this time with a file name
of ‘non_javascript.html’. Some of the content

needs amending and one addition is needed: a link
back to the JavaScript version of the Website. This is
added easily enough – type a paragraph of text and
link some of the words to index.html.

Note how when you open a template, it
isn’t blank – it contains all of the information

in the saved template document. This is handy,
because you often only have to change a few
things when creating new pages. First, save the
document as index.html, over-writing the
previously created file (because that document
isn’t currently based on a template). When the
warning dialog appears, click Replace.

To create a new page based on the template,
go to File>New and select the Templates tab.

The left column provides you with a list of local sites
that have templates – selecting one will show a list
of those templates in the middle column. Selecting
something from that list provides a visual preview of
the template in the right column. Click Create to
create a new template-based page.
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Opening new
windows
Be wary of targeting blank

windows, as outlined in step 7 on

this page. This tends to annoy a

lot of Web users and the content

within won’t be recorded in the

same browser history as the 

main Web page.

Save the template and Dreamweaver
automatically brings up the Update Template

Files dialog, along with a list of files that rely on the
template. You should always click Update upon
seeing this, otherwise certain pages on your site may
fall out of sync with the current design and bug fixes.

Save everything and close all open
documents, then open main.dwt from the

Templates folder. Have a quick look through the
code to check that everything is in order. If there are
unwanted spaces prior to or after tags, delete them.
(For instance, we had a space in our title, between
the opening <h1> tag and the element’s content.)
Although this probably won’t affect the Website’s
display in any browsers, it’s good to be sure.

All of the links within the list need changing,
because they all rely on JavaScript. This is

easiest to do in Code view. Remove everything 
from the links except for the href attribute, 
whose value should be the path and file name 
of the image that’s being linked to (so <a
href=”assets/1_alley_bars.jpg”> should be the
opening tag of the first list item). By default, 
these will open up in the same browser window 
as the Web page. To change this, you can click 
on each link and use the Properties Inspector to 
set the Target to _blank.
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Part 10: Testing and potential browser bugs
The final thing to do is check the site in browsers and against W3 standards...

Internet Explorer 5.5 for Windows is still very
popular and has some unique bugs, so you

should test in that as well as version 6. Again, things
looked fine and were almost identical to IE 6. The
most common problem in IE 5.5 is with the box
model. The browser incorrectly places padding and
borders within an element’s defined width; see [w]
http://tantek.com/CSS/Examples/boxmodelhack
.html for an explanation and workaround.

While building the site, we tested it in Internet
Explorer and Safari on the Mac, so it’s time to

ensure everything’s working in Windows browsers.
All was well in Mozilla and Internet Explorer 6
(depicted). The most common issue with IE 6 is
spacing problems between Web page elements, and
this can often be fixed by removing white space
from the mark-up around the offending element.

Go to Site>Check Links Sitewide to open the
Link Checker. We had no errors in our site, so

we faked an error report by removing the assets
path from step 7 of the previous exercise. Depicted
is the report; if you have broken links, you can
amend the link in question from the dialog.
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Likewise, you can test your HTML/XHTML at
[w] http://validator.w3.org/. The validator

returns both errors and warnings. The former
must be corrected to ensure compatibly and valid
code, while the latter are just for your information.
(Note that the validator requires a page to have
encoding and type specified, but Dreamweaver
includes these things automatically.)

Although our Web page now seems to be
working fine, it’s still worth testing our work

against W3’s standards. You might think this is
pointless, considering how much testing we’ve
already done, but sometimes the validation tools
at W3 pick up on errors you may otherwise have
missed, and Web browsers can be surprisingly
lenient with dodgy code that you can bet will mess
up something when your site goes live. CSS files can
be tested at [w] http://jigsaw.w3.org/css-validator/
by upload, textarea or URL.

Opera is mostly standards compliant,
especially in Windows. Again, we had no

problems with our site. However, it does have
some odd required defaults: for instance, Opera
requires you to explicitly set padding to zero on
the body tag and for list items (li), otherwise it
includes spacing. Opera makes it easy to test
your site without JavaScript, as depicted: toggle
File>Quick Preferences>Enable JavaScript.
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Onwards and upwards

To be honest, it doesn’t end here – the best

Websites are ones that change and grow, that

evolve and keep visitors interested. As we’ve

stated elsewhere, we recommend that once

you’ve got a site online you should put aside a

small amount of time each month to update it.

Such updates don’t have to be a complete

overhaul – all you need to do in order to keep

people interested is update the portfolio with 

your most recent work on a regular basis. Bear

in mind that if you don’t update your site for a

number of months, potential clients probably

won’t think you’re far too busy to update your site

– they’re more likely to assume that you simply

haven’t had any commissions!

Also, don’t rely on search engines to get the

word out there. You need to be active in promoting

your Website. This needn’t always be a lot of hard

work, and some promotional means are extremely

simple: remember to add your URL to your email

signature and to your next run of business cards;

and if you have a number of regular clients, send

them a brief email mentioning that you now have

a site online. Word will soon get around!  ca•p

And we’re done... or are we?
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