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Tutorial

Page-turning portfolios

J
ust imagine the situation: you need 
to create a portfolio fl ick book, 
you’re up against the clock, and 
you’re regretting not having given 

the Flash manual a thorough reading. In the 
following tutorial we show you how you can 
bring all the elements together, learn the basics 
of Flash and produce a fi nished movie in a little 
under an afternoon’s work. 

If you’re new to Macromedia Flash, don’t be 
baffl ed by ActionScript and XML, merely take 
advantage of the wealth of shareware and 
exchange products already out there. We show 
you the basics, and with a few simple timelines 
up and running, we drop in a fl ick book that we 
unearthed online, and show that you can 
frequently beat the clock if you know where to 
look, and when to keep things simple.

A bit of preparation and organisation can go 
a long way. Making sure things are right before 
you dive headlong into the world of Flash can 
save valuable minutes and prevent those 
infuriating head-scratching moments when 
the world of technology seems to be conspiring 
against you.

Thinking ahead, and always working toward 
the most effective fi le size and format for your 
project is a must. You can slave away all you 

like on your fl ick book, but if at the end of it 
all it’s going to take a yawn-inducing 
couple of minutes before a 
prospective client can view it, 
it’s wasted energy. 

Keep things simple. Set 
out a family of fonts that 
distinguishes the portfolio and 
its design structure from the 
artwork that you’re presenting. 
Don’t confuse and overcomplicate 
matters by giving too much 
information on too many levels.

We use Flash, Illustrator and Photoshop 
to illustrate the importance of balancing 
content with fi le sizes, understanding when 
CMYK goes awry in RGB, getting visuals 
working to your advantage and 
communicating a lot with very little.

Expertise provided by Prevamp, a team of designers working 
across all types of disciplines, from creating brand identities 
to lifestyle drivers. Visit www.prevamp.co.uk or contact Ben 
Bryant, Creative Director on +44 (0)1934 424594. 

The fi nished .fl a and .swf fi les can be found on the Computer 
Arts Projects CD83 in the DiscContent\Tutorials\Tutorial Files\
Flick book folder.

Create an impressive portfolio fl ick book in Macromedia Flash…
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You could fi nd that 
a wonderful piece 
of artwork becomes 
a horror show when 
displayed online. 
It’s a good idea to 
scout ahead when 
selecting pieces for 
your online folio and 
take time to see how 
things will look 
when converted to 
RGB  – you don’t 
want all your subtle 
hues looking like a 
psychedelic 
migraine do you?

Converting 

to RGB

Part 2: Sourcing components   
There’s a world of knowledge out there, so familiarise yourself with some of it…

1
Open Flash. If you’re new to the program, prepare to be 
bewildered by the interface and surplus of panels. We’re 

going to keep this quick and simple, and only touch on a few 
of the many wonderful things Flash can do. Create a new 
document, and save it in the same folder as the RGB images.

2
Flash is like other design packages in that we need to set 
up our area of work or ‘Stage’. Hit Ctrl/Cmnd+J for 

Document Properties. Set page dimensions to 900x550 pixels, 
background colour to black, and frame rate to 30fps (frames 
per second) for a smooth animation.

3
The most important bit of Flash 
to become familiar with is the 

timeline. You can add and rename 
layers, and build up a complex 
document where the content runs left 
to right in a series of ‘frames’.

4
It’s time to start making our existing high-resolution 
artwork more web friendly. After making all fonts into 

outlines (Illustrator) or vectors (FreeHand), copy and paste the 
panels into Photoshop. Convert images to RGB, and if 
necessary, re-size to 400x300 at 72dpi.

5
Save for Web (Alt+Shift+Ctrl+S on the PC or Option+ 
Shift+Cmnd+S on the Mac) and preview a particularly 

busy part of your image at 300 per cent. Choose to view ‘2 
Up’ and use the controls on the right to preview your image 
while you fi nd a suitable compromise between size and quality.

6
It’s time to start getting organised. 
Create a folder named ‘RGB Web 

Images’, and save your optimised fi les 
there. Name the fi les sensibly – Page 1 
may seem a good idea until you decide 
to completely change the running order 
of your book.

Part 1: Preparation and layout  
Start as you mean to go on by getting things right at the start…

1
We select 
work from our 

back catalogue that 
we know will be 
visually striking and 
communicate well 
despite the size 
constrictions of a 
web browser. Once 
we’ve assembled 
a collection of 
possible projects, 
we begin 
experimenting 
with some double-
page spreads.

2
It’s tempting 
to rush 

headlong into the 
really creative bit, 
but take time to 
play around with 
layouts, ensuring 
you have a cover, 
back cover and an 
even number of 
pages. There’s 
not much point 
creating a 
stunning book 
that doesn’t 
actually work.

3
Happy with 
our Illustrator 

layout, we decide 
to make our fi nal 
page size 400x300 
pixels, giving us an 
open spread of 
800x300, which we 
could place into a 
Flash document at 
900x550. This will 
allow the fl ick book 
to be easily viewed 
on monitors 
displaying in 
1,024x768.

If you need to 
reduce the fi le size 
of images in Flash, 
you can right-click 
(or Ctrl-click) on the 
image in the Library 
and either choose 
to edit in the 
application of your 
choice, or override 
any existing image 
settings and use the 
compression 
facilities of Flash to 
re-save your JPEG 
or PNG fi les, with 
image previews and 
size comparisons 
available.

Image resize

Tutorial Page-turning portfolios
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Sourcing components continued…

4
Open the Components panel from the Window menu 
(Ctrl/Cmnd+F7). There will already be a few components 

lurking in this panel – Macromedia has kindly given you a few 
freebies for instant interactivity. There’s no fl ick book yet 
though, so let’s go hunting.

5
Macromedia offers a huge amount of support on its 
website, and you can fi nd ‘Exchanges’ that support all 

products. There are a wealth of plug-ins, bolt-ons, patches 
and little miracles designed to enrich your design armoury at 
www.macromedia.com/cfusion/exchange. Register for free 
by heading to the Flash Exchange.

6
Search the Exchange for a page fl ick 
(or fl ip) and see what results you 

fi nd. Anything you download will activate 
the Extensions Manager, which can also 
be found under the Help menu in Flash. 
The extensions will self install and 
automatically appear in the relevant panel.

4
Click on the component and open the Properties 
Inspector (Ctrl/Cmnd+F3), and switch to Parameters. 

From here you control all elements of the fl ick book. Unlock 
the padlock on the left, and change the page book dimensions 
to 800x300.

5
Other adjustable features include the depth of the 
shadows, speed of the page turns, whether the page 

turns manually (on mouse grab) or with just one click. Adjust 
these to your preferences. 

6
The ‘Book Pages’ parameter is the most important 
section. In here you will tell the book the order of the 

pages, and it will pull them from a directory. Save the Flash fi le 
into the same folder as the images. You don’t need to defi ne a 
path, just type in the fi le name per page.

Part 3: Using the component   
Bring the fl ick-book component into Flash and get it working…

1
We found a fl ick book component instantly, followed the 
links and downloaded it. As a component it negates the 

need for you to understand ActionScript (fi ddly stuff that 
makes Flash do great things). The component is controlled 
from the Properties panel.

2
We paid a small fee for the fl ick-
book component from www.

fl ickingbook.com, but a free open source 
version exists at www.iparigrafi ka.hu/
pagefl ip, so you can view the source 
code and make changes in ActionScript.

3
Drag your component on to the stage, and what you’ll 
see is a blue keyline of your fl ick book, waiting to be told 

what to do. Hit Ctrl/Cmnd+K and open the Align panel, enable 
‘To Stage’ and centre the book horizontally and vertically.

If your timelines in 
Flash looks like a 
ball of wool that’s 
had the kitten 
treatment, you need 
to use symbols 
more effectively. In 
symbol-editing 
mode you can 
create clips within 
clips, but things 
can still look 
complicated with 
more than one 
timeline running. As 
soon as you’ve 
saved your symbol 
to the library, drop it 
into your movie 
timeline as a self-
contained element.

Symbol editing

When creating a 
movie with a large 
fi le size, it’s useful 
to consider the 
layout of timelines 
more carefully. 
When you export 
your movie you can 
decide whether it 
loads from the top 
down or bottom up. 
If something big is 
loading early when 
it doesn’t appear 
until the end of the 
movie, shuffl e the 
pack so it doesn’t 
slow things down 
unnecessarily.

Loading tricks
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Find out about using timelines, layers, symbols and tweens in Flash…

7
Click back to Scene 1 on the timeline. Your Loader 
symbol will now be in the Library (Ctrl/Cmnd+L). Drag it 

on to the stage in the layer called Loader, re-size and position 
it where necessary. Click F5 to duplicate the frame and pull it 
to frame 97.

8
That simple animation will buy time while the fl ick book 
loads. Create another symbol, name it Book Demo. On 

the symbol stage use Line and Bézier tools to draw a book 
with a curled page. We’ll split these elements between layers 
to apply animation.

9  Create four layers, cut and paste page corner, page curl, 
book outline, and page edges to each. The book outline 

stays constant, but other layers change to show a page being 
turned. Create new keyframes for each along the timelines and 
draw more exaggerated page corners and curls.

Part 4: Getting animated   

1
You can now test your fl edgling movie by hitting Ctrl/
Cmnd+Enter, and the movie will play. Let’s add more 

elements to the timeline. When you dragged the component 
to the stage, by default it added it to the fi rst frame of Layer 1. 
Rename Layer 1 as Flicking Book.

2  Add another fi ve layers using the Insert Layer icon in the 
timeline toolbar. Now drag the frame in the Flicking Book 

layer along to 183 seconds. Add a simple Loader and Demo to 
the timeline, which will give the fl ick book a chance to load.

3  Give the layer above the book a name: Loader. Go to the 
Insert menu and hit New Symbol or Ctrl/Cmnd+F8. 

Name the Symbol: Loader. Then select Graphic. You’re 
presented with a new stage and timeline. Here you can create 
an element to drop into the movie timeline.

4
Select a rectangle from the Tools palette, set fi ll to white, 
and stroke to empty. Draw a rectangle on the stage. Align 

it vertically, then draw fi ve more side by side. Add fi ve new 
layers, then cut and paste the rectangles to a layer of their own. 
In the bottom layer click frame 1, select Insert>Timeline>Frame.

5
You’ve now duplicated the fi rst frame. Drag its white 
handle to frame 16 of the timeline. Click frame 8 and 

Insert>Timeline>Keyframe (F6). Do the same for frame 16. 
Keyframes tell Flash that this frame will involve an action. 
Change the fi ll of the rectangle in frames 1 and 16 to black.

6
With all frames selected go to the Property Inspector, 
select Tween then Shape. You now have a rectangle 

that appears to fade in and out. Repeat this for remaining 
rectangles, then spread the layers along the timeline so one 
fades in while one fades out.
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Treading carefully 
with copyright is 
essential. Make 
sure that any 
elements you add to 
your movie, whether 
they are images or 
music, are correctly 
licensed. Yes, a 
burst of Isaac Hayes 
may suit your movie 
down to the ground, 
but the likelihood 
is you’d breach 
someone’s 
copyright. Search 
for royalty-free 
elements instead.

Copyright

considerations
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13
You can change the Alpha properties of a symbol, like the 
Shape tween, except this time the symbol will go from a 

0 per cent Alpha setting to 100 per cent Alpha setting using 
the Motion tween (invisible to visible). Select the Alpha 
properties by clicking on the symbol while on the stage.

14
Contact details can be revealed by having black boxes 
fade out to 0 per cent Alpha settings, just one more 

way to do reveals. With all the elements on the timeline, you 
need to do one last thing with Actions before publishing. In 
the fi nal frame you’ll tell the movie to stop.

15
Select the last frame of the movie, and open 
Window>Development Panels>Actions (F9). Open the 

Global Functions menu in the new panel, then Timeline 
Controls, and drag an instance of ‘Stop’ into the right window. 
This will prevent the movie from looping.

Getting animated continued…

10
Shape tween these elements as in Step 6, and add fades 
at the beginning and end (changing strokes from black to 

white and white to black). On the movie timeline drop in the 
new symbol from the Library at frame 98 and drag out to 
frame 182.

11
Now create symbols for contact 
details and instructions. These can 

be vectored sections of text copied 
straight in from Freehand/Illustrator. 
Paste them on to the stage and then 
click Modify>Convert to Symbol.

12
Name your symbol and select Graphic. It will appear in 
the Library straight away. Drag it on to a new layer, and 

edit it on the main timeline. Duplicate the frame (F5), and drag 
out to the appropriate length. Add three new keyframes, to 
give four in total.

Part 5: Publishing your portfolio  
In the fi nal section, export your fl ick book to the media of your choice…

1
You can now export the fi nished piece as a Flash movie 
(.swf). This can be placed into a Dreamweaver document 

and uploaded on to the web or used as a standalone movie. 
Save or upload into a directory with your page images.

2
You can now export the fi nished piece as an HTML ready 
for upload without Dreamweaver. Keep size properties as 

per the Flash fi le, and publish. Upload on to your web space 
with the page images in the same directory.

3
Test the fi le. If anything needs tweaking at this stage, it’s 
quick and easy to change the book properties and publish 

a new fi le.  ca p
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