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L
et's face it, the very words ‘PowerPoint presentation’ 
conjure up images of grey-suited execs throwing 
together an unsightly mess involving headlines set in 
Comic Sans and graphics care of a clip-art CD 

containing images that looked out of date in the early 80s. Stir in a 
couple of charts, graphs and bullet points and you 

have something that gives nightmares to anyone 
who cares about graphic design. 

Flash is more than capable of producing 
standalone content that looks amazing projected on 

to a big screen. And don't worry about ActionScript, 
because you only need a couple of 

simple lines of code, and the 
application itself does most of the 

hard work. Because the presentation is designed to be played 
directly from a computer, you're free from the bandwidth-saving 
code optimisation and image compression that can soak up valuable 
time when producing Flash movies for the web. 

The scalable vector graphics, custom animation and anti-aliased 
text will blow the PowerPoint equivalent out of the water. But other 
factors can help, too. Without relying on supplied templates, your 
imagination can run free. You should, however, remember a couple 
of key points. First, create a separate script to speak from: the words 
in your presentation should reinforce your message, not 
duplicate it. Second, don’t overdo it with an all-singing, 
all-dancing extravaganza. Create a good design, use a 
judicious amount of animation and your 
presentation is guaranteed to go down a storm.

Tutorial [illustration] Adi Gilbert, www.99seconds.com

Ditch PowerPoint and use the tools you love – Photoshop, Illustrator 
and Flash – for ultimate control of your presentation…

29Tutorial Super-charged presentation

Expertise provided by Jason 
Arber, founder of Pixelsurgeon. 
Get all the latest news at 
www.pixelsurgeon.com.
 

All the fi les needed to complete 
this tutorial can be found on the 
Computer Arts Projects CD83 in 
the DiscContent\Tutorials\Tutorial 
Files\Presentation folder.
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Keep your 
presentation to a 
conservative size, 
such as 1,024 by 
768 pixels. You 
could create a 
presentation that 
will fi ll an Apple 
Cinema Display, but 
the projection 
system or display 
screen may be 
capped at a fi xed 
size. Check 
beforehand how 
your Flash movie 
will be displayed 
to avoid showing 
your audience a 
scaled down 
version, or, worse 
still, just a chunk 
from the middle.

Size matters

Tutorial Super-charged presentation

Part 1: Initial design
You need to start by designing your presentation in Photoshop…

1
Start by creating a new Adobe Photoshop CS document at the screen resolution 
you want your presentation to be – 1,024x768 pixels at 72 pixels/inch is a safe 

bet if you're unsure. Give your fi le a name and click OK.

2
Fill the background layer with black by clicking on it with 
the Bucket tool from the toolbar with the foreground 

colour set to black. Open a vector version of your company's 
logo in Adobe Illustrator and copy and paste it into the 
Photoshop document. This should give you the option of 
pasting the logo as a Smart Object. 

3
Smart Objects can be repeatedly 
resized without losing any of the 

image’s sharpness because Photoshop 
keeps the vector data and re-renders the 
object after each change of size. Put 
the logo in the top-left corner, placing 
it at a slight angle.

8
Finally, create a slide which shows 
the screenshots at full resolution. 

As before, apply a soft drop shadow to 
the image. You can save time by copying 
the layer style by right-clicking on the 
layer (or Ctrl-clicking for Mac users with 
a one-button mouse) and choosing 
‘Copy Layer Style’ and then pasting it 
onto your new layer with a similar right-
click and selecting ‘Paste Layer Style’.

9
It’s time to gather up all the fi les 
you’ll want to use in Flash. Save all 

the vector elements, such as your 
company's logo, by exporting them from 
Illustrator as Macromedia Flash (swf) 
fi les (File>Export). Bitmap images can be 
saved as PNG fi les by saving for web 
(File>Save for Web...). 24-bit PNG fi les 
include variable transparency which can 
be imported into Flash intact. 

7
Design a thumbnails page. Create a smaller rounded corner box, big enough so 
that three can sit comfortably within the page’s inset box. Give each box a 

touch of soft drop shadow by selecting the Drop Shadow option from the Layer 
Style menu at the base of the Layers palette. Paste a screenshot over each box, 

resize, then mask it by creating a clipping mask (Layer>Create Clipping Mask).

4
Put your company's name in the opposite corner together 
with the name of the company you’ll be presenting to. 

This will help make them feel that this is a personalised 
presentation, not a generic one. You can also add the date 
of the meeting.

5
Create a rounded corner box, inset by between 10 and 
20 pixels. Use the Rounded Rectangle tool from the 

toolbar, with the Fill Pixels option selected and a corner radius 
of 9 pixels chosen in the Options window (Window>Options). 
Fill with a gradient of black-and-white by dragging down with 
the Gradient tool, ensuring that the ‘Lock transparent pixels’ 
option is selected in the Layers palette.

6
Build several templates to show how different kinds of 
content in your presentation will work. The simplest 

of these is the text slide: use a simple, bold font such as 
Myriad Pro set at a large height – 48 pixels or more. And 
remember, you don't want too much text or people will fall 
asleep reading it.
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There are two 
versions of Flash. 
The Professional 
version contains 
data components, 
support for mobile 
authoring, 
professional video 
features and other 
egghead friendly 
elements, whereas 
the Basic version is 
lacking features 
such as fi lters 
and handy blend 
modes. If you can 
justify the 
additional expense, 
the Professional 
version is defi nitely 
the way to go.

Software 

31Tutorial Super-charged presentation

Part 2: Transfer to Flash
Prepare to get your presentation moving in Flash MX…

4
Use the Text tool to recreate the text at the top right of 
the slide template. Usefully, you can use the Eyedropper 

tool to sample the pasted document's colour in case you can't 
remember the text's hexadecimal or RGB colour value.

5
Use the Rectangle tool to draw the inset box matching 
the template. It can be any colour you like at this stage 

because we’ll be fi lling it with a gradient in the next step. Use 
the ‘Set corner radius’ option to give the rectangle 9-pixel 
rounded corners.

6
Fill the rounded corner rectangle with a gradient by 
selecting the default linear black-and-white gradient from 

the bottom of the Swatches palette. Flash has excellent control 
over a gradient’s attributes, so choose the Gradient Transform 
tool from the toolbar and adjust to the gradient’s size and 
angle. You can now delete the Template layer.

1
In Macromedia (now Adobe) Flash 
MX, create a new document – or 

modify the default document – with the 
following attributes. Give the document 
a meaningful title, dimensions of 
1,024x768 pixels (the same as your 
Photoshop fi le), set the background 
colour to black and set the frame rate 
to 31 frames per second. Then click OK 
to set the properties.

2
Rename the default timeline layer 
to Template, then copy and paste a 

fl attened version of the basic template 
from Photoshop into Flash. Use the 
Properties palette in Flash to ensure 
that the image’s x and y coordinates 
are set to zero. 

3
Create a new timeline layer by clicking the document icon at the bottom of the 
timeline, then import the swf version of the logo to the stage (File>Import> 

Import to Stage...). Group it immediately (Modify>Group) and move it into place, 
resizing and rotating accordingly. 

7
Create a new timeline layer and call it ActionScript. Click 
in the fi rst frame to select it and in the Actions palette 

(Window>Actions) click stop in the top-left frame (Global 
Functions>Timeline Control) which should place the 
ActionScript stop(); in the code window. This just stops the 
animation at the fi rst frame, and don’t worry, the ActionScript 
isn’t going to get much more complicated than that.

8
On the timeline, select all four layers (ActionScript, Logo, 
Text and Background) at frame 100 and press F6 (or 

Modify>Timeline>Convert to Keyframes). This expands the 
timeline from a single frame to a hundred frames, which gives 
us enough space to work with.

9
Create a new layer called Labels and chop the timeline 
into regular intervals using the ‘Convert to Keyframes’ 

function, corresponding to the number of slides your 
presentation will have. In the fi rst frame of each section, give 
the frame a meaningful name in the <frame label> fi eld in the 
Properties palette. We’ll be using these names to navigate 
around the timeline rather than frame numbers.  
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Here are some 
practical tips to 
aid a smooth 
presentation. Try to 
use your script as an 
aide-mémoire and 
talk around the 
subject using key 
words and phrases. 
This way, you won't 
have your head 
buried in a piece of 
paper. Talk at half 
your normal pace, 
leaving plenty of 
spaces so your 
audience has time 
to digest what 
you're saying.

Talk tips

Tutorial Super-charged presentation

Part 3: Navigational elements
The next stage is to input some simple ActionScript to create buttons…

1
On a new timeline layer create a text box that 
spans the width of the inset box. Add some text, 

set the font’s size and colour and centre it within the 
text frame. Chop it up to match the slides using the 
‘Convert to Keyframes’ function and overwrite the 
text in each section with the title of the section.

2
We need a big button to manually step 
through the slides. On a new layer create a 

large rectangle that covers about half the screen. 
Right-click or Ctrl-click on it and select Convert 
to Symbol... (or choose Modify>Convert to 
Symbol...) and turn the rectangle into a Button 
Symbol. Double-click on the new button and 
expand the Layer 1 timeline all the way to the Hit 
state with the ‘Convert to Keyframes’ function. 
Delete the Up, Over and Down states.

3
Return to the main timeline using the breadcrumb 
function above the timeline layers. The button should be 

translucent, indicating that it’s now an invisible button with an 
active Hit state. Copy and paste the button on the same layer, 
but move the duplicate to cover the other side of the screen.

4
Select the fi rst button, and in the Actions palette choose 
goto (Global Functions>Timeline Control) which should 

put the following in the code window: 
 on (release) {
       gotoAndPlay(1);
 }
Change the Type to Frame Label and choose a random frame 
label from the dropdown list in the Frame section below.

5
Refi ne the default ActionScript by converting the top line to ‘on 
(press)’ rather than ‘on (release)’ and the second line to ‘gotoAndStop’ 

instead of ‘gotoAndPlay’. When each line is selected, radio button options 
appear so that you don’t have to type the code. As before, chop up the 
buttons layer, editing each button instance so that the left button goes to 
the previous frame label and the right button goes to the next. 

6
Test the Flash movie to ensure that 
everything is working as expected. Click 

File>Publish Preview>Flash to bring up a fully 
functioning preview movie. Click the left and right 
buttons to ensure that you’re stepping through 
the presentation and not skipping any slides. 

Spice up your 
presentation by 
adding some video. 
Flash's handling of 
video has improved 
immeasurably in 
recent years and 
slipping in some 
relevant video to 
make your point 
can make your 
presentation stand 
out from the crowd. 
It's surprisingly easy 
to create .fl v fi les – 
Flash's native video 
format – using 
QuickTime Pro or 
Flash Professional's 
Flash Video Exporter.

Video extras

8
With the button selected, type the 
following into the Actions palette 

code window using your own naming 
convention for the frame labels:
on (keyPress "<Right>") {
      gotoAndStop("Part 1 Intro");
}
on (keyPress "<Left>") {
      gotoAndStop("End");
} 
This tells the movie to navigate to a 
specifi c label using the left and right 
arrows. Chop up the layer, editing the 
button in each section to move to the 
correct place.

9
Having tested that the new 
functionality works as expected, it’s 

time to start adding some images and 
harnessing Flash’s animation and opacity 
capabilities. Import the three thumbnail 
PNGs onto their own layers on the 
timeline, and use the Align window to 
space them equally apart. 

7
If everything is okay, it's time to add some additional navigation. In a 
presentation situation, you may want to step through the Flash movie just 

using the arrow keys rather than a mouse or trackpad. To do this, drag another 
instance of the invisible button from the Library onto a new layer. Resize it to make 
it small and move it off to one side.
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9
The fi nal 
proof of the 

pudding is to 
install the 
Projector on your 
machine and play 
it. Choose Full 
Screen from the 
View menu and, 
depending on the 
size of your 
monitor, you may 
need to click 
Ctrl-1 (PC) or 
Cmnd-1 (Mac) 
to centre the 
presentation at 
100 per cent. ca p
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If you've got a 
PowerPoint 
presentation you'd 
rather have in 
Flash, you could try 
PowerCONVERTOR 
from www.
presentationpro.
com. It's a touch on 
the pricey side, 
but will retain all 
PowerPoint's 
features such 
as narration, 
transitions and 
hyperlinks. Note 
that the application 
is PC only.

PowerPoint 

1
Convert each thumbnail to a 
Symbol, turning them into movie 

clips. This gives you the most amount of 
animation fl exibility. Ensure that each 
one is given a logical name so that they 
can be tracked down easily in the 
Library. Click OK.

2
On the timeline, add a keyframe 
about 10 pixels away on each 

thumbnail layer. Select the fi rst keyframe 
for all three thumbnail layers and move 
them up about 20 pixels vertically. 
Right-click (or Ctrl-click) in the gap 
between the two keyframes and select 
Create Motion Tween (or select Motion 
from the Tween dropdown in the 
Properties palette). 

3
Now move to the fi rst keyframe, in turn setting the Alpha, or opacity, to 0 per 
cent in the Colour dropdown of the Properties palette. This means that as well 

as moving, the thumbnails will gradually become 100 per cent opaque from an 
initially invisible state.

4
For a more pleasing effect, stagger the thumbnails’ 
transitions by a couple of pixels so they don’t all appear 

at once. Change the gotoAndStop function to gotoAndPlay 
for all buttons that point to the thumbnails section. Ensure that 
the stop(); function is moved to the last animation frame on 
the ActionScript timeline.

5
Reverse the process so that the thumbnails animate out 
in a staggered fashion, moving up and returning to 

invisibility. This will create a corresponding exit animation. 
We’re using Frame labels to identify individual frames rather 
than frame numbers, so we can add more frames if more are 
needed without having to edit every single button. 

6
On three new timeline layers add the full-size images by 
importing the PNG fi les to the stage (File>Import) and, as 

with the thumbnail images, convert each one into a Movie 
Clip Symbol by choosing Modify>Convert to Symbol...

7
With the large images, it’s easy to 
create a great looking crossfade. 

Overlap the timelines and, in the 
overlap, create tweens that move from 
0 per cent alpha to full opacity. Create 
new frame labels and stop(); actions 
where required and edit the buttons so 
that they gotoAndPlay rather than 
gotoAndStop.

8
After testing the Flash movie with a 
preview to make sure everything 

works as expected, it’s time to export 
standalone fi les that will work on both 
Macs and PCs, whether the destination 
machine has the Flash plug-in installed 
or not. In the Publish Settings dialog 
(File>Publish Settings...) check the boxes 
for Windows Projector and Macintosh 
Projector and click Publish. 

Part 4: Adding imagery
Turn images into movie clips for the maximum amount of animation possibilities…
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