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G
etting your work on the web is essential 
when it comes to self-promotion. Any 
professional print materials should include 
a URL so that prospective clients can see 

more of your work at their convenience. Also, an online 
portfolio is a cost-effective way to keep your recent 
work in front of your clients’ eyes. Updating your website 
is quicker and cheaper than sending out printed 
promotional pieces every time you do something new.

For this particular portfolio, we’re looking to 
showcase some of Derek Lea’s more whimsical and 

vector-based work. The overall design refl ects the 
content of the illustrations featured in this 

online gallery, but the design is also subtle 
and subdued enough so that it doesn’t 

compete with any of the images on 
display. Any successful portfolio design 
should always complement the work 
within, without drawing attention away 
from it. Before you begin, launch the 
.swf fi le included on CD84. Viewing 
the portfolio before you get started is 

an excellent way to make sense of 
things ahead of time. 

If you look at the background, you’ll notice that it’s 
mostly white with groups of outlined objects scattered 
about as well as some fi lled shapes in varying shades 
of grey. The circular motif is one that appears 
repeatedly in this style of work and is an excellent 
background element because of its simplicity and 
versatility. This motif also lends itself nicely to simple 
animation techniques. 

So, we’ve created a simple looping animation in 
the background out of a few circles. This adds a little 
life to the static portfolio, creating some subtle 
movement without causing the viewers’ eyes to tire. 
You’ll also notice that the circular motif gets put to 
good use as an interface element, carefully containing 
all the illustration thumbnails at the left of the design. 
These thumbnails initially appear grey, until a simple 
rollover reveals a glimpse of colour that the full colour 
image will contain.

The Flash fi le is comprised of elements that were 
created in Illustrator as well as Photoshop. It is always 
a good idea to prepare elements well ahead and 
according to plan, so that once you’re inside the realm 
of Flash you can concentrate on nothing but creating a 
working portfolio. 

Tutorial [illustration] Derek Lea, www.dereklea.com

Build a Flash portfolio 
Use Illustrator and Photoshop fi les within the Flash 
environment to create a stunning and interactive online 
portfolio that showcases your best work…

27Tutorial Build a Flash portfolio

Expertise provided by Derek Lea, an award-winning illustrator based 
in Toronto, Canada. See more of his work at www.dereklea.com.

The fi les needed to follow this tutorial can be found on the Computer Arts 
Projects CD84 in the DiscContent\Tutorials\Tutorial Files\Flash portfolio folder.
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2
Choose Edit>Paste In Centre from the menu to paste 
the interface on the layer in the centre of the stage. 

Once you’ve done that, return to the Illustrator background.ai 
fi le and choose Select>All from the menu. After selecting 
everything, choose Edit>Copy and then return to your 
working Flash fi le.

3
Once you return to Flash, insert a new layer into the 
timeline. Rename the layer ‘background’ and drag it 

beneath the interface layer in the timeline. With the 
background layer targeted, choose Edit>Paste In Centre from 
the menu to paste the copied art onto the centre of the stage 
within the targeted layer.

The ‘insert layer’ 
button resides at 
the bottom of the 
palette and can be 
used to add a new 
layer to the timeline. 
You can rename any 
layer by double-
clicking on its 
name. Also, layers 
can be moved by 
dragging them up or 
down within the 
stack. Layer order 
affects whether 
layer contents are in 
front of, or behind, 
other layers.

Timeline layers

When you perform a 
Pathfi nder function 
in Illustrator and 
create a compound 
shape, it isn’t fi nal 
until you expand it. 
For instance, if you 
perform a union, 
combining two 
shapes, they can 
still be edited 
individually while 
they’re united. But 
if you select your 
united shape and 
press the Expand 
button in the 
Pathfi nder, a single 
shape is created.

Expanding

Tutorial Build a Flash portfolio

1
Launch Flash and create a new 
document. In the Properties 

Inspector, set the size to 800 pixels wide 
and 666 pixels high. This will give you 
a nice size to work within. Set the 
background colour to white in the 
Properties Inspector too. Change the 
name of the existing timeline layer, 
calling it ‘interface’.

Part 1: Illustrator fi rst 
We’ll start off in Illustrator, creating background and interface elements…

2
Now open up the frames.ai fi le from the CD. Again, you’ll notice that all of the 
objects have subtle grey fi lls and strokes applied to them. However, these 

objects are more prominent than the background objects. You’ll also notice that the 
circle motif is present, forming the basis for most of these compound shapes.

3
Have a peek through the Layers palette and you’ll notice 
that all of the compound shapes created via the 

Pathfi nder functions have been expanded, just to be on the 
safe side. No need trying to import objects with Illustrator 
because specifi c effects are applied to them in Flash. Choose 
Select>All and then Edit>Copy from the menu.

1
Launch Illustrator and open the background.ai fi le from the Flash portfolio folder on the CD. You’ll 
notice that it’s a simple group of shapes made up of spheres, spirals and rounded-rectangle Pathfi nder 

functions. We added a title across the top but have converted it to outlines so the text becomes uneditable 
objects, preventing us from accidentally altering it later on.

Part 2: Illustrator and Flash
Transfer the copied objects from one open application to another…
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Folders are a great 
tool for organisation 
within the Library 
panel. New folders 
can be created by 
simply clicking 
the button at the 
bottom of the panel. 
Library items can 
be added to it by 
dragging them into 
the folder, and 
folders can be 
renamed by 
double-clicking, 
in the same way as 
renaming layers.

Get organised

29Tutorial Build a Flash portfolio

Part 3: Setting up
Now add some of the Photoshop fi les and construct the main interface…

4
Insert another new layer into the timeline and rename it 
‘button 2’. Drag this layer beneath the button 1 layer. 

With the button 2 layer targeted, click on the retroman-1.psd 
bitmap fi le and drag it onto the stage. Use the Selection tool 
to position it inside of the second interface frame.

5
Use this method to create new layers, one after another, 
name them sequentially, and add bitmap objects from 

the Library to the stage on each layer. Do this using the same 
technique until you’ve added a greyscale image into each open 
frame on the stage.

6
Put all the bitmaps into a Library 
folder called ‘buttons’. Next, use 

the ‘Import to Library’ option to import 
all the bitmap fi les contained within the 
images fi le on the CD. Put them in a 
folder called ‘images’.

1
Use the Selection tool to move the currently selected 
pasted objects to the left of the stage. Next, click on the 

interface layer in the timeline to select all of the layer contents. 
Move the selected objects up a bit and to the left on the stage.

2
Choose File>Import>Import to Library from the menu. 
Navigate to the buttons folder included on the CD. Select 

all of the fi les in the folder then click on the ‘add to library’ 
button. All the selected fi les will appear in the Library panel.

3
Insert a new layer into the timeline and name it ‘button 
1’. Position it below the interface layer. Click on the 

spacegirl-1.psd bitmap in the Library and drag it onto the 
stage. Position it inside the top frame of the interface object.

1
The next step is to use the Selection tool to click on the 
top bitmap on the stage. With this bitmap selected, 

choose Modify>Convert to Symbol from the menu. Name the 
symbol ‘button 1’, just as you did with its timeline layer earlier. 
Specify ‘button’ as the symbol type and then click OK to 
complete the conversion. 

2
You’ve now converted your bitmap to a button and a 
new, appropriately named, button symbol will appear 

alongside your folders in the Library panel. Now you need 
to click on the next bitmap on the stage. Again, choose 
Modify>Convert to Symbol from the menu. Name this symbol 
‘button 2’, just like its layer.

3
Specify ‘button’ as the symbol type and then click OK to 
complete the conversion and add it to the Library panel. 

Use this method to convert each bitmap to a button symbol 
and name each to correspond with the appropriate layer. 
For instance, the bitmap on timeline layer button 4 will be 
named ‘button 4’.

Part 4: Button symbols
It’s time to add some interactivity to our new bitmap buttons…
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When importing 
Photoshop 
documents that use 
transparency into 
Flash, it’s important 
to remember that 
the colour mode of 
your Photoshop fi les 
should be RGB. If 
you import an 
image in greyscale 
mode, it will have a 
white background 
when it’s brought 
into Flash. We’ve 
done the work for 
you by converting 
all our greyscale 
buttons to RGB 
before putting them 
on the CD.

RGB fi les

Tutorial Build a Flash portfolio

4
Now we’re going to add a rollover effect. Double-click 
on the button 1 button symbol in the Library panel to 

edit the button symbol. You’ll notice that the stage changes, 
as does the timeline at the top. Click on the frame 
underneath the Over state in the button timeline and 
choose Insert>Timeline>Keyframe from the menu.

5
This adds a keyframe into the Over 
state, which is the state that occurs 

when you roll over a button with the 
mouse. Now choose Modify>Bitmap> 
Swap Bitmap from the menu. Open the 
buttons folder in the resulting dialog box 
and then select the spacegirl-a.psd 
bitmap fi le from the list. Click OK.

6
The grey bitmap now changes to a colour bitmap during 
the button’s rollover state. Next, double-click button 2 

in the Library panel to edit it. Again, add a keyframe in the 
Over state and then swap the bitmap to the colour version. 
When you’re fi nished, use this method to create a colour 
rollover effect for the remaining buttons.

Part 5: Frames and actions
These are the essential ingredients in your interactive Flash portfolio…

1
Choose Control>Test Movie from the menu. This will launch a .swf fi le from your Flash fi le. Run the 
mouse over all the buttons to test the effect. When you’re satisfi ed, close the window and return to 

your Flash fi le. Insert a new layer in the timeline. Drag it below the button layers.

2
Rename the layer ‘images’. Insert another new layer in the timeline. Name the 
new layer ‘action’ and drag it to the top of the layer stack in the timeline. Select 

the action layer’s fi rst frame in the timeline and go to the Actions panel. Click on the 
Script Assist button to simplify things.

3
Click on the + button to access the pull-down menu of options. From the pull-
down menu, select Global Functions>Timeline Control>Stop. This ensures that 

when the Flash movie plays, it will automatically stop on the fi rst frame. Collapse the 
Actions panel and then click on the action layer’s 16th frame in the timeline.

Button symbols continued…
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4
Hold down the Shift key and click on the background layer’s 16th frame in the 
timeline. This will select the 16th frame of every layer in the timeline. Choose 

Insert>Timeline>Frame from the menu to make the Flash movie 16 frames long. 
Click on the third frame of the images layer in the timeline.

5
Choose Insert>Timeline>Keyframe from the menu to add a keyframe here. 
With the new keyframe selected on the images layer in the timeline, direct your 

attention to the Library panel. Double-click the images folder in the Library panel to 
open it. Click on the spacegirl.psd bitmap in the Library and drag it onto the stage.

6
Use the Selection tool to position the image where you want it to appear on the stage. Next, click on 
the images layer’s fi fth frame in the timeline. Choose Insert>Timeline>Blank Keyframe from the menu 

to add a blank keyframe into this frame. Click on the retroman.psd bitmap in the images folder in the 
Library panel and drag it onto the stage.

7
Use the Selection tool to position the image where you 
want it to appear on the stage. When you’ve fi nished this, 

insert a new blank keyframe into the seventh frame of the 
images layer in the timeline. With this frame targeted, drag the 
creatures.psd bitmap from the Library panel onto the stage.

8
Click on the images layer’s ninth frame in the timeline and 
insert another blank keyframe. With the blank keyframe 

selected drag the robot2.psd bitmap from the Library to the 
stage and position it where you want it. Now, select the 
images layer’s 11th frame and add a blank keyframe.

9
Drag the octopus.psd fi le from the Library onto the stage. 
By now you’re noticing a pattern develop. Use this 

method to add blank keyframes into the 13th and 15th frames 
of the images layer. Add the foot.psd fi le onto the stage in 
frame 13 and the robot1.psd fi le onto the stage in frame 15.
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Ensure that when 
you’re adding 
ActionScripts to a 
button, you have 
the button itself 
selected. You must 
select the button on 
the stage – don’t 
make the mistake 
of clicking on the 
layer or a frame in 
the timeline 
thinking that 
you’ve selected 
the button. If you 
don’t select the 
button itself, your 
ActionScripts won’t 
work properly.

ActionScript 

Part 6: Button actions
Now we’ll control how the buttons will display specifi c images…

1
Use the Selection tool to click on button 1 on the stage area to select it. You’ll see a box appear 
around it and the layer will be highlighted in the timeline. In the Actions panel, click on the + button 

and then choose Global Functions>Timeline Control>Goto from the button menu.

2
Choose the ‘goto and stop’ option and set the frame to three. This means that 
when you click on button 1, your Flash movie, which is stopped in the fi rst 

frame by an action, will jump immediately to frame three and stop. Test your movie 
and then click on the button to see how it works.

3
Use this same method to add an ActionScript to each 
button. First, select the button. Second, add the ‘goto’ 

and ‘stop’ script in the Actions panel. And third, ensure that 
you enter the frame number that contains the image that 
corresponds with your button. Test the movie and try out all 
of the buttons.

Part 7: Adding animation
Start adding life to your design with a simple animated symbol…

1
Insert a new layer into the timeline and drag it down in 
the stack to just above the background layer. Rename it 

‘animation’. Choose Insert>New Symbol from the menu. 
Choose Movie Clip as the symbol type and name the symbol 
‘animation’. Click OK and the Flash environment changes.

2
The stage appears blank and the timeline has changed. 
This is because we’re editing the symbol right now and 

not the scene. Return to your open Adobe Illustrator 
background.ai fi le. Reopen the fi le if necessary. In Illustrator, 
select a large circle and a small circle and copy them.

3
Return to your Flash fi le and paste. Select the smaller 
pasted circle and choose Edit>Cut from the menu. Insert 

a new layer in the timeline on top of the previous layer. Paste 
the smaller circle stage. Position it over one side of the larger 
circle, then Alt/Opt drag it to copy it to the other side.
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Derek Lea has recently been tweaking his own online portfolio and 
jumped at the chance of sharing his experiences in our tutorial…

BACKGROUND:
Derek Lea is based in Toronto, Canada 
and has, in his own words, been 
“illustrating like a madman” since 1996. 
After working as an art director, graphic 
designer and professional retoucher in a 
variety of companies, he went freelance 
and, he tells us, “the phone hasn’t stopped 
ringing yet.”   

YEARS PRACTISING AS A CREATIVE:
Ten.

CLIENTS:
Lea contributes regularly to Computer Arts 
Projects and Computer Arts magazines. 

Additionally he has a plethora of editorial 
advertising, corporate and publishing 
clients in Canada and the rest of the world.
Lea has won a number of high-profi le art 
awards including the Fast Forward digital 
art contest, the Graphic Exchange digital 
art award and the Applied Art photography 
and illustration contest. 

FAVOURITE TOOLS:
Lea works mainly in Photoshop, but he 
is an expert in many other packages, 
including Illustrator and Flash. 

WEBSITE: 
www.dereklea.com

Expert profi le: Derek Lea
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4
Select the two smaller circles and group them. Select 
frame 60 of both layers in the timeline and add a 

keyframe there. Select the keyframe of the top layer. Select 
the grouped circles and use the Free Transform tool to rotate 
them almost 360 degrees, but not quite all the way – 
somewhere around 350 degrees will do.

5
Select the fi rst keyframe of this layer and, in the 
Properties Inspector, choose the Motion option from the 

Tween Type pull-down menu. Click on Scene 1 at the top of 
the timeline to return to the scene. Click on the fi rst frame of 
the animation layer in the timeline and drag your animation 
symbol onto the stage from the Library.

6
Reposition the animation to the upper left and test your 
movie. If all is working well, choose File>Publish from the 

menu to export your movie and an accompanying html fi le. If 
you’re running into trouble, be certain to check out the Flash 
.fl a fi le, which we’ve included on the CD for your reference 
and troubleshooting purposes.  ca p

Clockwise from top right: Image for Today’s Parent magazine 

for a feature on the gap between adults and kids when it 

comes to using the internet; commission for Canadian 

Geographic on nuclear energy; illustration for Health Digest 

to accompany an article on diabetes and proper foot care. 
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