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Tutorial

[illustration] Clusta, www.clusta.com

Produce a short, explosive credit sequence using Adobe 
Premiere, Flash and After Effects…

F
or this tutorial, multi-discipline studio 
Clusta shows you how it created a short 
but dynamic credit sequence for up-and-
coming electro/indie band Deluka. HDV 

footage was taken using a Sony Z1E HDV Pro and edited 
down through Premiere 2.0 and After Effects 7.0. Both 
applications are more than capable of handling HDV 
footage and even though the end result will be rendered 
back down to PAL widescreen 16:9, there will be a 
notable difference in the quality of the output. 

The band’s video was shot in a disused warehouse 
loft in Hockley, Birmingham, with kind permission of 

The Oxygen Rooms music studio. The video is still in 
production, but the central theme is a mass of cabling 
that was set up around the band members’ feet. This 
cabling transcends into animated lines and graphics 
which explode around the band members’ heads. 

The closing panning shot detailed over the following 
pages is a simple handy-cam pan inspired by an old 70s 
TV that the band got hold of. Camera matching is used to 
give a real sense that the graphics are in the space.

Expertise provided be Clusta. Once completed, 
the full video will be available to view online at 
www.clusta.com and www.deluka.co.uk.
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3
In Flash, 
divide the 

elements of your 
logo into individual 
layers for 
animating. In this 
case, the splats are 
being staggered in 
and the wire will 
have a simple 
Motion Tween 
downwards. 
We’ve used a 
white block on the 
layer above to act 
like a reverse mask  
because masks 
can’t be exported 
as frame 
sequences.

4
Set your animation frame rate to 25fps in Flash (Modify>Document). It’s 
important to remember that you cannot export a mask animation from Flash – 

instead, it has to be on the timeline. We want the logo to appear as if it’s drawing 
itself in from either side. To do the same, move your logo to its own layer, break it 
apart so that it’s just shapes on the timeline (Ctrl+B or Cmnd+B) and create 17 
keyframes of this shape by selecting 16 frames in front of it and pressing F6.

5
This is a more traditional approach to animation, but it’s 
often much quicker. Start at frame 1 and click the ‘onion 

skin’ marker so you can see what you’re doing. You can also 
outline the layer by clicking the outline option above the 
timeline – this will also give you better visibility. 

When working in 
Flash and exporting 
for video it’s usually 
worth keeping your 
Flash settings in line 
with your video, so 
you know where you 
are on the screen. 
This means if 
you’re working in 
widescreen, your 
Flash stage size 
should be 
1,024x576 at 25fps; 
PAL 4:3 would be 
720x576 25fps. 
Here, we just need 
graphics with alpha 
backgrounds – we’ll 
do our positioning 
in After Effects.

Flash settings

Part 1: Animating the logo 
Add some effects to your logo in Flash so it’s ready to bring into After Effects…

1
First, you need to create the text elements that are going to feature in your 
video piece. This particular piece is an outro, so it’s going to involve the band’s 

logo and some production credits.

2
The band, Deluka, already has a logo, but we want to add a few bits to it. We 
do this in Flash so we can animate the logo and then bring it into After Effects 

to composite within our scene. We add in some splats and a wire graphic to make 
the logo more dynamic and to give us the opportunity for more animation. 

6
At frame 1 we rub out all of the logo excluding its two 
corners. At frame 2 we can see exactly what’s contained 

in frame 1 because ‘onion skin’ and ‘outline’ are on. Now we 
rub out everything again but leave a little more of the logo. 
We repeat this process until all of the logo is visible, then we 
play it back to review our animation.

7
Next, we select all the keyframes, copy them, create a new 
layer and paste them into it. We go through each frame 

by selecting the frame (this selects our object) and giving it a 
white fi ll by choosing the white fi ll option while everything is 
selected. It’s then outlined using the outlining tool.
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One thing to be 
aware of when using 
HDV or HD footage 
is the size of the 
fi les – expect 
frames exported 
from Premiere to 
be 4.5MB each! 
Make sure you have 
plenty of hard disk 
space before 
embarking on an 
HD project. In this 
case, we have 
used a lossless 
compression Codec 
to deal with the fi le 
size issue.

File sizes

When you import 
your source footage, 
After Effects sets the 
fi eld order, frame 
rate, alpha channel 
interpretation and 
pixel aspect ratio 
automatically. You 
can manually 
override these 
settings to make 
sure that the footage 
you’ve imported is 
being interpreted 
correctly. Note that 
the settings in the 
Interpret Footage 
dialog box should 
match your source 
footage settings – 
not the settings you 
wish for your fi nal 
rendered output.

Automatic

1
We’ve fi lmed all our footage for this project in HDV (High Defi nition Video) using a Sony Z1E HDV 
Pro. You can hire these cameras relatively cheaply, record onto normal Mini DV tapes, capture your 

footage into the computer and then return the camera. Even if you’re rendering back out to PAL 720x576 
or 16:9 resolutions, you’ll still fi nd that the grade of your footage will be better having used HDV.

2
We’re using Premiere 2.0 to capture our footage, which 
is more than capable of dealing with HDV footage and 

32-bit colour depths. 

8
Once we’ve 
applied this 

technique to all 
the frames, we 
select the 
keyframes and 
move them six 
frames to the right 
– this will stagger 
the animation. We 
create another 
duplicate of the 
fi rst layer’s frames 
and paste them in 
a layer above 
everything else, 
then we move 
them six frames 
to the right again 
and play back 
the sequence.

9
Once your movie is complete, export it from Flash as separate PNG fi les. Go to 
File>Export Movie and select PNG in the ‘Save as type’ dropdown. How big 

you want the graphic to appear in the scene will affect how high a resolution you 
should use. Select appropriately and export to a folder. We’re using PNGs because 
they compress well and use alpha channels.

3
In Premiere 2.0, use the HDV 1080i settings with a 16:9 
aspect ratio. Once your footage has been captured and is 

on the timeline, select the bits of footage you’re happiest with 
and export them, dragging the Work Bar to the start and end 
points of the footage and going to File>Export. 

4
We’re now going to use a codec called Huffy. It’s free to 
download – just do a search for HuffyUV in Google and 

download it from the most appropriate source. Install it and 
you’ll then have the option to export using this compressor. 
HuffyUV is a fast, lossless Win32 video codec. ‘Lossless’ means 
that the output from the decompressor is bit-for-bit identical 
with the original input to the compressor. ‘Fast’ means a 
compression throughput of up to 38 megabytes per second on 
an 416 MHz Celeron. Use the HD Anamorphic 1080 (1.333) 
settings to keep everything at 16:9. Use the maximum bit 
depth and tick the Deinterlace footage option. Hit OK, set a 
suitable folder to render to, and render.

Part 2: Using HDV
Capture your footage in Premiere and load it into After Effects…

5
Open After Effects and choose your 
project setting. Use the HDV 

1080/25 preset with a 16:9 aspect ratio 
then set the length of your composition 
and hit OK. Go to File>Import, select the 
footage fi le and hit OK. Right-click 
(Ctrl-click on a Mac) on it in the project 
window and select ‘interpret footage’. 
A dialog box will appear, in which you 
should select ‘lower fi elds fi rst’ from the 
Fields dropdown.
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Part 3: Lighting the footage
Lens fl are effects can look good. Here’s how to animate one into your scene…

1
Drag your footage onto the 
timeline in After Effects. Now you 

can use the application to create a fi lm 
grade. Your footage should already look 
quite good because you’re dealing with 
HDV, but you can make it even better. 
Duplicate your layer and Right-click or 
Ctrl-click on it in the timeline then go 
to Blending Mode>Soft Light. This will 
give you a little more defi nition to the 
overall look.

2
Try adding a lens fl are to give the 
footage a nice gradient of light. 

Add in a solid layer (Layer>New>Solid) 
and call it Lens Flare. On the timeline, 
Right-click or Ctrl-click on the footage 
and select Effect> Generate>Lens Flare. 
Here, we’ve used the 35mm prime 
preset from the Lens Type dropdown. 
Position the lens fl are using the Flare 
Centre option as it would be within the 
scene – click on the icon and then click 
on your footage at the point where you 
think the source might be.

3
The Flare Brightness has been set to 
193 per cent. We don’t want the 

lens fl are to be too obvious – we just 
want a nice gradient pool of light. You 
can achieve this result by selecting the 
layer and increasing its scale to 200 per 
cent. You then need to animate the fl are 
to coincide with the footage, so go to 
frame 1 and click on the Lens Flare 
clock icon next to Flare Centre – a 
keyframe will be added in at this point. 
Go to the end of the footage and use 
the Flare Centre tool to re-select where 
you think the fl are should be. The lens 
fl are will now alter its position between 
the two keyframes. 

1
First, select the layer you want to track in the timeline. 
From the top menus, select Animation>Track Motion. 

After Effects will automatically open the Tracker Controls panel 
if it’s not already open, and the selected layer will be displayed 
under Motion Source. A new track will be created and its 
name will be displayed in the Tracker Controls panel for the 
Current Track. Click Edit Target, and choose the footage that 
you want to inherit the movement displayed in the source 
footage. Select Position and Rotation as well as Translation – in 
this case, we want to track the full range of camera movement 
as the camera moves back through the scene. 

2
We only track a selected range of footage because the 
TV screen fi lls the entire shot for about the fi rst 40 frames 

and we want to see the room in its entirety. Defi ne the work 
area you wish to track in the Layers panel by setting the 
in-point and out-point, then move the time indicator to the 
fi rst frame on which the tracking should begin.

3
The last step before you can begin feature tracking is to 
position the trackers over the features you want to track. 

These need to be as individual and as contrasting as possible. 
In this instance, we tracked the corner of the TV because it 
provided a sharp black edge against a white background. Pay 
particular attention to which features you decide to track: they 
should be as distinctive as possible, such as the corners of 
buildings, and they shouldn’t disappear behind any other 
objects in the movie, or trackers will fail. 

4
Animate the fl are so it fl ickers. Go to frame 1 and click on the clock icon next to 
Flare Brightness, move slightly further forward on the timeline and increase the 

Brightness slightly. Move forward a couple of frames and take it down, then repeat 
this for fi ve or six keyframes. Select all your keyframes, and copy and paste duplicates 
on the timeline. Move these further along the timeline, and repeat until you have a 
random set of keyframes across the sequence. Play it back and tweak if necessary.

Part 4: Tracking functions
Match the movement of the camera by using the built-in tracking functions in After Effects…  
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4
Expand the White Solid layer’s properties on the timeline and you’ll see a 
Material Options dropdown. Make sure that Accept Shadows is turned on. 

Now select your logo layers, and ensure Cast Shadows is turned on. Check the 
preview in the project window, and adjust the position of your light if necessary so 
that you can see the shadow being cast on the Solid. Go back to White 
Solid>Material Options and turn off Accept Lights. You’ll now be back to having a 
bright white solid with a shadow. Set the White Solid’s blending properties to 
Multiply and watch the solid disappear with only the shadow left.

1
You should now have some camera 
data that’s emulating your footage. 

Next, you need to import your logo so it 
looks like it’s ‘in the scene’. In After 
Effects, import the PNGs you’ve created 
(File>Import>File), locate the fi rst PNG, 
tick the box that says PNG Sequence 
and hit OK. Your footage will now be 
in your project with a transparent 
background. Drag your footage onto 
the timeline and click on the ‘3D layer’ 
icon represented by a 3D box. Your 
footage will now be visible by your 
Composition camera – if you switch to 
‘2 Views’ in the Composition screen, 
you’ll be able to see better what’s going 
on. Select one screen as your Active 
Camera and one screen as a Top View 
so that you can see what your camera 
is doing in 3D space.

2
In the top window, roll over your logo object and when 
it says ‘Z’, drag it around to see your logo moving 

backward and forward within the 3D environment created 
within After Effects. In this instance, we’ve created a shadow 
for the logo. To do this you need to add a light to the scene 
(Layer>New>Light) and then create a fl oor for it to cast 
shadows on to. Simply create a solid layer (Layer>New>Solid).

3
Make sure 
the solid layer 

is white, so that 
once a shadow hits 
it you can select 
Multiply as the 
layer’s blending 
mode and be left 
with just the 
shadow. Make the 
solid a 3D layer by 
clicking its 3D icon 
and then adjusting 
its X Rotation 
value. This would 
ordinarily be 90 
degrees for a fl at 
surface, but 
adjust it until 
you’re happy.

4
Click the Analyse Forward button in the Tracker Controls panel to begin the 
feature tracking. Pay careful attention to the position of the trackers ensuring 

they’re sticking to the feature you wish to track. If the markers slip off the feature, 
press the stop button and correct the problem by moving the tracker back into the 
correct position. You might need to increase the size of the search area – this is the 
outermost box of the tracker – to include a greater movement range. If you fi nd 
that the tracker is having diffi culties sticking to an object, you may need to pick a 
different feature to track, one that is in a higher contrasting area of your movie.

5
Once After Effects has analysed the movement of the 
features, and you’re satisfi ed with the position of the 

attached tracker throughout the footage, click the Apply 
button on the Tracker Controls panel. This will then create 
keyframes for the layer you’ve selected under Edit Target. If 
you’re only tracking position, you can choose to constrain the 
motion to the x or y axis. The layer to which you’ve applied 
the motion should appear to stick to the source layer.

6
If you want to add a camera 
into After Effects to match the 

movement you’ve just captured, you 
can do so by simply copying the 
keyframes generated by the feature 
tracker, selecting the camera’s Rotation 
and Position parameters, and pasting in 
the appropriate keyframes. 

Part 5: Working in 3D 
Add your logo and some additional graphics to your footage in After Effects…
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Working in 3D continued...

5
You can use 
the same 

technique that 
we’ve just outlined 
to add some 
graphics into the 
scene. In this 
instance, we’ve 
created a water 
ripple graphic in 
Flash simply by 
Shape Tweening 
a circle with an 
outline of 10 
through 10 frames 
to a circle 600 per 
cent bigger with 
an outline of 0.5. 
Export this as 
you’ve done with 
your logo and 
import it into the 
timeline in Flash.

6
We drop this graphic on the timeline, adjust its X Rotation again to give it a 3D 
appearance and set its blending mode to Overlay. What we want to do here is 

mask out part of it so it looks like it goes under/behind the TV. We select our 
Rectangular Mask tool from the toolbar at the top of our scene and draw a square 
around the television onto our graphics layer. We then use the Mask Feather, Shape 
and Expansion properties to get it just right, and these can also be animated over time.

1
We’re featuring just two credits at the end of this video, 
but they need to be a fl uid part of the end sequence. 

With this in mind, we’re going to treat them in the same way 
as the logo. First, we lay out our credits in Flash. Then we 
divide the elements onto separate layers. We Shape Tween the 
black line in and Motion Tween everything else using a slightly 
fl ickery, low-fi  feel.

2
We import the credit as we did the 
logo, making sure it’s a 3D layer in 

After Effects. Our camera is moving 
backwards, so we position the two 
credits further in front of the logo in the 
order that we wish to view them, so that 
our camera pans back through them as 
they appear. As the credits appear, we 
want the logo to disappear so that the 
aesthetic doesn’t become confusing 
and hard to read. We do this by 
incorporating one of our splat graphics. 
It animates on and off and, at its peak, 
completely obscures the Deluka logo. 
At this point we turn off the Deluka logo 
layer, so once the splat has animated out 
it has disappeared. This gives us a nice 
fl uid transition between the two.

3
Now we use a great plug-in from 
a company that produces some of 

the best plug-ins for After Effects – 
Trapcode (www.trapcode.com). This 
plug-in is called 3dStroke and it enables 
you to create realistic looking animatable 
lines in 3D space. It can also be used in 
combination with other plug-ins, such 
as Shine and Starglow, to produce some 
interesting effects. First, we create a new 
solid layer in After Effects and name it 
3dStroke. With the plug-in installed we 
Right-click (Ctrl-click on the Mac) on our 
layer in the timeline and select Effects>
Trapcode>3dStroke. We then select the 
Pen tool and draw a line on the screen.

4
In the Effects 
window we 

scroll down to 
Camera>Camera 
Comp and tick the 
box. This uses our 
active camera to 
display 3dStroke. In 
the Taper dropdown 
we tick Enable, then 
in the Transform 
dropdown we 
adjust the X rotation 
and position it until 
it sits where we 
want it to.

Part 6: The credits
In the fi nal section, we create our end credits and animate some wire effects…
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6
We repeat these steps using 
slightly different lines staggered 

throughout the animation. It’s possible 
to adjust the line’s structure by selecting 
the layer it’s on, and dragging the nodes 
on the vector with the Arrow tool until 
they become different. We can also 
radically alter the look of the lines by 
going to the Transform dropdown and 
upping the Bend value – this means the 
line looks like it’s sweeping up and over 
your other objects.  ca p

BACKGROUND:
Matthew Clugston received a BA Hons in 
Negotiated Studies at UCE. He is Creative Director 
of Clusta Limited, a studio he set up in 1997. The 
company works across a number of disciplines: 
web, new media, print, branding, 3D, motion 
graphics and animation. 
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AS A CREATIVE:
Twelve.
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DMC Records, Pacha London, Creation Financial 
Services, Graduart, InTheDetail, Style Birmingham, 
University of Central England and Type3.
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“WeDesignWeCreateWeBuild. YouLove.”
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www.clusta.com  

Left: An illustration commissioned by the Midlands lifestyle 

magazine City Living to promote a competition Clusta 

ran to win a website.

Below: This graphic was created as an identity for bespoke 

furniture creators InTheDetail (www.inthedetail.co.uk). The 

image includes a selection of extrusions from the company’s 

furniture designs, which were then multiplied along paths. 

Expert profi le: Matthew Clugston
Clusta’s Matthew Clugston runs a multi-discipline studio in Birmingham, where he’s as happy working with illustration as with motion graphics…
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5
We move to the frame where we 
want the line’s animation to begin, 

and hit the clock icons next to Start and 
End on the 3dStroke Effects panel. We 
set them both to zero, move along the 
timeline and set the End value to 100. 
We go a little further along the timeline 
and set the Start value to 100, then we 
play back and watch our line animate.
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