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Tutorial

[ill
ustra

tio
n] Julian House, www.intro-uk.com

Why follow the crowd and use MySpace for your band’s 
website when you can create something better and easier 
to manage with Photoshop and GoLive? 
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C
reating a MySpace page for your band is 
as easy as falling off a log, but the diffi culty 
is making it look good. MySpace is 
notorious for its unwieldy code and sparse 

CSS hooks, creating an uphill battle for anyone who 
wants their site to stand out from the crowd. By all 
means have a MySpace page for your band (it is, after 
all, seen as an increasingly important way to give your 
music some exposure), but if you want to be different 
and have a good-looking, easy-to-manage site to boot 
then the only thing to do is to build it yourself. 

If you’re fairly comfortable with HTML, you may want 
to manage news updates yourself, but if you’re handing 
the design off to someone less technical, you can look at 
blogging software to act as a content management 
system. If you’re an Adobe GoLive user, CS2 contains 
ready-made templates for the TypePad service, as well 
as Movable Type servers. Integrating a blog into your 
design can’t compete with MySpace for simplicity, but 
you’ll end up with a site that’s fully under your control. 

Sadly, Adobe’s support for Movable Type and 
TypePad is patchy, with no mention of it at all in 

GoLive’s help menu. If things aren’t working as 
expected, it’s tough to fi gure out what the problem is. 
Dreamweaver enables you to install the Movable 
Type/HTML Editor extensions suite from http://
dreamweaver-mt.sourceforge.net, but this can only 
be used in code view, making the GoLive solution 
marginally better. 

Entrepreneurs and open source developers have 
made once troublesome issues, such as adding video, 
simplicity itself. Upload a video to YouTube, grab the 
embed tags from the site and paste it into your HTML 
and your band’s video is available to anyone who visits 
your site (and YouTube, of course).  

Look to Flickr to host your photos, who again 
usefully provide all the HTML code to add the images 
to your site. It’s also a relatively painless process to set 
up a PayPal account to handle the shopping cart side 
of things for selling CDs and band T-shirts. 

By using your website as a melting pot of available 
technologies, you get all the fl exibility you could want 
without the technical or bandwidth headaches you 
might expect.

Expertise provided by Jason Arber, Founder of Pixelsurgeon (www.pixelsurgeon.
com) and Creative Director at design and media agency Children of Finland (www.
childrenoffi ndland.com).
 

You’ll fi nd the Electro Crotch logo and a PSD fi le of the fi ctional website home 
page on the Computer Arts Projects CD88 in the Disc Content\Tutorials\
Tutorial Files\Music website folder.
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Smart Objects are 
containers in which 
you can embed 
raster or vector 
image data, such as 
a logo from an 
Illustrator fi le. The 
embedded data 
retains its original 
characteristics and 
remains fully 
editable and you 
can scale, rotate 
and warp layers 
non-destructively 
in Photoshop. You 
can also apply 
transformations to 
Smart Objects as 
well as layer styles, 
opacity, blend 
modes and warps. 

Smart objects 
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PayPal (www.paypal.
com) offers a simple 
shopping cart 
solution that can be 
added to your site 
so that visitors can 
buy merchandise. 
Setting up an 
account involves 
PayPal making a 
couple of small 
deposits into your 
bank account that 
you must confi rm, 
which may take 
several days. After 
that, you can start 
adding Buy Now 
buttons to your site. 

Shopping cart

Part 1: Designing the site
Start by using Photoshop to build your band’s website template…

1
As with any design, it’s always best 
to have a clear idea of the design 

before you start and there’s no better 
starting point than a pen and paper. 
Even a rough layout will show you what 
works and what doesn’t and ensures 
that you don’t forget anything.

2
Once you’re happy with your 
rough, it’s time to fi re up Adobe 

Photoshop. Create a new document 
(File>New...) with a width of 1024 
pixels and a height of 768 pixels – the 
base monitor dimensions most of your 
visitors are likely to have – and set the 
resolution to 72 pixels/inch. Make sure 
the Colour Profi le is sRGB, the colour 
space of the internet.

3
Although some people will still be 
using 800x600 screens to view 

your site, it’s safe to assume that the 
vast majority of your potential audience 
will have 1024x768 or above. However, 
browser chrome will eat into this space, 
so the design will have to be narrower 
than that. Ensure that your design has a 
maximum width of 950 pixels.

4
In Adobe Illustrator, open the 
Electro Crotch logo (electrocrotch_

logo.ai) from the Computer Arts Projects 
CD88. We’ll be doing the colouring of 
the logo within Photoshop so there’s no 
need to change the colour in Illustrator. 
For now, simply copy the logo 
(Edit>Copy) from the disc.

 

5
When pasting the logo into Photoshop, you should be 
presented with four options. Choose Smart Object, which 

pastes a rough preview onto the page which can be resized 
and rotated before being rendered. Smart objects can be 
resized at any point without losing quality. Create a clipping 
mask above the logo (Layer>Create Clipping Mask) and use 
vibrant pinks and oranges to fi ll the logo. 

6
It’s time to block in the basic elements on the page, such 
as the main photograph and the navigation using simple 

rectangles created with the Marquee tool or the Rectangle 
tool. This is so you can be sure that all the elements will sit 
nicely on the page before spending too long designing them.

 

7
Once you’re happy with the size and position of the 
blocked in elements, you can start creating the actual 

designs. Some items, such as the photographs, can use the 
block rectangles by using clipping masks, while others, such 
as the navigation, will replace the blocks completely.  

8
The home 
page, with 

its simple news 
layout, should 
be easy and 
straightforward 
to do. Break the 
page into several 
paragraphs, 
complete with a 
date stamp and 
subject. Other 
text-heavy pages 
will follow the 
same format. For 
video pages, we’ll 
be using YouTube, 
so use an image 
from the site for 
the video player.

9
For the Buy Music page, you need to create a layout that 
includes details of the physical CD or music download for 

sale and a Buy Now button. PayPal allows you to design your 
own button, but other shopping cart software may have 
restrictions (see margin note). 
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Part 2: The build 
Use XHTML and CSS within Adobe GoLive to build the site’s basic structure…

1
Use GoLive’s Site Creation Wizard to create a new 
website (File>New...). This keeps all your fi les together for 

easy editing and uploading. Choose Blank Site and click the 
next button to specify your site’s name, location, FTP details 
and whether or not to use Version Control (if there’s only you 
working on the site, you probably don’t need Version Control).

2
You should end up with a main site window that splits all 
the local fi les that are based on your computer on one 

side and the server on the other. It’s possible to skip the FTP 
details, adding them at a later point, in which case the right-
hand side will be blank.

3
GoLive has usefully created an index.html page for you 
and a basic external CSS document. Opening the CSS 

document reveals a selection of basic tags that can be edited 
straight away. Choose the body tag and give the background 
a new colour based on an Eyedropper selection from the 
Photoshop document.

4
You can specify the font family and font colour with the 
body tag. With the basic.css document still open, click the 

‘A’ symbol and choose white from the Colour dropdown 
menu. Choose Arial from the Font Family dropdown menu at 
the bottom of the palette. You can preview the effects your 
choices have in the Inspector palette.

5
Save the basic.css document and open the index.html fi le. 
You should notice immediately that it has inherited the 

background colour you specifi ed in Step 3. Typing a short 
phrase will demonstrate too that the text is formatted in the 
style you created in the previous step. This is because GoLive 
has automatically linked the CSS document to the HTML page, 
saving you a couple of steps.

6
Save the logo out from within Photoshop by cropping 
the fi le and exporting the image as a PNG via 

Photoshop’s Save for Web functionality (File>Save for Web...). 
8-bit PNGs are a better solution than GIFs because they 
generally compress to much smaller sizes.

7
Back in Adobe GoLive, drag two image icons from the 
toolbar into the document. It doesn’t matter if the images 

are above or below the text because we’ll position them using 
CSS demonstrating what is known as Semantic Layout, which 
divorces the underlying content from its presentation.

 

8
Click on one of the image icons, which should be listed as (EmptyReference!) in 
the Inspector palette. Use one of GoLive’s cool little tricks to rectify this. Click 

the tiny spiral icon next to the fi le name in the Inspector palette and drag it to the 
fi le you want to associate with it in the Site window.

9
Once you’ve done this for the logo 
and the main photo, swap to the 

Source view on the index.html page and 
wrap and pair of Divs around the 
images. Give each Div a unique, 
descriptive name, like this: <div 
id=”logo”><img src=”logo.png” /></
div> and <div id=”mainphoto”><img 
src=”photo.jpg” /></div>.
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A short time ago, 
embedding video 
into your website 
was fraught with 
diffi culties, such as 
deciding which 
format to use. A 
popular video could 
burn through your 
available bandwidth 
leaving your website 
unavailable. Thanks 
to YouTube (www.
youtube.com), and 
similar services 
such as MetaCafe 
(www.metacafe.
com) it’s now simple 
to embed videos 
hosted on their 
sites into yours: 
you get all the 
benefi ts without 
the bandwidth 
headaches. 

Adding video 
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11
Saving the CSS fi le and fl ipping 
back to the layout mode shows 

that the images have now snapped to 
their new positions. The text (“Hello 
World”) appears to have vanished, but 
it’s actually underneath the logo graphic. 
We’ll return to the text later, but fi rst we 
need to look at the background.

10
Open the basic.css fi le and click the 
Source view and add your two new 

Divs, giving them a position attribute of 
Absolute (which fi xes them to the page), 
then a top and left value to place it 
specifi cally. You can get the positions by 
measuring the Photoshop template: 
#logo { position: absolute; top: 0; left: 0; }
#mainphoto  { position: absolute; top: 
196px; left: 70px; }

12
The background currently has a 
fl at colour, but we’d like a darker 

strip to go down the middle of the page. 
All we need is a 1-pixel-high strip saved 
as a PNG. Returning to the basic.css 
page, click the body tag followed by the 
icon for Background Properties. In the 
Image dropdown choose URL and link 
the background PNG. In the Repeat 
dropdown select the Repeat Y option. 
This repeats the 1-pixel-high tile along 
the Y axis.

13
In the design, the photo had a thick pink border at the 
bottom of the image. We could use a graphic for this 

or include it as part of the image, but to save fi le size and 
for maximum fl exibility we can create a class. In the 
basic.css page, click the Create New CSS Statement button 
and choose New Class Style. In the Border and Outline 
properties section, create a 17-pixel, pink, solid border along 
the bottom and save the fi le.

14
In the source view, the new pink border is easy to apply with a simple 
class=”bigphotoborder” within the img tag. While you’re there, slap a Div tag 

around the text with an ID tag so that you start to position and style it: <div 
id=”copy”><p>Hello World!</p></div>

15
In the basic.css page, create a new ID: #copy with an Absolute position and top and left coordinates. 
Include a 22-pixel-high, pink, solid border along the top and save. The text should now spring into 

position and have a thick pink rule above it. Specify a width of 425 pixels for the copy Div to make the pink 
rule that length. For the navigation, create PNGs for each menu item in both normal and rollover states. 
Name the rollover PNGs with -over at the end, such as home-over.png. GoLive knows that when you drag 
an image fi le that has a companion fi le named “-over” that it should use that graphic as the rollover state.  

16
Group the nav image fi les into four separate Divs that are tall enough so the 
images sit on top of each other within a single Div. To ensure that the sub-Divs 

sit next to each other create a class, whose only attribute is Float: Left. Apply to the 
sub-Divs: <div class=”fl oat”>

17
You can’t always see the borders of your Divs, but you can apply temporary 
ones with CSS so you ensure everything is positioned as expected. Test your 

page in as many browsers as you can, including Internet Explorer on a PC. When 
you’re happy, you can use the index page as the basis for other pages within the site.
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Part 3: Adding media
Time to add video, a shopping cart and TypePad integration…

Movable Type is a 
weblog publishing 
system from Six 
Apart (www.
sixapart.com), 
which requires the 
user to install it on 
their server. If the 
thought of messing 
around with servers 
makes you feel 
light-headed, you 
may want to 
consider Six 
Apart’s hosted 
offering, TypePad. 
TypePad shares 
many of the features 
and APIs of its 
more complex 
cousin, but is 
marketed at non-
technical users. 

Blogging 

software

Tutorial Explosive music websites

1
You can add a music video to your site by simply 
creating an account with YouTube, uploading your 

video in Divx format then going to your YouTube page and 
copying the supplied code found in the Embed section of 
‘About This Video’.

2
Back in GoLive, copy the code where you would like the 
video to appear in your site. It’s important that you do 

this in the source view and not in the layout view, because 
pasting code in the latter won’t work. Once you’ve inserted 
the code, you can swap to layout mode and carry on working.

3
Preview the page in your web browser to ensure that it 
works as expected. The YouTube video is in .FLV format 

and requires the most recent versions of the Flash player to 
work. This is the most popular web plug-in, so the vast majority 
of your visitors will be able to see your video with no problems.

4
Adding a shopping cart with PayPal is simplicity itself. 
You need to specify a URL that visitors land on when the 

transaction is complete and then you can fi ll in the details of 
the item for sale in the PayPal Shopping Cart page in the 
Merchant Tools section of the PayPal site.

5
Once you’ve fi lled in all the details, PayPal generates 
custom code for you to insert into your website. This is 

essentially a simple form with pre-baked variables and so 
should work in virtually every web browser. PayPal even 
generates a View Basket button if you need it.

6
As with Step 2 above, you must 
paste the code into your site in 

source view. Preview your page to 
ensure it works. PayPal’s default buttons 
are not very inspiring, but you can go 
back to PayPal and use your own button 
designs, should you wish.

7
If you want to use Movable Type or TypePad on your site, 
you need to create a blog template in GoLive (File> 

New...>Page Samples (Blog)>Bubble). This creates a page with 
all the necessary hooks into Six Apart’s blogging APIs. Click OK.

8
The resulting 
page looks 

completely unlike 
your current 
design. However, 
if you’re confi dent 
with your HTML 
skills, it’s possible 
to reskin the page 
using your existing 
basic.css and a 
touch of manual 
adjustment so that 
it matches your 
existing design.

9
Once the 
page’s look 

and feel matches 
your site, use the 
default Movable 
Type sections or 
add your own 
using Special> 
Insert>TypePad 
Blog. For more on 
Six Apart’s blogs 
and Movable 
Type’s APIs see 
www.sixapart.
com.  ca p
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