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Tutorial [illustration] Chris Ashmore, www.studiospooky.tv

Design a graphic-
rich website 
The HTML shackles have come off and you now have the 
freedom to design creatively rich web pages in Photoshop…

Expertise provided by Paul Wyatt. Wyatt is the Head 
of Design for Lycos and produces web, animated and 
print work. Find out more at www.paulwyatt.co.uk.

You’ll fi nd the layered Photoshop CS2 document 
containing the completed web animation on the 
Computer Arts Projects CD91 in the DiscContent\
Tutorials\Tutorial Files\Website folder.

W
eb design has changed. Spliced and 
diced images in tables and cells? Oh, 
that’s very last century… With the arrival 
of CSS and absolute positioning, the 

designer’s creativity has been set free to create 
inspiring and enticing graphical websites. 

Photoshop CS2 is the perfect tool of choice to 
help you build these sites. From creating your layouts 
to exporting with the great ‘Save for web’ optimisation 
feature, Photoshop is king for starting your website 
designs – ones that are no longer restricted to the 
dull old HTML table.

We’re going to create such a site. It’s called Blush 
and is run by a group of artists, fashion designers and 
textile makers. It’s a consortium of creative guys and 
gals who produce rich and colourful designs and 
materials and want the world to know more about them. 
The brief is to make their site big, bold and colourful. 

Photoshop is a great tool for meeting website 
design briefs. Mock-ups can be created with minimum 
fuss and switched around easily when elements are 
grouped together in layer sets. Just drag the content 

around in its layer set, or make it invisible and add on 
something new. This fl uid structure is great when 
there’s a deadline to meet and the client wants 
change after change.

A neat trick is to make several output JPEGs 
from your one Photoshop mock-up using several 
arrangements of content. This looks to the client as if 
you’ve created a number of different designs, but it’s 
all come from one master fi le.

The key to this is to keep all your work organised. 
Layer sets in particular can make your life so much 
easier when it comes to making changes to your work. 
Oh, and don’t forget to name your layers as you go. 
Otherwise it’ll drive you mad when you return to your 
work and fi nd you have to go through all your layers. 

In the following tutorial, we’re going to look at 
elements of the Blush website and show you how to 
make a web-friendly background texture and have fun 
with images and bits of thread. Learning to sew in 
Photoshop, animating (using the new Animation 
palette), messing around with textures and a few tips 
will help you excel with your website designs.
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3
Now you can really sell this image 
by compositing real strands of 

fabric (captured via a digital camera or 
scanner) on to the texture and adding a 
low opacity drop shadow on to these to 
accentuate the frayed, worn look. We’ll 
outline how to use this technique in Part 
4 on the opposite page. First, though, 
there’s one problem with our texture…

4
Our texture shows some repeating blemishes, too regular 
to be credible. We’ll use the Patch tool to fi x these. Like 

the Healing brush, this tool copies pixels and textures from one 
source to another. The difference is that the Patch tool enables 
you to defi ne the size of the area that you want to fi x. 

5
With the texture open, click the Patch tool. In the options 
bar at the top of the screen, make sure the tool is set to 

Source. (Confusingly, you can confi gure it to work in two 
exactly opposite ways – setting it to Destination means the 
Patch tool works more like the normal Clone tool, where you 
fi rst select the ‘clean’ pixels to brush on. We’ll do the reverse.) 

CSS enables you to 
position elements 
on top of one 
another in a stack, 
similar to Photoshop 
layers. Most 
animations can be 
exported on 
transparent 
backgrounds. This 
means that only the 
animated content is 
exported. An 
animation can be 
positioned over the 
header graphic 
using CSS and 
absolute positioning.

CSS stacks
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Part 1: Texture and patch
Make a background texture, add some frayed edges and remove unsightly blemishes…

1
Let’s begin with the underlying background texture. 
Create a new document and fi ll it with a mid to dark 

brown colour. Select Filter>Texture>Texturizer. Choose 
Canvas with a Scaling of 131 and a Relief of 5.

2
Select the Eraser and choose an Oil Pastel brush with 
which to erase parts of the canvas. Experiment with 

different sizes and erase areas of the top left-hand corner of 
the fi le. Erase in a painterly style to give this the proper ‘frayed 
edges’ effect. Vary the Eraser size to add to this effect.

Part 2: Header graphics
Create some graphic elements to represent the client’s home cities…

6
Now drag inside your image to defi ne the area you want 
to fi x, plus a bit of a margin. Here, we select a blemish on 

our sack cloth (plus a bit), then drag the tool to an unblemished 
area. Release the mouse button, and the blemish vanishes.

1
For the 
stylised 

Eiffel Tower 
graphic, we 
duplicated the 
original image 
layer. On this 
layer, we applied 
Film Grain and 
the Sharpen fi lter, 
then dropped the 
opacity back to 
76 per cent. We 
fl attened the fi le, 
and adjusted 
the Hue and 
Saturation to 
reduce the 
colour saturation. 

2
The header images were cut out 
using the Pen tool and reduced in 

scale to fi t. The trick is to use the Linear 
Burn blending mode. This will give you 
an effective overlay on the textured 
background, making the graphics appear 
stitched on. We’ll show you how to add 
real threads in Part 4 opposite.

3
We treated the factory graphic in the same way. However, for this the chimneys 
were copied to make a row of them that sit under the logo. We’ll use this later 

to animate threads of smoke extending from the chimneys to the logo.
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4
Now select 
the path 

you’ve created in 
the Paths palette, 
choose a colour 
to stroke the path 
with, and use the 
Stroke Path button 
to stroke the path 
with your new 
brush. You should 
now have a nicely 
imperfect row of 
stitches in your 
chosen colour.

5
Select the 
photographic 

layer and choose 
the same path you 
used to create 
your stitches. Ctrl-
click the layer (on 
Mac, Cmnd-click) 
to turn it into a 
selection. Invert 
this selection and 
hit Delete. Select 
the Stitch layer 
and double-click 
the layer to bring 
up Layer Styles. 
Add a Pillow 
Emboss fi lter with 
a 5-pixel strength.

6
Use a type layer for the logo and turn it into a selection. 
In the Paths palette, select ‘Make work path’. Delete the 

type layer and create a new one. Ctrl-click the path (Cmnd-
click on Mac) to make it a selection and stroke with your red 
V brush. Create a new layer and use the same selection, but 
use a small black chalk brush for the stroke.

Part 3: Stitch it up
Continue the textured theme by creating some stitching effects in Photoshop… 

1
First you need to create a custom brush to form the stitch 
shape. Do this by drawing a V shape with the Pen tool 

and stroke the path using the Stroke Path button at the 
bottom of the Paths palette. Use a 3-pixel round hard brush.

2
Now to turn this shape into a brush. Make a rectangular 
marquee around the V brush stroke, choose Edit>Defi ne 

brush, then name the brush. In Brushes>Brush Presets, select 
Brush Tip Shape and change the spacing to 100 per cent. This 
makes the V shapes touch one another. In Shape Dynamics, 
set Angle Jitter to 3 per cent and Control to Direction. 

3
In one of 
your image 

fi les, choose the 
Pen tool to draw 
a path around 
your picture. Start 
ten pixels within 
the image, and 
make sure you’re 
not too precise 
about it because it 
needs to look as if 
it’s been done by 
hand. Don’t close 
the path – instead, 
veer it off slightly. 
Later, we’ll add 
some real thread 
to this area.

Part 4: Real strands 
Composite real strands and pins to add depth to the composition…

1
The strands of thread that are added to the Eiffel Tower 
and other parts of the image really boost the overall 

effect. We photographed several cotton thread strands, along 
with a needle, and then composited them into the artwork. 
Use the Marquee tool to select the isolated thread image and 
copy this into a new image. 

2
Use the Magic Wand to remove the unwanted 
background. Then use the Feather tool at a very low 

setting to smooth the edge and hit Delete. Copy this layer into 
your original fi le. Position and scale your image. Use the Hue/
Saturation tool in Colorise mode and adjust until you get a 
colour that matches that of your stitches. 

3
Next, we want to give the effect of the needle piercing 
the photograph. For this, select a small section of the 

Eiffel Tower photo and overlay this on top of the pin. Use the 
Eraser tool or Feather tool to soften the edges and the Burn 
tool to darken the area over the needle. This will give it a 
slightly raised, 3D look, as if the needle is underneath it.
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The Blush website 
is a fully graphical 
textured site. It’s put 
together with clever 
HTML and image 
tiling – the 
background texture 
is a repeating tile 
image. From your 
Photoshop design, 
you’d export a 
smaller image of 
just the frayed 
edges. These would 
then be overlaid via 
CSS on to parts of 
the tiled image. This 
makes it look like a 
complete image 
with frayed corners.

Tiling tricks  
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Part 5: Animation
Create smoking threads with the new CS2 animation tool…

1
Photoshop CS2 now comes with a lot of the animation 
functionality of ImageReady built into the regular 

interface. Open the animation.psd fi le from the Website folder 
on the CD. Select Window>Animation. This brings up the 
Animation palette. If you’ve already used ImageReady in the 
past, this feature will be familiar to you because it works in 
exactly the same manner.

2
You simply create a frame-by-frame animation in this 
palette. Begin by duplicating a frame, then in the new 

frame change a layer or the position of an object within a 
layer. Duplicate this frame and then make another change, and 
so on. Then you need to assign a time duration for each layer 
and click Play to see your frame-by-frame animation run. 

4
Click the fi rst frame of your 
animation to start from scratch, 

then click ‘Duplicate Selected Frame’ in 
the Animation palette. Select the layer to 
animate. If you chose the layer purple1 
and made it visible, move to frame two. 
Deselect this frame and make purple2 
visible. Do the same in frame three. Hit 
Play and the threads will look as though 
they’re drifting upwards.

5
Each frame can be set a duration time limit. Click the 
arrow next to the 0.0 Seconds text. This will display 

a dropdown menu with a number of time durations for that 
layer. You can also create your own duration limit using the 
Other option in the same menu.

6
In Looping Options you can select how many loops your 
animation does. Choose from Once, Forever or Other. In 

Other you can customise this amount. Think carefully about 
this. An animation that loops continuously can be annoying on 
a web page. It’s probably best to have it loop only a few times.

3
In animation.psd, twirl down the Header Container layer 
set. Do the same with Smoke. You’ll see a number of 

layers – some visible, some not. Click each successive 
animation frame and you’ll see these layers drop in and out of 
visibility. Those selected are visible in the animation, those that 
aren’t are not shown in the Layers palette. 

7
Tweening 
simplifi es 

the creation of 
animations. It 
creates the frames 
in-between two 
keyframes. If you 
had a ball in the 
top left of your 
layer in frame one, 
then moved it to 
the bottom right 
in the end frame, 
tweening would 
create all the in-
between frames 
for you.

8
In the Animation palette, select the frames to tween. 
Select your fi rst and end frames and click the Tween 

button. A dialog box will appear that gives you the option of 
tweening with the next or previous frame, as well as enabling 
you to select the number of Tween frames to add, which layers 
to use and the animation parameters.

9
You can view your fi nal animation 
by hitting the Play button or 

clicking ‘Preview in browser’. The 
animation will then be shown in your 
default web browser, along with the 
generated HTML.
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6
The fi nal site 
sits within a 

grey border, which 
gives it added 
defi nition and a 
more structured 
framework. This 
acts as a container 
for the more 
textured, graphical 
elements that are 
contained within 
it. To fi nish, we 
added the main 
navigation, 
keeping it clean 
and simple.  

CS2 gives you more 
creative freedom by 
enabling you to try 
out a number of 
scaling options 
without setting them 
in stone. Access the 
Layers sub-menu 
and choose ‘Group 
into Smart Objects’. 
Scale down the 
layer and see if that 
suits. If not, scale it 
up to see what that’s 
like. The original 
quality will be 
maintained as long 
as you don’t scale 
up beyond the 
original size (doing 
this will cause the 
image to degrade).

Scaling
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4
We overlaid the site text in HTML 
over semi-transparent yellow 

background PNG graphics. These tile to 
the size of the div containing the text in 
the HTML. The result is a cool effect with 
the background showing through.

5
Fabric layers and illustrations give 
the impression of the ‘real world’ 

creative. These are textured on to the 
design by using blending modes such as 
Overlay and Multiply. Experiment with 
these to get the right look.

1
Create a new document measuring 
800x600 pixels. Create a patterned 

layer and shaped it into the left-hand 
wall using the Perspective tool. Scale a 
coloured layer down to make the back 
wall. You can overlay an appropriate 
pattern using the Multiply blending 
mode – this is an effective way to knock 
out the white background.

2
A Soft Omni light adds depth. Go 
to Filter>Render>Lighting Effects. 

Choose a Soft Omni directional light. 
Settings are: Intensity 53, Gloss 79, 
Material Plastic –60, Exposure –54 and 
Ambient 29. The directional arrow 
should be pulled to the bottom-left 
corner. Apply the effect, fl atten the fi le, 
move to your master fi le and rescale.

3
Our dummies 
are scanned 

photos of models, 
traced using the 
Pen tool and fi lled 
with a colour. Scan 
or photograph 
textures to apply 
to them. Make 
each dummy into 
a selection which 
the texture fi les 
can be ‘pasted 
into’. A mask is 
then created and 
the textures can 
be rescaled to suit.

1
If you want to save the animation 
as an animated GIF fi le, select 

File>Edit in ImageReady. In ImageReady, 
you can alter the optimisation levels in 
the Optimise panel. When you’re 
happy, select File>Save Optimised As. 
Choose the GIF’s destination and name 
it. Save as GIF Only and with the 
settings on Custom.

2
From ImageReady, you can also 
save your fi le as a QuickTime movie 

by clicking File>Export and then Original 
Document. In the ‘Save As Type’ 
dropdown menu, choose QuickTime 
Movie. Click the Down arrow of the 
compression codec. Usually, the default 
Photo-JPEG option is fi ne. Click OK to 
save the fi le.

3
Save as an 
SWF fi le 

by clicking on 
File>Export and 
then selecting 
‘Macromedia Flash 
SWF’. In the 
dialog box, click 
the Preserve 
Appearance check 
box. This enables 
you to retain the 
appearance of text 
and shape layers 
that can’t be 
rendered natively 
to the SWF 
format. Finally, 
choose an ‘SWF 
bgcolor’ and 
‘Generate HTML’. 
You can then save 
your fi le. 

Part 6: Exporting your animations 
GIF, QuickTime or Macromedia Flash, the choice is yours…

Part 7: Textured room
Dress dummies, add light, text, fabric and a container to hold them all in…
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BACKGROUND:
Paul Wyatt is the Head of 
Design for Lycos. He runs the 
design team and produces web, 
animation and print work for 
Lycos and its many partners and 
clients. He also does a bit of 
website and design judging. 
“I’ve worked with Jakob Nielsen 
on ITV’s Who’s London project 
and on the Daily Mail with its 
property awards,” says Paul. “I’m 
also a motion graphics designer 
and have produced animated 
creative for TV and web.”

YEARS PRACTISING AS 
A CREATIVE:
Ten.

CLIENTS:
Sony/BMG, BBC, 2 Entertain, 
Fremantle, Canal +, Fox, 
Universal, and Contender 
Entertainment Group.

MISSION STATEMENT:
“To design great, energetic, 
enticing, fun and downright 
brilliant creative work that both 
appeals and entertains.”

WEBSITE: 
www.paulwyatt.co.uk

Expert profi le: Paul Wyatt
As head of design at Lycos, Paul Wyatt is well qualifi ed to give website design tips…

Above: The iconic show The Avengers is back on DVD early 

next year. With a brilliant restoration job, this 60s classic 

looks better than ever. “I worked with 2 Entertain on creating 

a teaser trailer for this release,” says Wyatt. “It was created 

using Photoshop, Flash, After Effects and Cinema 4D.”

Top: Televise is a band whose website has just been 

relaunched. “For this, I created animated site headers using 

the Televise logo and coloured strands that animate in twists 

and turns around the site header.” 

Right: “I created an animated sting for a great cartoon called 

Combat Wombat,” says Paul. This independent project by 

Cartoon Network animator Tom Baker was produced in After 

Effects, Photoshop and Cinema 4D. View the whole cartoon at 

www.bakeranimator.com.
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